Jump to content

Stargazers Lounge Uses Cookies

Like most websites, SGL uses cookies in order to deliver a secure, personalised service, to provide social media functions and to analyse our traffic. Continued use of SGL indicates your acceptance of our cookie policy.

Chris Willocks

Slight Focusing Issue in SG Pro

Recommended Posts

Hi everyone,

I've been doing some deep sky imaging over the past few nights of Sh2-132 in narrowband with my FSQ-85 and Atik 383L, however my focusing in SG Pro has been hit and miss.

Usually, my focusing is spot on and I've never had any issues up to now. The first night of imaging Sh2-132, my focusing was also perfect. However, yesterday and tonight, I keep getting a message after running auto focus in SG Pro, stating that the HFR is outside the expected value (not by much mind).

The curve looks absolutely fine i.e. a V curve and I've physically checked my Lakeside focus motor, to see if there are any issues, but everything seems fine. I've tried different exposure times, binning, step sizes and I still get the message.

Having said all of the above, the full moon is out and the weather has been quite windy over the past few nights. So, I don't think the seeing is particularly great as a result.

Is it normal to have slight focusing difficulties when the seeing is poor? The lowest HFR I'm getting is still in the 1-2 range and the images aren't that out of focus. I've just never seen this before.

Hopefully someone has experienced something similar?

Many thanks,

Chris

Share this post


Link to post
Share on other sites

I experienced this myself the other night, an identical scenario and I am in South Australia. I have just refitted my camera after some repair work and was trying to test it and just could not get focus. I tried several objects across the sky and gave up in the end. 

I then tried to upgrade to the latest version of SGP and discovered I did not have the correct updates and am currently waiting to retest after updating all the relevant software. Will post when I get a chance to test, probably next week.

Glad to see I was not alone.

Share this post


Link to post
Share on other sites

Thanks for the reply. Good to know someone else having the same issue.

Although, I am using an older version of SG Pro (V3.0.3.165), as I can't upgrade my PrimaLuceLab Eagle PC to a newer version of Windows 10 because I don't have administrative rights apparently. So, the newer versions of SG Pro aren't supported on my PC, unless I can find a way to upgrade Windows.

But, I've been using this version of SG Pro for a year or so up to now and not had any issues up to now, so I think that it's seeing related, but I could be wrong.

There was one occasion tonight where I didn't get the HFR message when running auto focus.

Chris

Share this post


Link to post
Share on other sites

If you are getting a good V curve then everything should be OK I'd have thought.  If you are concerned then you could double-check by ensuring you have good focus with a Bhatinov mask and comparing the HFR of the resultant image with the same target / camera settings using auto focus.

  • Like 1

Share this post


Link to post
Share on other sites

Yes, mine was an older version of SGP as well. I would have thought that updates to the system like dot NET would go ahead anyway regardless.

Anyway, my obs is 60 km away so it isn't easy to put a mask on the scope, I rely on my software to be set up and function properly. I use remote utilities to control the imaging computer. Special trip next week coming up.

Share this post


Link to post
Share on other sites

The 'HFR being outside the expected value' message can be a sign of the backlash compensation being insufficient. Is the first segment of the focusing V curve more horizontal compared to the second segment. If so when the final check image is taken by SGP it will not be at the bottom of the V curve causing the error message. The grub screws attaching the focus motor to the focus shaft can work loose causing increased backlash.

Alan

  • Like 1

Share this post


Link to post
Share on other sites
4 hours ago, symmetal said:

The 'HFR being outside the expected value' message can be a sign of the backlash compensation being insufficient. Is the first segment of the focusing V curve more horizontal compared to the second segment. If so when the final check image is taken by SGP it will not be at the bottom of the V curve causing the error message. The grub screws attaching the focus motor to the focus shaft can work loose causing increased backlash.

Alan

Hi Alan,

The first part of the curve is slightly flatter, however I've physically checked the grub screws on my Lakeside focus motor and they are tight.

I don't have any backlash compensation enabled for the motor in SGPro, as I've never had any requirement to in the two years I've had it, up to now i.e. I've never had this message before.

I'll give it a try anyway. What would be a good backlash compensation value to use for the Lakeside motor?

Chris

Edited by Chris Willocks

Share this post


Link to post
Share on other sites

I get that message when the seeing is poor. I never get it when the seeing is average or better.

I am running the very latest beta version of SGP and Windows 10 in completely up to date.

I usually just tell it to return to the previous focus point and accept that its not perfect focus but its slightly irrelevant as the seeing is so poor.

Share this post


Link to post
Share on other sites
1 hour ago, Chris Willocks said:

Hi Alan,

The first part of the curve is slightly flatter, however I've physically checked the grub screws on my Lakeside focus motor and they are tight.

I don't have any backlash compensation enabled for the motor in SGPro, as I've never had any requirement to in the two years I've had it, up to now i.e. I've never had this message before.

I'll give it a try anyway. What would be a good backlash compensation value to use for the Lakeside motor?

Chris

There will always be backlash present as the lakeside motor system is geared down quite a bit. It's always best to eliminate it if possible. It can be set in the lakeside unit itself by its utility prog, or using the buttons on the unit, but it's easier to let SGP do it as it's easier to change. With my two lakeside focusers I use a backlash setting of 30, and set it to always work on inwards travel so that the focuser always reaches its completed position by an inwards movement against gravity. Setting the compensation too high doesn't really matter, it just means the focuser travels further back and forth each time it compensates.

As your first curve segment is only slightly flatter on the V curve a, setting of 20 may be fine. If the first segment is then the same or slightly steeper than the second segment then your compensation is good and hopefully your final focus position will actually be at the bottom of the V curve and you won't get the error message.

I can't remember as to whether compensation is enabled by default on the lakeside unit itself and set to some value. If you're going to set it by SGP it's probably best to check it's disabled in the lakeside controller so that the two systems don't try to do the same job.

Alan

Edited by symmetal

Share this post


Link to post
Share on other sites
9 minutes ago, symmetal said:

As your first curve segment is only slightly flatter on the V curve a, setting of 20 may be fine. If the first segment is then the same or slightly steeper than the second segment then your compensation is good and hopefully your final focus position will actually be at the bottom of the V curve and you won't get the error message.

Alan

The correct backlash can vary quite a bit depending on how you have the Lakeside setup.  Easiest thing to do IMO is to look at the first, flatter part of the graph.  The vertical lines on the graph should be the step size you've set in SGP and so you can count the number of data points where the curve is a bit flat, multiply this by your step size and that gives you a decent starting point for backlash compensation.  Worth adding a bit to that to be safe; as @symmetal says set the backlash to IN and it's better to have too much compensation rather than not enough.  For info, I need to set my backlash to 150 and my step size is 35...

I had no joy setting the backlash via the Lakeside ASCOM driver or the control box for some reason but worked fine when set in SGP.

 

Share this post


Link to post
Share on other sites

All good advice above, you will have some backlash so add some in the settings in SGP.

Further to this, I'm not an early adopter and have stayed clear of the betas but followed their progress on the SGP forum.

They recently released 3.1.... as stable and my last two sessions have been with the new version.  I can only say that I'm seeing the best focusing I've ever seen in SGP, it's more robust and more aware / tolerant of of outliers. I'm also imaging with an FSQ85 and Lakeside focus motor btw.

Edited by Starflyer

Share this post


Link to post
Share on other sites

Sorry for the late reply everyone. Thanks for the advice. 

It's all sorted now. I think the issue was that I updated SGPro on my PC and in doing so, it removed my equipment profile, in which I forgot to put the focuser backlash parameters back in that I had before.

I set the compensation to 100 steps in and it's perfect now. As Starflyer said; the auto focus in the new version of SGPro is significantly better.

Chris

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.