Jump to content

stargazine_ep44_banner.thumb.jpg.6153c4d39ed5a64b7d8af2d3d6061f61.jpg

EQMOD Port Error


Recommended Posts

Last night I couldn't guide in PHD, there was one instance of EQmod open in APT for the mount, but PHD failed with a port error when a second instance of EQmod was opened by PHD for mount.  I did notice that if the mount was connected in PHD then it failed in APT.  Any advice pls.

Edited by dtastro
  • Like 1
Link to post
Share on other sites

Hi,

Now then I had this issue sometime back and I am sure I have cured it.

I think I searched this forum and found another thread with similar issues and a reply by  @Anthonyexmouth  said as above but when I looked into it APT was already set to run in Administrator mode, so that set me thinking and checked PHD2 which was not set to run in Administrator mode, when I did set it then it all worked. So I was very grateful for this suggestion as it led me to get it all working 🙂 

Some weeks later I bought a new computer to run my Astro stuff and when I set those programs I wondered what would happen if I made sure no programs were set run in Administrator mode and hey presto all worked perfectly. 

So I am no computer Guru by any means but it makes sense that if you set a program to run in Administrator mode then any other interacting with it or using the same application that it is linked to (by opening it from within that application) also needs to be in the same mode, because even programs opened by that will also be running in Administrator mode. But I tend to think unless there is a reason it has to run in Administrator mode then don't .

Sorry for the ramble, that's just normal for me 🙂

This was my thread by the way just so you can see if it is the same issue.

how-to-connect-apt-and-phd-to-mount-solved-i-think

Steve

Edited by teoria_del_big_bang
Link to post
Share on other sites

Its ALWAYS a bad move to run everything as Administrator, outside of testing, as it will introduce other errors, some of which may not be noticeable....  

As all the software we use, has been written with standard user privileges in mind, therefore check your user account has full access to all the software, and that no application security permissions have been amended.

  • Like 1
  • Thanks 1
Link to post
Share on other sites
8 minutes ago, teoria_del_big_bang said:

Hi,

Now then I had this issue sometime back and I am sure I have cured it.

I think I searched this forum and found another thread with similar issues and a reply by  @Anthonyexmouth  said as above but when I looked into it APT was already set to run in Administrator mode, so that set me thinking and checked PHD2 which was not set to run in Administrator mode, when I did set it then it all worked. So I was very grateful for this suggestion as it led me to get it all working 🙂 

Some weeks later I bought a new computer to run my Astro stuff and when I set those programs I wondered what would happen if I made sure no programs were set run in Administrator mode and hey presto all worked perfectly. 

So I am no computer Guru by any means but it makes sense that if you set a program to run in Administrator mode then any other interacting with it or using the same application that it is linked to (by opening it from within that application) also needs to be in the same mode, because even programs opened by that will also be running in Administrator mode. But I tend to think unless there is a reason it has to run in Administrator mode then don't .

Sorry for the ramble, that's just normal for me 🙂

This was my thread by the way just so you can see if it is the same issue.

how-to-connect-apt-and-phd-to-mount-solved-i-think

Steve

Is there any way to set the shortcut to make sure it's in admin mode when opened?

  • Like 1
Link to post
Share on other sites

Yes if you right click the shortcut:

image.png.6015160739d3381f5f93d9de8ac3762f.png

Click "Properties"

Then under the "Compatability" tab check the "Run as Administrator" checkbox"

image.png.562716f6b2b901022ab5b44d7907a06b.png

The click OK or Apply.

BUT as I said I think a better way is to check all other programs you are using are NOT set to run as administrator and it should then work as well.

So do the same as above for PHD2, APT, and all your EQMOD stuff and I bet you find one of them, or more, has the checkbox ticked so just deselect it on all of them.

Steve

Link to post
Share on other sites
3 minutes ago, teoria_del_big_bang said:

Yes if you right click the shortcut:

image.png.6015160739d3381f5f93d9de8ac3762f.png

Click "Properties"

Then under the "Compatability" tab check the "Run as Administrator" checkbox"

image.png.562716f6b2b901022ab5b44d7907a06b.png

The click OK or Apply.

BUT as I said I think a better way is to check all other programs you are using are NOT set to run as administrator and it should then work as well.

So do the same as above for PHD2, APT, and all your EQMOD stuff and I bet you find one of them, or more, has the checkbox ticked so just deselect it on all of them.

Steve

Thanks will check them all later.

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. By using this site, you agree to our Terms of Use.