Jump to content

sgl_imaging_challenge_2021_annual.thumb.jpg.3fc34f695a81b16210333189a3162ac7.jpg

ASCOM? EQMOD? EQASCOM? ASCOMPAD?


Recommended Posts

Hi all,

So, I'm trying to get to grips with connecting up my laptop to my SkyWatcher 130p Synscan GoTo mount. This is probably a familiar story to many of you.

A few months ago I got it working quickly and easily with Stellarium, just use the plugin and slew to object. However, I couldn't work out how to have a simple 'nudge' feature that way, ie some sort of keypad window that let me slew very slightly to get  an object dead centre. I know that within Stellarium I can move the view slightly and slew to centre, but I'd prefer a keypad-type feature, it just seems more intuitive.

I fiddled around with ASCOM and EQMOD and somehow got an ASCOMPAD utility that looked promising. However, it would only work with east/west slewing, not north/south. Odddddd. I invested in the official SkyWatcher USB cable and still no joy. Then I noticed another larger keypad with a 'Stop'button in the middle. If I clicked the direction arrows on that, no response from the mount. However, If I clicked the 'Stop' button, the first keypad worked. Oddddddd, again. Not ideal, but sort of a rough and ready way to get this to work. However recently, for some reason, that doesn't work any more. I have to click Stop every time before using north/south. Very oddddddddddddddddddddddddd.

So I decided to bite the bullet, instead of installing stuff I didn't really understand and getting it to work partially, I decided to uninstall it all, work out what I should be doing, ideally using ASCOM so that I have a good foundation for adding stuff as I go along, and start from scratch.

I've installed the ASCOM platform, and I'm now desperately, desperately trying to figure my way through the instructions at both http://www.atm-workshop.com/synscan-pc-connect.html and https://www.lightvortexastronomy.com/tutorial-setting-up-an-equatorial-mount-on-ascom-with-eqmod-stellarium-and-cartes-du-ciel.html# They're well-meant and very comprehensive, but I'm lost at page two of both!

Progress so far: I try to download EQMOD from https://sourceforge.net/projects/eq-mod/files/ but the latest download on the page seems to be ASCOMPAD. Don't understand. Find what looks like EQMOD, run it, click the Register button, get an error. Don't understand. Uninstall it. Go to the Yahoo Group at https://groups.yahoo.com/neo/groups/EQMOD/info but I have to register to download the files. Done, but how long do I wait now? I've shouted at the cat but she doesn't want to help.

I should add that I have a degree in IT, used to be a programmer, have built my own PCs in the past, have worked as a technical author, and am pretty tech-savvy. But after two hours of this, I have to admit I am completely and utterly confused. I understand drivers, software and hardware but this seems such a fragmented environment, I'm far from clear what I should be downloading or running.

Can someone point me to a resource that quite literally lists the steps for getting what I want? I just want to align the SkyWatcher mount with the handset in situ (I find it easier that way), which is connected to my laptop via the USB cable, then after alignment, go inside and drive it via Stellarium, but also have some sort of keypad window, or something that works off the numeric keypad on the laptop, for fine adjustments so I can centre the object in my camera. I'd like to do this via ASCOM because I have a strong feeling it'll be a good foundation for adding kit in future.

Any advice? I'm sure lots of people have asked this question before but I've looked through the forum and there seem to be lots of bits of info here and there, just no single resource that is succinct and easy to understand. Apologies if this is annoyingly basic,

Thanks

Brendan

Link to comment
Share on other sites

So I figured out why I got an error message when registering the mount with EQMOD - I had to run the toolbox with admin rights in Windows 10.

So I'm back to how I was before. I'm running Cartes du Ciel this time, because it seems to loom large in most people's instructions, have connected up the scope, and the funky little hand control is back. I can go east/west, and for a few seconds just now the north/south worked too, but it's stopped again.

If this worked, it would be exactly what I want. I'm starting to wonder whether there's a problem with my scope. The handset controls work fine, but north/south does not work on the hand control.

Any ideas?

Link to comment
Share on other sites

Thanks, that's exactly the point I'm up to. The small handset control is appearing, and it controls the mount when I click west and east, but not north and south.

Also, whereas CdC shows where the scope is pointing, if I select a target object and click Slew, it doesn't slew.

I've run the ASCOM diagnostics, it says there are some fails but I do not understand the log files.

I'm going to try Stellarium again but I have a strong feeling I'll be back where I started ie with the small ASCOM handset working with west/east but not north/south.

 

 

Link to comment
Share on other sites

OK, bit more diagnostic/fiddling/scratching of head.

Situation is this:

* In CdC, the software handset control (ie as distinct from the Synscan hardware unit) lets me go west and east full pelt

* HOWEVER, when I click north or south, I just discovered, it IS actually slewing the mount - but always very very slowly, always down, always for about five seconds then stops. 

* I installed ASCOMPAD to see if I could get back to where I was before. I can: if I run ASCOMPAD, none of the controls on ASCOMPAD work. However, when I click 'Stop' in the middle of ASCOMPAD's keypad, the other software handset control works perfectly.

* If I then go back into CdC and reconnect the scope, the north/south works once or maybe twice, then goes back to the strange crawling-south-for-five-seconds mode.

I should add that this is completely replicated with both my USB/serial converters ie the cheapo one I first bought, then the SkyWatcher official one that cost about five times as much in the hope this would fix it, which it hasn't.

So I don't know why north/south is doing this on the software handset control when in CdC. Any ideas? Any/all suggestions welcome.

Edited by BrendanC
Link to comment
Share on other sites

... and after more fiddling, this is the situation:

* ASCOMPAD open only (ie no astro software): west/east software hand control works, north/south does the strange crawling thing. Click Stop on ASCOMPAD's keypad, and north/south work fine. Is this an ASCOM conflict?

* In CdC: if I open ASCOMPAD before connecting in CdC, north/south behaves exactly as above on the software hand control. If I then close ASCOMPAD and connect in CdC, north/south don't work unless I turn off tracking. They then work, but tracking is immediately switched on again! Is this a tracking conflict?

* In Stellarium, while the scope is connected, ASCOMPAD is grayed out, which strongly implies Stellarium controls the scope while ASCOM cannot. If I disconnect it, ASCOMPAD behaves as above.

So there seems to be something conflicting with the north/south software hand control which might be due to ASCOM, or might be something to do with tracking.

If anyone has experienced anything like this it would be great if you could let me know your thoughts. I realise this has been a bit of a whine and I've been posting while investigating, so no worries if not. I think I'll give up for a bit, have a cup of tea and cherry tart, then think about this some more later. Main thing is, it seems I did have things set up properly first time around because after an entire morning with this, and after being careful to try and understand what I'm doing, I'm back to where I started!

Link to comment
Share on other sites

Which version of the ASCOM Skywatcher mount driver are you using. V6.06262.1573 appears to be the most current version and I think I replicated the same problem. I can slew L/R using the small ASCOM  on-screen H?C but not U/D. Using an old Celestron driver (5.0.30) which I have used for a long time with my SW mounts I get full control in all directions with the on-screen HC. Select Nexstar 5I and AltAz as the mount type.

Celestron(5.0.30)Setup.exe

Link to comment
Share on other sites

Thanks, I'm using v6.0.6262.15273, which seems to be the latest on https://skywatcher.com/download/software/ascom-driver/ and https://ascom-standards.org/Downloads/ScopeDrivers.htm

I downloaded and installed your drivers and selected NexStar 5I. I can connect it in CdC  but the software hand control does not appear at all.

Another new discovery: if I just switch on the mount and don't go through alignment, up/down works perfectly, even with tracking turned on in CdC. If I do set it up, I'm back to the weird up/down thing again. This could tally with the idea that there's some sort of conflict between the scope being locked onto something, and the manual up/down setting.

Thanks for the suggestion though, really appreciate it. I might play around with other drivers to see if I get anywhere.

Link to comment
Share on other sites

... and now I've sort of got EQMOD to work, but I keep getting the dreaded timeout message when connecting to the COM port. All drivers updated, several uninstalls and reinstalls. This is driving me bonkers. I'm going to give up for a bit.

Link to comment
Share on other sites

Yep. I'm only checking out EQMOD because I can't get the other approaches to work!

I'd be happy not using it. All I want is to align outside, go inside, use planetarium software to find objects, and then have some sort of software keypad to fine-tune an object to the centre of the camera. Whatever I use just doesn't quite work as I want it. Any/all advice appreciated!

Link to comment
Share on other sites

Decided to leave this one on ice for now. Seriously considering just getting around the problem by using the StarWatcher app instead, which means either updating the handheld hardware or buying the wifi upgrade.

Link to comment
Share on other sites

  • 2 weeks later...

Thought I would tie this one off - I finally sorted it.

I noticed that Sharpcap recognised my mount via the Ascom drivers, so I can control it exactly as I want from within Sharpcap. Get aligned manually, centre the image on the viewfinder, then I can fine-tune and centre on the computer screen.

All controls work fine, only bugbear is that if I turn tracking off, it turns it back on a few seconds later for some reason.

So, out with alternative drivers, EQMOD and even the ASCOMPAD, it really is just a case of installing the ASCOM platform and the ASCOM Skywatcher drivers. Which it should have been to begin with, but wasn't.

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. By using this site, you agree to our Terms of Use.