Jump to content

Stargazers Lounge Uses Cookies

Like most websites, SGL uses cookies in order to deliver a secure, personalised service, to provide social media functions and to analyse our traffic. Continued use of SGL indicates your acceptance of our cookie policy.

Sign in to follow this  

PHD2 disconnects ZWO ASI 120MM Mini

Recommended Posts

Hi All!

I have guiding problem with the following guider setup: 9x50 finder + ZWO ASI 120mm mini + PHD2.
The imaging scope is a 6' newtonian + canon dslr on a HEQ5, driven by a laptop via diy EQDIR cable.
When the mount is set up and running correctly, polar aligned and all... I connect the guider camera
and mount with phd2. All nice and easy, I run a calibration, then it starts to guide. All seems ok.

Then I am starting to take pictures. The first seems OK, then the second have the star trails...
I check phd2 and there is a message: the camera (ASI) did not take a picture for "xy" seconds so it is disconnected.
Grrr.... I reconnect try to set up a longer period for "xy" in the settings as mentioned in the message.
And all the same again and again. Whatever I add for connection timeout for the camera, it just reaches that
and disconnect the camera.
PHD + philips toucam has worked for me flowlessly. I changed to PHD2 because I gave myself a birthday present,
the little ZWO camera. (and PHD did not recognize it)
Do you have any idea what can be the problem? I will contact PHD2 help also, but maybe somebody had already
the same problem and figured out how to overcome. I am almost sure I make some dumb mistake in the PHD2
software settings, however I tried to change only what was needed.

Share this post

Link to post
Share on other sites


Check the power management for your USB devices/ports and disable power saving for them. Maybe it's because of this.

Share this post

Link to post
Share on other sites

Here are some things to try:

Make sure you are using the latest version of PHD2 ( 2.6.6 dev 1)

Try using the 'other' driver for the ASI120 mini (there are 2 ASCOM drivers and a ZWO native driver - can't remember at the moment which gives the better results, so swapping and seeing may be a good idea)

Try switching from 16 bit to 8 bit images

Post your PHD2 guide and debug logs over on the PHD guiding forum 

If you are connecting via a USB 3 port, switch to a USB 2 one


Share this post

Link to post
Share on other sites

Thanks for the quick help! Will try all (one by one) and give a feedback.

Share this post

Link to post
Share on other sites

Tonight I had the chance to give it a try. I disabled the usb power saving first, but I could not even start looping in PHD2. I started to worry, but as I chose the ZWO camera driver (not the ascom ZWO) everything went as a charm. Thanks again for the help!!!

Share this post

Link to post
Share on other sites

I too was getting mysterious disconnects during imaging sessions. In PHD2 an error message against the guide camera (ZWO ASI120MM) would say something like "An image has not been acquired after 17 seconds so the camera has been disconnected..retrying". Sometimes it would reconnect successfully other times the imaging camera (ASI183) would error in APT saying "waiting 30 seconds for download from camera".

I found that PHD2 would acquire whatever ZWO camera would respond regardless of whether it was already connected. They were both using ZWO ASCOM drivers.

After pulling my hair out over the last couple of days with my rig I am now using the ZWO native driver for the ZWO ASI120MM mini guide camera and the ZWO ASCOM driver for my ZWO ASI183. It seems to have settled down now 🤞.

It is so much easier with a DSLR 😁


Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Tom Shinal
      Can Nebulosity and Ph.D operate simultaneously and share a single camera. Running Win 10.
    • By Forunke
      Ok, so this is a really annoying bug / problem that I have with my setup:
      From time to time, in non regular intervals the image my guiding cam (ZWO ASI120) send seems to get flipped / mirrored or looks like it's from a completely different patch of sky.
      When I'm paying attention to the guide images I can clearly see that the image seems to be flipped in some way.
      It only happens for 1 frame PHD send a warning ( No star found / Star lost Mass changed) and after that everything is fine again. My gear is all connected to a single USB3 Hub which then runs via powered USB3 cable to my Pc.
      I'm not binning and have the noise reduction off (though PHD might got hickups while processing) but it still happens. Sometimes there are minutes between two events sometimes it happens 5 times in a row.
      It also seems like it's only happening during guiding, I haven't seen it happen during calibration yet...
      I'm completely clueless what's happening or how to get rid of it, any help / idea is greatly appreciated.
    • By Cemers1
      Hi Guys, hoping someone can help me with the guiding issues Iv'e been having. First of all my setup is:
      Explore Scientific ED80 Triplet  Skywatcher EQ5 mount with synscan  Orion mini 50mm guide scope Altair GPCAM2 AR0130 Mono (as the guide camera) I did my polar alignment and 3-star alignment, which was spot on. So I set up the GPCAM2 and opened PHD2 where I selected "Altair Camera" and "On-Camera". It was all in focus, kept it on the default settings and I selected "auto select star", then it said I was guiding (I can hear the mount making small adjustments). A message popped up saying I needed to increase the max RA duration, then I needed to increase the max DEC duration, which I did gradually by 1000ms each time the message appeared. Still no progress.
      So I restarted the process with the max RA and DEC duration as 8000ms and it said I needed to eliminate the source of the problems.
      I'm not sure why it not working and if I'm doing something wrong. But if someone knows where I'm going wrong, or has any advise it will be greatly appreciated!

      Oh and just let me know if you need any more info, because Iv'e probably missed something out. 
      Thanks again ?

    • By thomasv
      I've picked up a second hand Lightrack II recently, so was keen to test it. My plan was to use the guiding assistant in PHD to get a graph of the tracking performance, but initially the mount wouldn't move. After a search, I had to modify the guiding cable that came with the mount, as it was wired up 'the other way' to the one required for QHY5L. After that it calibrated fine and could run the test. Below is a 22min graph of the unguided performance, while it's not within the 2" peak-to-peak quoted, it's still pretty good. 
      Next I've tried it with a canon 300mm lens (unguided again), the picture is a crop of a 10min exposure, slightly eggy, but again pretty happy with that. 

    • By joecoyle
      I've set my scope up on it's pier in my ROR observatory, done a few drift aligns and started to take some images. 
      I've noticed a 'quite' regular dip in my DEC line on several nights. 
      Would anyone be able to have a quick scan of my log and offer any insight?
      Could it be backlash? Could it be something with each rotation of the gears? Faulty tooth? 
      It is quite regular, although not always, and always in the same direction.
      It doesn't seem to be adversely affecting imaging yet, but I've not tried anything too taxing.
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.