Jump to content

Stargazers Lounge Uses Cookies

Like most websites, SGL uses cookies in order to deliver a secure, personalised service, to provide social media functions and to analyse our traffic. Continued use of SGL indicates your acceptance of our cookie policy.


Pi 3 USB GPS/GPSD Start-up troubles

Recommended Posts

Hi All

Been struggling to get the new USB GPS to play ball with the Pi. Manage to manually connect to it and it works with KSTARS but getting it to connect on boot is problematic. I've read heaps of great forum posts on configuring GPSD on boot (using something like below) to modify my /etc/default/gpsd file. Still no joy. Lost a whole night of imaging mucking up drivers and reinstalling everything and now onto about day 3! Running Stellamate OS 1.4.2 and KSTARS 3.3.3. Any pointers welcomed (new to playing with Linux and Pi).




# Default settings for gpsd.

# Please do not edit this file directly - use `dpkg-reconfigure gpsd' to

# change the options.



DEVICES="/dev/ttyUSB0" USBAUTO="true"


Share this post

Link to post
Share on other sites

Without Kstars/Ekos loaded what does gpsmon or xgps client utility say when loaded - you may have to install gpsmon or xgps. The utilities act as GPSD clients so if GPSD is running correctly they will show he correct GPS time/position - note getting a 2d or 3d fix indoors can be very difficult but time normally comes up fast.

Try another test only start up PI without GPS gadget plugged in ,then insert the dongle ( i am assuming USB but you dont say what GPS you are using!) and  start one of the GPSD clients and see what,if any, info you get.

Also "dmesg" is your friend check the output to see if there are any errors with GPSD and/or your dongle

The problems I encounter were to do with "USBAUTO" conflicting with other serial USB devices - hence some people use Udev rules to fix a name - in essence Udev creates a fixed name for the device no matter which port you plug the device in.

As you "pay" for Stellarmate support drop a line to Jasem if you haven't already done so 🙂

Plus did you read this https://www.indilib.org/forum/ekos/3562-can-t-get-gps-dongle-to-work.html

Sorry if you know all this already 🙂



Edited by stash_old

Share this post

Link to post
Share on other sites

cgps works fine after a manual start (along the lines of sudo gpsd /dev/gps -F /var/run/gpsd.sock) so I know the gps is working fine (it is this one https://www.pbtech.co.nz/product/HHAGST0354/GlobalSat-BU-353-S4-Weather-proof-USB-GPS-receiver).

The GPS talks to the Pi which talks to KSTARS (running on the mac via wifi hotspot). The location and time in KSTARS are update from GPS. 

All works fine until the Pi is restarted when gpsd does not run automaticaly (I understand that is the point of the /etc/default/gpsd file and the statement START_DAEMON="true". Just can't get it to work! Work around is to run the gpsd manually each time and everyhting is fine but would be great if I can work out how to do it automatically! 

Next step talk to Stellarmate.

Seen heaps of links and just read the one you posted. Sounds similar problem but I have tried the suggested fix and it hasn't done the trick for me. 

I'll take another look tonight. Maybe a couple more hours and I'll crack it!

Share this post

Link to post
Share on other sites


Don't ask how I did it (I couldn't recreate it lots of forum posts and eventually it worked!)  but it works and that's fine by me. Even managed to get the pi system date and time to read the gps and update. 

Bring on the clouds!

Edited by mbalkham
  • Like 1

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.