Jump to content

Stargazers Lounge Uses Cookies

Like most websites, SGL uses cookies in order to deliver a secure, personalised service, to provide social media functions and to analyse our traffic. Continued use of SGL indicates your acceptance of our cookie policy.

sgl_imaging_challenge_banner_terminator_challenge_winners.thumb.jpg.6becf44442bc7105be59da91b2bee295.jpg

Saj_37uk

Skywatcher 2" Extension Tube - Low Profile

Recommended Posts

Posted (edited)

Looking for the 2" low profile extension tube that is provided with most of the skywatcher scopes. I have a used 190MN that didn't come with the extension tube and need it to get accurate focus. 

 

I believe Orion scopes may have one too.

Edited by Saj_37uk

Share this post


Link to post
Share on other sites

What does this look like, I have a couple of skywatcher extensions that appear to be 2" at one end and slightly larger at the other, do you have a pic. of what you are after.

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Mark Daniels
      Been looking for neat solution to taking small scope abroad using my stuff and not paying out for a dedicated set up. 
      Have a skywatcher finder which with a barlow and 90 * gives good results. I was looking at an Orion mini eq tabletop tripod but hard to get hold of. 
      Play a bit of music in a band and have a few microphone stands so got to work with a hack saw. 
      I used a mic holder as in photo they are about £3 and cut the holder part off and filed flat. Drilled hole through to accept large camera thread (£3 screw bolt)
      this allows shortened micstand to fit to the alt az mount. (Mic stand 15 of ebay. )
      the dovetail was expensive as i wanted green and got from germany £30 with couier the white finder bracket from tring harrisons £6
      so thats £60 but if i went for black dovetail less than £40  seeing i had mic stand already quite a cheap solition
      the stand is very stable and provided the telescope is moved clockwise when rotating freehand the threads stay tight  with the fine controls either direction works well
      overall wiegt is bit over 3 kg and will fit in a standard aluminium camera case 
      hope this if useful 
      Mark👍
       







    • By starcorral
      My club's Atlas is stuck on the date 11/13/2099.   Last night was 6/28/2019.  Every time I reset the date and started the 3 star alignment the scope chose Vega and then pointed to the western sky - sorta wonky.  When I tried a second star it aimed at a totally wrong part of the sky.  I went back to date and it had reset to the11/13/2099 date.  The mount has a working GPS module.   I went through all the menus and there was no place other than the " sub menu to attempt to replace the errant date.  After five tries I gave up.   Apparently the GPS was accurate to withing a stride or two.  What should I try next?   I know my club; they'd rather stuff it in a corner than take the time or money to fix it.  So it will be m time and my money.  I used the mount several times this year and had no problem.
    • By Lachlan
      Hi everyone, 
      as the title suggests, I've noticed that the RA axis of my HEQ5 pro mount has some give. I don't notice it while the clutch is unlocked, but it's very obvious with a locked RA clutch. Any suggestions on what could be causing it/what adjustments need to be made? 
      Thanks 
    • By Bellatrix2
      Greetings,
      I'm super happy to have found this forum of night sky enthusiasts and look forward to learning and sharing on this site! I am an amateur stargazer fortunate to live in a rural area with great dark skies. I'm used to using a GoTo Celestron.
      Unfortunately I'm having a problem with a newly purchased Orion SkyQuest XTg 10. 
      I've only used it a couple of times. Recently, when I turn on the power, the hand controller (a SynScan V4 GoTo, version 04.39.04) states a message "Both axes...no response!" which means the motors won't work. 
      I've unplugged all the cords & replugged to no avail. The power comes from a new Orion Dynamo Pro, 12 V, Lithium Power Supply which was recommended.
      Does anyone have any ideas what the problem might be?
      Thank you 🌟
    • By ruskclark
      This is a recent edit of data I collected back in January. Image is taken with a Canon 450Da and Canon EF L 70-200mm f/2.8 lens sitting on a Sky-Watcher Star Adventurer. It’s quite a large crop from a 200mm frame. 25 x 3 min guided subs. Stacked in SiriL and processed in Photoshop. Image taken in Northumberland under Bortle 3 skies. 

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.