Jump to content

Stargazers Lounge Uses Cookies

Like most websites, SGL uses cookies in order to deliver a secure, personalised service, to provide social media functions and to analyse our traffic. Continued use of SGL indicates your acceptance of our cookie policy.

sgl_imaging_challenge_banner_terminator_challenge_winners.thumb.jpg.6becf44442bc7105be59da91b2bee295.jpg

Prolifics

PHd2 Guiding Mount selection.

Recommended Posts

Posted (edited)

Hi wondered if anyone could help.

I have an old EQ6 Pro mount. There is no ascom driver or sywatcher eq6 mount in the selection in phd2. I have downloaded the skywatcher eq6 drivers from ascom for telescopes and mounts but it just tries to uninstall drivers when I run the setup program everytime i run it. I tried rebooting the pc between installations.

These are the only options I get in the mount selection only the Gpint options connect.

Everything else works fine via eqmod and all my other software. I have disconnected all my connectons in all software and tried PHD2 on its own.

 

image.thumb.png.c1a742019afe66278f324b520e7b2612.png

 

Here is the install screen of the skywatcher eq6 driver from ascom. Even after a computer restart it will do the same thing if I trya nd reinstall again.

 

image.thumb.png.6d2670c24d46e61bb377f94279a459dc.png

 

 

Edited by Prolifics

Share this post


Link to post
Share on other sites

I have connected the telephone type socket cable for st4 guiding between the altair Gpcam and the mount autoguider port. PHD2 now allows me to connect to the ON-Camera option. I hope this will work.

I have also configured my eqmod driver to ST4 guiding instead of Ascom Pulseguiding. Any advice would be appreciated.

 

Regards

Share this post


Link to post
Share on other sites

One thought, if you are updating any drivers, then older ones are un-installed, which is what you are seeing.... also have you installed the EQMod drivers & system ? (http://eq-mod.sourceforge.net/)

Share this post


Link to post
Share on other sites
17 minutes ago, Dr_Ju_ju said:

One thought, if you are updating any drivers, then older ones are un-installed, which is what you are seeing.... also have you installed the EQMod drivers & system ? (http://eq-mod.sourceforge.net/)

Yes all installed everything working fine except ths problem.

 

Stellarium scope stellarium APT SGP all running at the same time without faults.

Share this post


Link to post
Share on other sites

and SGP is seeing\controlling the EQMod\Ascom mount ok? if so which version of PHD2 are you using ?

Share this post


Link to post
Share on other sites
Just now, Dr_Ju_ju said:

and SGP is seeing\controlling the EQMod\Ascom mount ok? if so which version of PHD2 are you using ?

I'm using version 2.6.6 and mount control is fine,

Share this post


Link to post
Share on other sites

Usually when having connection issues when equipment can have multiple connections, its down to security.... are any of your apps running as Administrator ?? and\or installed as Administrator ?

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

I just ran PHD2 as admin and now i get all these options :) Think it's fixed... Which one should i be using? Heq5/6 as in the rest of my programs?

 

 

image.thumb.png.da25fff4c01e3afb501e2a5c51d2463c.png

Edited by Prolifics

Share this post


Link to post
Share on other sites

Yes, use the "EQMos ASCOM HE5/6"...

Share this post


Link to post
Share on other sites

OK i tried that it says does not support st4 so I canged that back to ascom pulsing now eqmod loads and says this.. Com port is not being used by anything else i am running it alone.

 

image.thumb.png.3c86b72bedae2a86061ed7687a59f99c.png

Share this post


Link to post
Share on other sites

Have you selected the correct COM port in the configuration, i.e.

Setup.jpg

Share this post


Link to post
Share on other sites
2 minutes ago, Dr_Ju_ju said:

Have you selected the correct COM port in the configuration, i.e.

Setup.jpg

Hi yes com3 as it always is just checked it in device manager too. I take it i don't need the telephone connection to by autoguider port anymore as my guide camera is piggy backed to my main cmos camera?

Share this post


Link to post
Share on other sites

If you are using pulse guiding then the ST4 cable isn't required

Share this post


Link to post
Share on other sites
Posted (edited)

Thanks for confirming that. OK i loaded up all my programs in a different order with phd2 last and it now has connected :) Took a few combinations and tries.

 

Still have issues. Everything connects until I connect phd2 and then it disconnects all my other programs. :(

Edited by Prolifics

Share this post


Link to post
Share on other sites

How many other programs are connecting to the mount?

The great thing about com ports is they only like one connection 

if you download and run a separate program called Stallariumscope, this acts as a middleware for all the programs that want to access the mount. You start this program first and it handles all communications. 

Share this post


Link to post
Share on other sites

I'm not sure that my comments here are particularly relevant in your case, but I ran into a problem a few weeks ago with com ports in EQMOD, so it may be worth taking note.

I dare say I'm fairly typical in that I have connected a fair number of different pieces of kit to my laptop (Windows 7) over the years and it hadn't really struck me until recently that Windows remembers that a com port has been assigned previously, so any new hardware gets assigned successively higher com port numbers. I think in my case using 3 or 4 different cameras, filter wheels, focusers etc.  and then  trialling several USB hubs, took the com port assignments up to COM16. Where things went pear shaped for me was the setting the COM port for EQMOD after making some changes. The last COM port that the EQMOD setup routine can address is actually COM16 and my EQDIR (the mount) was assigned to COM17.  It was then necessary to essentially clear out the unused COM ports by editing the registry. I'm now back to single digit com ports for the time being at least. 

As I say ...not sure if this helps you at all...but worth bearing in mind!

Steve

 

Share this post


Link to post
Share on other sites

When using st4 in phd do you not need to select "on camera" as the mount (or something similar)?

Share this post


Link to post
Share on other sites
12 hours ago, SteveA said:

  It was then necessary to essentially clear out the unused COM ports by editing the registry.

Go into Device Manager/COM ports and select Show Hidden Devices in View.

Then click on each unwanted port and Delete.

Michael 

Share this post


Link to post
Share on other sites
On ‎09‎/‎05‎/‎2019 at 11:03, spillage said:

When using st4 in phd do you not need to select "on camera" as the mount (or something similar)?

Yes, 'on camera' is correct for st4 :)

Louise

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.