Jump to content

Stargazers Lounge Uses Cookies

Like most websites, SGL uses cookies in order to deliver a secure, personalised service, to provide social media functions and to analyse our traffic. Continued use of SGL indicates your acceptance of our cookie policy.

sgl_imaging_challenge_banner_beauty_night_skies.thumb.jpg.2711ade15e31d01524e7dc52d15c4217.jpg

Starwiz

ASI1600mm-Pro and APT Gain Settings

Recommended Posts

I'm still trying to get to grips with my ASI1600mm.  In ASICAP, I can set the camera to unity gain 139, but in APT the setting for gain only goes up to a maximum of 100.

So, my question is, what will the actual camera gain be if I set it to 100 in APT?

Thanks

John

  • Like 1

Share this post


Link to post
Share on other sites

Hi there - this seems very odd - I have the same camera and also use APT, and I'm pretty sure the gain can be set higher than 100. I tend to use 139....

My first reaction to your post is that you might not have the right driver selected in APT....to check, click on the "Settings" button next to the camera name at the bottom of the APT screen...then make sure the ASI-1600 is selected specifically from the driver drop down menu in the Ascom screen that pops up.

Personally I tend to set the gain using the Ascom driver (in the same "Settings" pop up) and leave the gain setting blank in APT itself - this is because in my filter wheel setup, I have a different gain associated with each filter and I don't want that overridden by the manual gain setting on the camera screen.

Let me know if you need me to explain the above more clearly...happy to help!

  • Like 2

Share this post


Link to post
Share on other sites
6 hours ago, eshy76 said:

Hi there - this seems very odd - I have the same camera and also use APT, and I'm pretty sure the gain can be set higher than 100. I tend to use 139....

My first reaction to your post is that you might not have the right driver selected in APT....to check, click on the "Settings" button next to the camera name at the bottom of the APT screen...then make sure the ASI-1600 is selected specifically from the driver drop down menu in the Ascom screen that pops up.

Personally I tend to set the gain using the Ascom driver (in the same "Settings" pop up) and leave the gain setting blank in APT itself - this is because in my filter wheel setup, I have a different gain associated with each filter and I don't want that overridden by the manual gain setting on the camera screen.

Let me know if you need me to explain the above more clearly...happy to help!

Many thanks.  As you suggested, I can only think it had selected the guide camera as it works now.  I didn't know that leaving the gain setting blank means it can be overridden so that's useful info.  I've found out how to do it using the APT scripting today, so if that works when I try it, I think I'll be using that method.  It also means I can script in the cooling at the start instead of using the cooling aid.  I forgot to do this this the other night so ended up with all my subs at 14 deg instead of -15, so if it works OK it's helpful to be able to 'set and forget' in advance.

  • Like 1

Share this post


Link to post
Share on other sites

Not used the scripting in APT but I know the gain is selected under the settings tab near where the cooler aid tab is. Don't make the same mistake I did last week. Captured 4 hours of data with a gain of 0 when I thought it was at unity!!

  • Haha 1

Share this post


Link to post
Share on other sites
1 hour ago, Starwiz said:

Many thanks.  As you suggested, I can only think it had selected the guide camera as it works now.  I didn't know that leaving the gain setting blank means it can be overridden so that's useful info.  I've found out how to do it using the APT scripting today, so if that works when I try it, I think I'll be using that method.  It also means I can script in the cooling at the start instead of using the cooling aid.  I forgot to do this this the other night so ended up with all my subs at 14 deg instead of -15, so if it works OK it's helpful to be able to 'set and forget' in advance.

The way it works is that if you put a gain number in the little box on the camera tab, that will override whatever was in the Ascom driver pop up, for a single shot and for an imaging plan - *if* you haven't assigned a gain to each filter in settings.

In APT's settings when you set up your filter wheel, you can add a couple of things per filter which are useful as defaults for every time each filter is used - (1) the focus offset, if you are using autofocus and (2) the gain. So I tend have 139 assigned to LRGB filters and 200 for narrowband filters for example. I then leave the little box on the camera tab blank to make sure it doesn't override the filter wheel settings I put in when an imaging plan starts.  

It works perfectly for me....APT's scripting is pretty powerful...I also used it to platesolve to another target (Goto++) and restart PHD guiding in the same night...worked fine.

Glad it's working for you now!

  • Thanks 1

Share this post


Link to post
Share on other sites
11 minutes ago, david_taurus83 said:

Not used the scripting in APT but I know the gain is selected under the settings tab near where the cooler aid tab is. Don't make the same mistake I did last week. Captured 4 hours of data with a gain of 0 when I thought it was at unity!!

Yep done that one too....one to add to the slapstick astro mess ups...though not as bad as taking 20 mins to realize that the cap was still on my polemaster once...the hot pixels looked like stars on the ipad screen...it took me time to figure out why they weren't moving when I rotated the RA axis....!

  • Haha 2

Share this post


Link to post
Share on other sites
23 hours ago, eshy76 said:

The way it works is that if you put a gain number in the little box on the camera tab, that will override whatever was in the Ascom driver pop up, for a single shot and for an imaging plan - *if* you haven't assigned a gain to each filter in settings.

Any thoughts on why I can't see the gain settings for the filters?

Thanks

John

FilterWheelASCOMSettings.jpg

  • Like 1

Share this post


Link to post
Share on other sites
5 hours ago, Starwiz said:

Any thoughts on why I can't see the gain settings for the filters?

Thanks

John

FilterWheelASCOMSettings.jpg

Hi there - do you have the latest version of APT? I believe the gain per filter was only recently added. I have version 3.63. APT is not updated within the program - you have to download and install the new version over the old one. Settings survive that process!

That would be my best guess.

  • Like 1

Share this post


Link to post
Share on other sites
9 hours ago, eshy76 said:

Hi there - do you have the latest version of APT? I believe the gain per filter was only recently added. I have version 3.63. APT is not updated within the program - you have to download and install the new version over the old one. Settings survive that process!

I'm also on 3.63, so it's probably not that.  What ASCOM version are you running?

Thanks

John

  • Like 1

Share this post


Link to post
Share on other sites
On 01/05/2019 at 08:11, Starwiz said:

I'm still trying to get to grips with my ASI1600mm.  In ASICAP, I can set the camera to unity gain 139, but in APT the setting for gain only goes up to a maximum of 100.

Believe me I am with you all the way as in exactly the same situation with the ZWO1600mm and also using APT. 

I was unaware that you could set different gains in the filter settings dialog of APT and had to use scripts to do it, until I saw this thread.  I too am on V3.63 and if I click on settings for the FW when on the Gear Tab I too get the dialog same as above that does not have any gain settings (I believe this is just the Ascom Dialog APT opens).

FilterWheelASCOMSettings.jpg

But if I go to the "Tools" Tab and click on "Settings" and then click on the "Filter Wheel" "Tab in Settings" I get the following:-

However, I have just seen this so not tried it to see if it works but I guess it should, most things do just seem to work in APT.

image.png.d6767ae10ca7c0bf6f145b2192bbc34b.png

 

I don't know if this helps but I have learnt something today at least ? 

Steve

Share this post


Link to post
Share on other sites
1 hour ago, Starwiz said:

I'm also on 3.63, so it's probably not that.  What ASCOM version are you running?

Thanks

John

Hi there  - I'm on a pretty recent Ascom version, maybe not the latest one....however, the answer is in the post above this one. When I set up my filter wheel, I use APT's settings, not the Ascom settings, so Tools/APT Settings as specified by Steve. That should work.

Share this post


Link to post
Share on other sites
1 hour ago, teoria_del_big_bang said:

Believe me I am with you all the way as in exactly the same situation with the ZWO1600mm and also using APT. 

I was unaware that you could set different gains in the filter settings dialog of APT and had to use scripts to do it, until I saw this thread.  I too am on V3.63 and if I click on settings for the FW when on the Gear Tab I too get the dialog same as above that does not have any gain settings (I believe this is just the Ascom Dialog APT opens).

FilterWheelASCOMSettings.jpg

But if I go to the "Tools" Tab and click on "Settings" and then click on the "Filter Wheel" "Tab in Settings" I get the following:-

However, I have just seen this so not tried it to see if it works but I guess it should, most things do just seem to work in APT.

image.png.d6767ae10ca7c0bf6f145b2192bbc34b.png

 

I don't know if this helps but I have learnt something today at least ? 

Steve

Hi Steve - yes that's exactly it - Tools/APT Settings. Once you plug in figures for gain per filter (and autofocus offsets if applicable) in the dialog in your screenshot, whenever you select the filter in an imaging plan, the same gain/focus offset will be brought into the plan...very convenient once you've settled on what you want to use. 

  • Like 2
  • Thanks 1

Share this post


Link to post
Share on other sites
5 hours ago, eshy76 said:

Hi Steve - yes that's exactly it - Tools/APT Settings. Once you plug in figures for gain per filter (and autofocus offsets if applicable) in the dialog in your screenshot, whenever you select the filter in an imaging plan, the same gain/focus offset will be brought into the plan...very convenient once you've settled on what you want to use. 

Many thanks for the help - it looks like it'll work for me too now.  I've learned a fair bit this week, including the scripting which looks great.

  • Like 2

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.