Jump to content

Stargazers Lounge Uses Cookies

Like most websites, SGL uses cookies in order to deliver a secure, personalised service, to provide social media functions and to analyse our traffic. Continued use of SGL indicates your acceptance of our cookie policy.

sgl_imaging_challenge_banner_lunar_landings.thumb.jpg.b50378d0845690d8a03305a49923eb40.jpg

deafasabat

Enabling OpenGL on Windows 7 laptop

Recommended Posts

Posted (edited)

Hello all, sorry if this is in the wrong section, but not too sure which is the correct one. My Windows 7 laptop has decided to throw it's teddy out of the pram so I have had to resurrect an older laptop, which was Vista but upgraded to Windows 7. Everything on the old laptop is working fine except that I cannot download Stellarium as it tells me it needs Open GL. The old laptop is an Asus F3J and the graphics card is an ATI Mobility Radeon X2300. After a long session Googling it seems that the graphics card supports OpenGI 2.0 (unless I have totally misunderstood things) but how do I enable it?  Most of the websites I have been pointed to seem to be inactive now. So if anyone out there has some info that can help me I would be very grateful. Thanks

 

Chris

Edited by deafasabat

Share this post


Link to post
Share on other sites

I found that old laptops will only run old versions of Stellarium, eg. a Dell D430 would only run Stellarium 0.12 (under Windows XP).

Share this post


Link to post
Share on other sites

From memory, OpenGL is a part of the graphics card's driver package, as long as the graphics card supports OpenGL and you have loaded the latest driver available for that card from the manufacturers website then OpenGL support should be enabled automatically, if not, check in control panel, look for the graphics card's manufacturers icon for the specific card, open the icon and there should be a choice there to enable/disable OpenGL support.

If there is no specific icon for the graphics card this means that Windows is just running with Microsofts generic card driver and that will not include Open GL.

There used to be an issue with Windows 7 if 'Classic' theme was enabled for the desktop, in which case OpenGL is disabled by default. you had to enable Windows 'Aero' theme for OpenGL to be active but I thought they had changed that with service releases before Windows 7 ended it's lifecycle.

William.

  • Like 1

Share this post


Link to post
Share on other sites

Chris,

Go to Stellarium web site and download the current user guide    0.18.3-1   at top right.

http://stellarium.org/en_GB/

Section 2.4 describes running Stellarium under OpenGL, Angle and MESA modes.

After installing Stellarium, Go to Start menu and, if memory is correct, ( because I deleted to options I didn't need!), you'll see a couple of "start" options listed. (GL, Angle and MESA). Run each in turn to see which works best for your setup and then just create a shortcut to launch that particular option of Stellarium.

My Toshiba laptop running Win 7 64bit runs under the Angle mode quite happily. 

Regards,Les

  • Haha 1

Share this post


Link to post
Share on other sites

After upgrading the operating system you need to upgrade drivers for graphics card too.

  • Like 1

Share this post


Link to post
Share on other sites

Thanks folks, particularly Les. It is now working. It's amazing what you can do if you read the manual! I had to use ANGLE mode.

Chris

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.