Jump to content

Stargazers Lounge Uses Cookies

Like most websites, SGL uses cookies in order to deliver a secure, personalised service, to provide social media functions and to analyse our traffic. Continued use of SGL indicates your acceptance of our cookie policy.

sgl_peoples_choice_2018_winners.thumb.jpg.d8ce9c6569dfc2f48814f6d87da46170.jpg

halli

Raspberry Pi 3 Model B+ problem !

Recommended Posts

Hi

 

Bought the latest version of the Raspberry Pi ie Pi 3 Model B+ to fiddle around with Indi and establish a telescope control hub.

Tried to install Ubuntu Mate and it wouldn't boot.  It boots fine with a Raspbian image so hardware and SD card is ok. 

I get  no green light and the red power led flashes 4 times long and 4 times short.  The hdmi video out gets stuck at the rainbow screen with a yellow lightning flash on the RHS.   

I have done some research and this seems to  indicate that the OS is not compatible and cannot progress with the boot code.  It is def the Ubuntu Raspberry Pi image  I downloaded and used Etcher to write to the SD card and this worked fine 

I know Gina has a tutorial for this installation and I am dong the same thing 

Has anyone else come across this issue or can help with a solution please ? - is it related to the Model B+ perhaps ?

Thanks

Ian

 

Share this post


Link to post
Share on other sites

Ian,

Ubuntu Mate 16.04 does not work with the RPI 3b+ out of the box a problem with the kernel Head over to the indi forum a lot discussed about this. I have the same problem with my Rpi.

Regards

Andy

Share this post


Link to post
Share on other sites
11 minutes ago, fozzybear said:

Ian,

Ubuntu Mate 16.04 does not work with the RPI 3b+ out of the box a problem with the kernel Head over to the indi forum a lot discussed about this. I have the same problem with my Rpi.

Regards

Andy

Oh yes it does, it’s 18.04 that has issues...!!

that sounds like a power supply issue, if there is not enough power it can get stuck in a re boot loop...?

Share this post


Link to post
Share on other sites

I use this exact model PI for my complete imaging set up, with out issues, so I can be sure it does work, but I use the Stellarmate OS Image, which costs $50 so not quite the same, although I have put ubuntumate in with no issues before...

As I said before make sure the power supply is at least 2.5amp, or you will have issues, like you are having..

Edited by LightBucket

Share this post


Link to post
Share on other sites

Does not work for me using genuine RPI power supply 5.1v 2.5 amps from element 14.. as per the rpi org forum a lot of probs with 16,04.  on indilib they say use stellarmate.  where did you get your image from for 16.04 and whose script did you use would be greatly appreciated I tried ubuntu's own link and Robert's script on my 3b+ and failed.

Andy

Share this post


Link to post
Share on other sites
51 minutes ago, fozzybear said:

Does not work for me using genuine RPI power supply 5.1v 2.5 amps from element 14.. as per the rpi org forum a lot of probs with 16,04.  on indilib they say use stellarmate.  where did you get your image from for 16.04 and whose script did you use would be greatly appreciated I tried ubuntu's own link and Robert's script on my 3b+ and failed.

Andy

Lol, Stellarmate is Ubuntu mate 16.04.... its just got some extras and all packaged ready to use with no configuration needed... :)

Are you sure you are not trying to use version 18.04....the newer one as that has issues, the older 16.04 is fine and as I said that is what SM is anyway...

Edited by LightBucket
  • Like 1

Share this post


Link to post
Share on other sites

I didn’t use anybody’s script when I tried it before I bought SM, just put Ubuntu mate 16.04 for ARM on, then installed Kstar / Ekos and full INdI library 

Edited by LightBucket

Share this post


Link to post
Share on other sites

This is a simple way to test your kit out https://www.berryterminal.com/doku.php/berryboot  it will then run Ubuntu 16.04 Mate + Indi + Ekos + Kstars - you install Indi bits -Note that its 32bit running not 64bit. For 64bit RPI3+ and 5GHZ wifi I have used Raspex http://raspex.exton.se plus Ubuntu 18.04 server edition works for Indiserver only - note "server edition"

Edited by stash_old

Share this post


Link to post
Share on other sites

pictures tell no lies normally 🙂 Plus Realvnc server installed and being used for free as its RPI

ubuntu-2.png

ubuntu-1.png

Edited by stash_old

Share this post


Link to post
Share on other sites

I downloaded direct from ubuntu site 16.04.2 Xenial  maybe berryboot does something different will hava a go at that cheers

 

Share this post


Link to post
Share on other sites
18 minutes ago, LightBucket said:

Lol, Stellarmate is Ubuntu mate 16.04.... its just got some extras and all packaged ready to use with no configuration needed... :)

Are you sure you are not trying to use version 18.04....the newer one as that has issues, the older 16.04 is fine and as I said that is what SM is anyway...

cheers head banging like I said crashed after flashing I've about 6 Rpi's for other things from the very first to the latest. and my indi one is running on rpi3b not the + could not get it working with ubuntu 16.04 works a treat on Raspbian also archlinux that's another story...

Share this post


Link to post
Share on other sites
3 minutes ago, fozzybear said:

cheers head banging like I said crashed after flashing I've about 6 Rpi's for other things from the very first to the latest. and my indi one is running on rpi3b not the + could not get it working with ubuntu 16.04 works a treat on Raspbian also archlinux that's another story...

Hmmm, I’m confused as to why Stellarmate works ok the rpi3b+ (which is Ubuntu mate) but you can’t just install Ubuntu mate 16.04 straight onto your b+... 🤔🤔

Share this post


Link to post
Share on other sites

An Ubuntu 18.04 lts server edition straight from Ubuntu Site (64bit) 

You can of course use the images from the Ubuntu Mate etc sites - but make sure you have quality SD cards _Sandisk A1 class 10 or the like and Real ones.

ubuntu-4.png

ubuntu-3.png

Share this post


Link to post
Share on other sites
2 minutes ago, LightBucket said:

Hmmm, I’m confused as to why Stellarmate works ok the rpi3b+ (which is Ubuntu mate) but you can’t just install Ubuntu mate 16.04 straight onto your b+... 🤔🤔

as per the OP same problem are you sure yours is the 3b+ and not just the 3b as this is the 64bit processor?

Share this post


Link to post
Share on other sites
Just now, fozzybear said:

as per the OP same problem are you sure yours is the 3b+ and not just the 3b as this is the 64bit processor?

Mine is 3b+ and there is no Ubuntu mate that works on 64 bit, mine is 64bit rpi but there is only 32bit Ubuntu mate for rpi...

Share this post


Link to post
Share on other sites
2 minutes ago, stash_old said:

An Ubuntu 18.04 lts server edition straight from Ubuntu Site (64bit) 

You can of course use the images from the Ubuntu Mate etc sites - but make sure you have quality SD cards _Sandisk A1 class 10 or the like and Real ones.

ubuntu-4.png

ubuntu-3.png

using sandisk class 10 card don't buy cheap expletive removed …. stashold I take it you just run the server end on rpi and kstars on local machine?

Share this post


Link to post
Share on other sites

Depends which SD card I put in and where I am - off site or home - But I can,and do, run either way  🙂

Fedora 28 is supposed to run 64bit mode on RPI3b+ and use Windows thingy (KDE or the like) but haven't tried it.

Share this post


Link to post
Share on other sites
2 minutes ago, LightBucket said:

Mine is 3b+ and there is no Ubuntu mate that works on 64 bit, mine is 64bit rpi but there is only 32bit Ubuntu mate for rpi…

everytime I image the Microsd card it fails on first boot I have 3 3b+ cards one for my 3d printer works fine with octoprint another for acars (plane plotting running Raspbian) another for gprs/arps amateur radio arch....

Share this post


Link to post
Share on other sites
1 minute ago, LightBucket said:

But there is no Ubuntu Mate 64 bit, to work directly on rpi3b or b+..?

I know that it is the architecture of the device yet ubuntu 16.04 fails and I do not know why on indilib forum just get stellarmate solves it all....

if it worked for you what was your workflow to get 16.04 to work to a valid logon then there is the problem with firefox not working etc...…………..

Share this post


Link to post
Share on other sites

Never tried it on a RPI3B+ but you could try https://fedoraproject.org/wiki/Architectures/ARM/Raspberry_Pi#aarch64_supported_images_for_Raspberry_Pi_3 .

Have run Fedora 28 on AMD with Kstars/Ekos/Indiserver local and remote.

I even used,as a test, my Zero W to run Indiserver for my DSLR and Mount - no problems  so long as you have a decent Wifi Signal to connect too

Dont forget RPI3b and RPI3b+ use different CPU - Arm7h and Armv8 so images are not interchangeable 🙂

Try Rufus to write your SD images - etcher normally works but Rufus ok too https://rufus.ie/en_IE.html.

What size SD cards are you using as a matter of interest ?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

By using this site, you agree to our Terms of Use.