Jump to content

Stargazers Lounge Uses Cookies

Like most websites, SGL uses cookies in order to deliver a secure, personalised service, to provide social media functions and to analyse our traffic. Continued use of SGL indicates your acceptance of our cookie policy.

sgl_imaging_challenge_banner_solar_25_winners.thumb.jpg.fe4e711c64054f3c9486c752d0bcd6f2.jpg

Helen

ASCOM, .net 3.5 and windows 10 problem

Recommended Posts

I got an EQMod cable for my AZGTI for Chrsitmas ?  I'm now trying to get my laptop set up to use it, but have hit a problem which despite a lot of googling is proving challenging to fix.  I wondered if anyone else had the same problem and had found a solution?

When I try to install ASCOM 6 I get a message to say it needs the .net framework 3.5  and that I should enable using control panel> programs>  turn windows features on and off to enable  it.  It works fine on my desktop, but on my laptop I get an error saying 'The referenced assembly could not be found' ?

Any ideas?

Thanks

Helen

Share this post


Link to post
Share on other sites
13 minutes ago, Helen said:

I got an EQMod cable for my AZGTI for Chrsitmas ?  I'm now trying to get my laptop set up to use it, but have hit a problem which despite a lot of googling is proving challenging to fix.  I wondered if anyone else had the same problem and had found a solution?

When I try to install ASCOM 6 I get a message to say it needs the .net framework 3.5  and that I should enable using control panel> programs>  turn windows features on and off to enable  it.  It works fine on my desktop, but on my laptop I get an error saying 'The referenced assembly could not be found' ?

Any ideas?

Thanks

Helen

Hi

You can download net framework 3.5 from here :) . However, the latest Ascom appears to be 6.4 which requires net framework 4?

Louise

Happy New Year

Share this post


Link to post
Share on other sites

The latest Net framework 4 can be downloaded here: -

https://www.microsoft.com/en-gb/download/details.aspx?id=17718

The alternative is to load v3.5 as per the link from 'Louise' above and then access windows update to download the upgrades.

I hope this helps.

Sandy

Have a Happy New Year

Edited by Lonestar70

Share this post


Link to post
Share on other sites

Thanks both for trying to help.  In the end after even more googling I found something which said try disabling framework 4 then installing 3.5 and then re enabling farmework 4 - and it worked :hello2:  Somewhat frustrating to have wasted so many hours on what was a simple fix Grrr.  Right, now to install EQMod etc - hope that is more straightforward!!!

Helen

Share this post


Link to post
Share on other sites
21 minutes ago, Helen said:

Thanks both for trying to help.  In the end after even more googling I found something which said try disabling framework 4 then installing 3.5 and then re enabling farmework 4 - and it worked :hello2:  Somewhat frustrating to have wasted so many hours on what was a simple fix Grrr.  Right, now to install EQMod etc - hope that is more straightforward!!!

Helen

Hi Helen

Um, any reason you didn't want to install Ascom 6.4?

Louise

Share this post


Link to post
Share on other sites

Hi Louise,

It was 6.4 I was trying to install but it wouldn't let me without .net framework 3.5 ? Odd!

Thanks

Helen

Share this post


Link to post
Share on other sites

Hi Helen,

Grrr... don't you just love M.soft... they give W10 a later version 4 but don't make it backward compatible with their earlier versions.

Anyways, I am pleased you solved the problem and can get on with better things.

Keep happy and enjoy.

Best regards for the New Year.

Sandy.

Share this post


Link to post
Share on other sites
1 minute ago, Helen said:

Hi Louise,

It was 6.4 I was trying to install but it wouldn't let me without .net framework 3.5 ? Odd!

Thanks

Helen

Oh ok, I was confused.... Net Framework is a Microsoft nightmare!

Share this post


Link to post
Share on other sites
9 minutes ago, Lonestar70 said:

Hi Helen,

Grrr... don't you just love M.soft... they give W10 a later version 4 but don't make it backward compatible with their earlier versions.

Anyways, I am pleased you solved the problem and can get on with better things.

Keep happy and enjoy.

Best regards for the New Year.

Sandy.

 

9 minutes ago, Thalestris24 said:

Oh ok, I was confused.... Net Framework is a Microsoft nightmare!

Thanks Sandy and Louise,

Yes, I agree Net Framework is a complete nightmare!

Now on the next challenge...EQMod set up!  I loved it when I had my EQ6, but it has been 5 years since I used it, so now need to relearn it and adapt to the AZGTI quirks.  Don't we just love all this ? ?

Helen

Share this post


Link to post
Share on other sites
1 minute ago, Helen said:

 

Thanks Sandy and Louise,

Yes, I agree Net Framework is a complete nightmare!

Now on the next challenge...EQMod set up!  I loved it when I had my EQ6, but it has been 5 years since I used it, so now need to relearn it and adapt to the AZGTI quirks.  Don't we just love all this ? ?

Helen

Yeah, I spend far more time tinkering and fiddling than I do imaging - more than I will ever do!

Share this post


Link to post
Share on other sites
1 minute ago, Thalestris24 said:

Yeah, I spend far more time tinkering and fiddling than I do imaging - more than I will ever do!

I suppose it keeps us out of mischief on cloudy nights.... ! ?

Helen

Share this post


Link to post
Share on other sites
3 minutes ago, Helen said:

I suppose it keeps us out of mischief on cloudy nights.... ! ?

Helen

Nights are cloudy >90% of the year here... So I do other things as well, like evening classes twice a week :). I wish I could move to rural East Anglia but that won't ever happen.

Louise

Share this post


Link to post
Share on other sites

If this helps anyone, what I do after a clean install is: -

1. Go to the Windows Control Panel
2. Select small Icons
3. Click Programs and features
4. On the top left hand side it says turn windows features on or off
5. From the dialogue box check .NET Framework 3.5

The system will then download and install the required files: -

image.png.a5c284620fd9d103aeb4057836355611.png

Hope that helps?

Share this post


Link to post
Share on other sites
2 hours ago, Jkulin said:

If this helps anyone, what I do after a clean install is: -

1. Go to the Windows Control Panel
2. Select small Icons
3. Click Programs and features
4. On the top left hand side it says turn windows features on or off
5. From the dialogue box check .NET Framework 3.5

The system will then download and install the required files: -

image.png.a5c284620fd9d103aeb4057836355611.png

Hope that helps?

Just to clarify what I did which solved my problem - in the screen shot above I unchecked the framework 4.7 and clicked ok.  That disabled 4.7.  Then I checked 3.5 and it downloaded the files and set it up ok (it had thrown an error message when I did the same but with the 4.7 box checked).  Then I re-checked the 4.7 box and it installed that with no problems.  And ascom then worked ?

Helen

Share this post


Link to post
Share on other sites

You shouldn't have to do that... the disabling that setting, I'm sure I didn't when I was tinkering last.

I do a lot of tinkering.. bit it's sorted now.  

 

Share this post


Link to post
Share on other sites

It is one of those odd things... Didn't need to do it on my pc, but it was the thing that solved the problem on my laptop when just checking 3.5 didn't work.

Helen

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.