Jump to content

sgl_imaging_challenge_banner_31.thumb.jpg.b7a41d6a0fa4e315f57ea3e240acf140.jpg

ZWO Peltier Cooler


Recommended Posts

I'm still having trouble getting this thread to cut.  I've checked, the rod is the right thickness.  I'm wondering if there's a way of using a power drill.   (just playing with ideas)

Link to post
Share on other sites
  • Replies 145
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Here’s a progress update.    When I got home from work, I switched out the peltier module with the 40mm one.   Also I double checked that the paste below the block was ok - I wasn’t happy with it, so

I'm down to 7.5C now, that's down from 20.2C.   That's a good improvement.   I'm thinking of adding another EPDM rubber sheet, to add to help with the insulation.

Started work on the control box and here’s where two minor modifications rather than a cable gland, I’m using a plug aviation plug and socket.   Also the dc power supply plug and sock

Posted Images

I'm rather puzzled as to why you want a copper rod.  I have my Peltier TEC straight onto the back of the ZWO camera.  The sensor is in thermal contact with the case for cooling.  Surely an extra copper rod will just increase thermal resistance.

Link to post
Share on other sites
9 hours ago, Gina said:

I'm rather puzzled as to why you want a copper rod.  I have my Peltier TEC straight onto the back of the ZWO camera.  The sensor is in thermal contact with the case for cooling.  Surely an extra copper rod will just increase thermal resistance.

The copper rod will sit into the 1/4" thread on the back of the camera.  By filling that void, with copper, it will create a thermal conductor that will help to get the cold from the peltier to the sensor.

In addition, I'm planning on having an aluminium plate connected to the m4 threads on the camera, this plate will have a 1/4" threaded hold though it.  On top of that, will be another 6/8mm block of aluminium (haven't decided on that bit yet, as 6) I'm thinking about threading as well, so that the copper rod can be in direct contact with the peltier.  That's a decision that I will make when I'm dry fitting everything together.

 

Right now my main thought is about getting that thread onto the 1/4" copper rod.  Once the whole rod is threaded, the rest should be dead easy. I think the reason that I'm struggling so much is that I don't normally do much DIY, probably not messed anything up, maybe I'm being too cautious.

Link to post
Share on other sites

Personally, I think you are making the whole thing unnecessarily complicated and giving yourself extra work.  Sorry to be negative but I am trying to be helpful. 

Link to post
Share on other sites
1 hour ago, Stub Mandrel said:

The best thing you can do is use a thin layer of heatsink paste.

That's already in hand.  ?    Actually, I'm also thinking about adding some to the 1/4" lug nut once it's made too.  that way there's better transfer from the copper to the camera ;)

  • Like 1
Link to post
Share on other sites

Just tried using a Drill to cut the thread and think I have figured out the problem.   I think it's the wrong die that I'm using!   It says 1/4" NC20.  whilst when I pass a steel 1/4" that I'm using for testing through.  The tool itself isn't so much cutting as stripping most of the metal.   Something tells me that the tool is too low a quality to be able to do the job!

Link to post
Share on other sites
16 minutes ago, cjdawson said:

Just tried using a Drill to cut the thread and think I have figured out the problem.   I think it's the wrong die that I'm using!   It says 1/4" NC20.  whilst when I pass a steel 1/4" that I'm using for testing through.  The tool itself isn't so much cutting as stripping most of the metal.   Something tells me that the tool is too low a quality to be able to do the job!

I guessed it must have been something relatively simple. Glad you’ve figured it out. 

I used one of these: https://m.ebay.co.uk/itm/Imperial-UNC-1-4-x-20-tpi-re-threading-thread-repair-cleaning-die-inc-VAT/332568835393?hash=item4d6ea5b541:g:d74AAOSw0H9Z31-a as I didn’t have a tap & die set, didn’t want to spend vast amounts for probably a use once item & because the copper is soft a re-thread/cleaner sufficed. 

Link to post
Share on other sites

That's on order.   Here's the die that I was using

 

IMG_1949.thumb.jpg.d61ffe33e9e33eaa8933781d9c79da84.jpg

 

Looking at it like that I don't think this took is better for cleaning up, or retreading threads, it's struggling to cut a brand new thread.

Oh, and the idea of using a power drill is a good one :) takes alot of the effort out of it.   I think I'll be planning on using the drill to get it started, then will be working most of the thread by hand.   It'll be easier to do most of the work be hand because of the back and forward constant changing.  This will take forever with a drill.

  • Like 1
Link to post
Share on other sites

1/4 20 NC (UNC) is the correct thread.

But it's an unsplit die... that can mean one of three things:

  1. It's a precision die not meant to be adjusted. (Very good, although some people will deny the existence of such dies they are much sued by CNC and industry who don't want to faff about adjusting dies, I have a metric set of such dioes and they are excellent)
  2. It's a die nut meant for cleaning up damaged threads (not so good)
  3. It's 'cheap and cheerful' (definitely not good)

Inspired by your travails, I got one of these (to go with my sole 1/4 UNC tap, good enough for making camera threads in light alloy)

https://www.ebay.co.uk/itm/UNC-UNF-Unified-1-OD-Tungsten-Split-Die-1-4-5-16-3-8-7-16-1-2-9-16-5-8-3-4/261768712801?ssPageName=STRK%3AMEBIDX%3AIT&var=560642644720&_trksid=p2057872.m2749.l2649

Edited by Stub Mandrel
Link to post
Share on other sites

Use a ceramic based thermal compound rather than silver based. Minimises risk of long term galvanic corrosion between the copper and alu when the frost melts and seeps into the thread... although just going all aluminium would zero that risk entirely.

Link to post
Share on other sites

That's a good point.  Although I don't have that problem with my ASC cooling system, having the Peltier TEC directly onto the camera, I was considering using a copper strip to conduct heat from the hot side to an external passive cooler which is aluminium.  I guess a thicker aluminium heat conducting strip would be better than copper.

Link to post
Share on other sites
1 hour ago, Stub Mandrel said:

How are you holding the die?

I simply held the twisty tool in a drill press vice.  Just to stop it moving.   I put the ord into a drill and pressed it hard into the die.  No movement, but it didn't cut a thread.    I'm guessing my die is either a 2 or 3 from the post above ? 

Link to post
Share on other sites

Get a die holder, you need a lot of end force and low speed. I can't see enough being applied with a hand drill without introducing some wobble. If the pressure isn't great enough or the drill wobbles, the thread won't form well.

Link to post
Share on other sites

I have a couple of die holders.    Couldn't think of the name of it when I wrote about putting something in a vice - it was the die holder that I clamped.   When the die in the holder.   Then the rod was in the drill and turned at low speed with my pressing down.   The result I ended up with on my aluminium rod looked the same as the copper rod.   The copper rod was done completely manually, with the rod clamped.  This is why I'm certain that it's the die that isn't up to the task.

  • Thanks 1
Link to post
Share on other sites
  • 2 weeks later...

Moving on from the fun and games with threaded copper rod.  This month, I'm going to concentrate my efforts on the rest of the build.

Next phase is to get the order in for the laser cutting, £47.46.

 

In addition, I'm going to take a good close look at getting all the M4 bolts, nuts and other bits together.    I'm not sure whether to bother with wing nuts, or simply use normal nuts instead.    In total, I'm thinking that I'll need 10 bolts, and 6 nuts.

The 10 bolts are as follows - 4 to attach to the camera back.  4 to attach cpu fan to main plate, and 2 to attach the project box to the main plate.

Also, I've been looking over the pictures on the instructable.  Looks like I might need a cable gland after all, Or at least a rubber gromit, to allow the CPU fan cable, temp sensor and peltier module cabling to exit from the small project box.

Edited by cjdawson
Link to post
Share on other sites

Have a look here re tapping copper https://www.model-engineer.co.uk/forums/postings.asp?th=95556  . Copper work hardens. Some lubricant may help. A manual job (with the hands) -no power - A lathe could be used (unpowered) keeping all square that way with a die holder head and hand rotating the chuck. Two steps forward and one back was drummed gently in to me when tapping threads back at school more than 60 years ago 

Link to post
Share on other sites

Was just looking on ebay, putting in the order for the bolts, and I came across this listing.

https://www.ebay.co.uk/itm/Packs-of-1-5-10-20-M4-M6-BLACK-NYLON-THUMB-NUTS-With-Collar-FINE-KNURLED/183119357814?var=690400702708&hash=item2aa2c3a776:m:mxGcSZwZBRl7xzRmd_AJftg

Got a pack of 10 of these, might end up nicer than having wingnuts.

 

Will be interesting to see if there's enough clearance to the USB socket on the camera with these too.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. By using this site, you agree to our Terms of Use.