Jump to content

Stargazers Lounge Uses Cookies

Like most websites, SGL uses cookies in order to deliver a secure, personalised service, to provide social media functions and to analyse our traffic. Continued use of SGL indicates your acceptance of our cookie policy.

sgl_imaging_challenge_banner_solar_25_winners.thumb.jpg.fe4e711c64054f3c9486c752d0bcd6f2.jpg

Recommended Posts

Setting up all the software on my win10 laptop and getting things to talk to one another is a nightmare.

I'm starting a new thread, so I can post all the problems I am having, one at a time, so issues don't get confused. This will also hopefully help anyone coming to similar situations later, as the problems and answers will not be interlaced.

First issue: APT does not detect ZWO camera.

I have got the camera (ZWO) drivers installed and sharpcap can see it and will connect to it properly. However, when I try to connect the camera in APT, the only CCD options it gives me are SBIG (which it isn't), QSI (which it isn't) and ASCOM. Now it shouldn't need to use an ascom driver, because the proper driver is installed, but I give it a go anyway, and this just offers me 2 simulators and 3 QHY cameras (I have one qhy driver installed for the guidecam .... I'll get to that later!). I have disconnected both the filterwheel and guide camera from the camera hub, so they cannot be interefering with the process.

I am at a total loss ... any suggestions?

Thanks.

Share this post


Link to post
Share on other sites

Straight off the top of my head. How about Win 10 compatibility mode? 

Share this post


Link to post
Share on other sites

 

1 minute ago, Rob said:

Straight off the top of my head. How about Win 10 compatibility mode? 

I have a ASI120MM running under Win10 with no issues regarding compatability mode = I'd be checking that you have installed both the native ZWO driver, *and* the ZWO ASCOM driver (they are 2 separate downloads on the ZWO site: https://astronomy-imaging-camera.com/software/). It sounds like you either haven't got the separate ASCOM driver, or it's not installed properly. 

Share this post


Link to post
Share on other sites

I have both a 120mm & 1600mm running happily on a Win 10, together with mount\focuser\phd2\ansvr\filter wheel etc. all being run by either APT\SGPro etc.

As a first starting point, go to https://astronomy-imaging-camera.com/software/ and download\install the latest versions of all the drivers, also install ASICap (its useful as it will run two instances, so can have both cameras active at once)

 

Share this post


Link to post
Share on other sites

God do i detest PC's, Apple convert since i literally ran my PC tower over with my car and you tubed it years ago.

  • Haha 2
  • Confused 1
  • Sad 1

Share this post


Link to post
Share on other sites
46 minutes ago, Dr_Ju_ju said:

I have both a 120mm & 1600mm running happily on a Win 10, together with mount\focuser\phd2\ansvr\filter wheel etc. all being run by either APT\SGPro etc.

As a first starting point, go to https://astronomy-imaging-camera.com/software/ and download\install the latest versions of all the drivers, also install ASICap (its useful as it will run two instances, so can have both cameras active at once)

 

Thanks.

I already have the latest proper driver and will, as above, download the ascom driver when I get back to my desktop this afternoon. What do I need asicap for?

Share this post


Link to post
Share on other sites

The ascom driver for ASI only drives 1 ascom ASI camera.  If you need to use 2 (ASI and ascom cameras) you need it, but if the other camera is not an ASI or a guide cam with PHD2 it's ok as it doesn't require the ascom driver.

Word from the wise, in my experience the ASI ascom driver/APT combo is pathetic, well, probably worse than pathetic, unusable - you can use SharpCap but dithering is non-trivial unless there's been recent updates, SGP very very good.

Share this post


Link to post
Share on other sites

ASICap, needs no additional drivers, as long as you've installed the main driver.

 

One thought that has just struck me... Which version of Windows 10 are you using?, hopefully the Pro version, as there are gotchas with the cut-down versions.

Edited by Dr_Ju_ju

Share this post


Link to post
Share on other sites
1 hour ago, John78 said:

The ascom driver for ASI only drives 1 ascom ASI camera.  If you need to use 2 (ASI and ascom cameras) you need it, but if the other camera is not an ASI or a guide cam with PHD2 it's ok as it doesn't require the ascom driver.

Word from the wise, in my experience the ASI ascom driver/APT combo is pathetic, well, probably worse than pathetic, unusable - you can use SharpCap but dithering is non-trivial unless there's been recent updates, SGP very very good.

I will only be using 1 zwo camera at a time (either 224 or 1600). My guide cam is a qhy & I have installed the ascom driver for that.

I would prefer to use sharpcap, but will be running the pointing program on apt and am going to try imaging with it as well. If it becomes too much hassle I will revert.

Share this post


Link to post
Share on other sites
43 minutes ago, Dr_Ju_ju said:

ASICap, needs no additional drivers, as long as you've installed the main driver.

 

One thought that has just struck me... Which version of Windows 10 are you using?, hopefully the Pro version, as there are gotchas with the cut-down versions.

I'm obviously being dense. No additional drivers to do what? If I need to install the ascom driver to use the cam on apt, what is the benefit? 

Not sure which win10 it is - will check when I get home.

Share this post


Link to post
Share on other sites

One of my reasons for going to apt is that I am trying to get away from AT that I always found to be temperamental at the best of times. The other 2 options require the computer that they are being installed on to connect to the Internet  (which this one isn't). I wonder if AT in sharpcap is better than AT on its own?

Share this post


Link to post
Share on other sites
3 hours ago, Dr_Ju_ju said:

One thought that has just struck me... Which version of Windows 10 are you using?, hopefully the Pro version, as there are gotchas with the cut-down versions.

It's windoze 10 home.

Share this post


Link to post
Share on other sites

Then you may have issues getting all the 'bits' talking to each other, as most of the software we use, acts on a client\server basis, which Home version is deliberately ham-stringed to disable such software working (its based on the user not needing to 'worry' about security, Microsoft has it covered :BangHead:). 

Share this post


Link to post
Share on other sites
1 hour ago, Dr_Ju_ju said:

Then you may have issues getting all the 'bits' talking to each other, as most of the software we use, acts on a client\server basis, which Home version is deliberately ham-stringed to disable such software working (its based on the user not needing to 'worry' about security, Microsoft has it covered :BangHead:). 

Sorry that is not 00% correct - I use Win 10 home on my tablet and it happily runs a number of apps ,which I have written , using TCP client/ server / UDP basis. Plus you can run CDC on another PC and connect to it in "Client/Server" mode with ease. 

Yes I know certain features don't exist on the Home edition - RDP ,Virtualisation ,Bitlocker etc and "buffers"/resources are managed differently but disabled "client/server" working ?????

 

So could you please expand on what you mean by "deliberately ham-stringed to disable such software working" :dontknow:

P.S. APT does NOT support Native ZWO only via ASCOM ZWO drivers!

 

Edited by stash_old
  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

Sorry if this is 'teaching grandmother to ... etc' but do your see the 'ASCOM Camera Chooser' dialogue box appear after you have clicked connect and selected CCD ASCOM Camera when the  'Selected Camera Type' dialogue box appears. (For CCD read CMOS for the 1600!) If you do get the ASCOM Chooser select ASI Camera (1) from the drop down list and that should connect the camera. (Assuming it's plugged in of course)

Share this post


Link to post
Share on other sites

It isn't there - only simulators (2) & qhy (3). Once I install the zwo driver, it will hopefully do that.

Thanks.

Share this post


Link to post
Share on other sites

I have downloaded the ascom driver for these cameras from zwo site (v1.0.3.15) and will transfer it to the laptop later this morning.

I have also been thinking about the AT/Sharpcap option rather than APT.

For several reasons, I prefer using Sharpcap to APT as my capture program, so if AT works better as part of sharpcap than it did as a standalone program, it would make sense to go with that. Simple solution is to "suck it and see". So I will also install AT and transfer all the index files from my windoze 7 machine onto the new laptop and can try it. If it performs, I can remove APT completely, releasing that space for data. If it doesn't, then I still have Platesolve2 to fall back on.

I guess that, even if I remove APT, having the zwo ascom driver installed will not be a major drain on my ssd space, and may even help connectivity with some other part of the system.

Plan!

Thanks.

Share this post


Link to post
Share on other sites
15 hours ago, Demonperformer said:

One of my reasons for going to apt is that I am trying to get away from AT that I always found to be temperamental at the best of times. The other 2 options require the computer that they are being installed on to connect to the Internet  (which this one isn't). I wonder if AT in sharpcap is better than AT on its own?

Nowt wrong with AT, just need the right settings binning being the first and obv the fov (and search radius).  However sharpcap can also use ASPS which is what APT uses behind the scenes iirc and both AT and ASPS run using the index files from astrometry.

The bottom line is, if you can upload your image to astrometry and it can solve it, you can also solve it offline using AT or ASPS if you prefer.

Share this post


Link to post
Share on other sites

There was "nowt wrong with AT" - when it worked! Settings are, of course, important, but that does not explain why it will work on one go, but redo the same field immediately afterwards and it fails.

APT has 2 options, ASPS is one, but setting that up requires the computor on which it is being installed to be connected to the Internet. As stated above, my new laptop is not being allowed anywhere near the Internet. 

The other APT option is PS2, which allows you to download everything you need and transfer those files onto the laptop you will be using. This is the option I have provisionally put onto the laptop.

Share this post


Link to post
Share on other sites

Second issue: PHD2 refuses to recognise QHY5Lii guide cam

Another setup that works on windoze 7 without any problem.

I have installed the latest ascom driver for this camera (QHY5LIIASCOMSetupV1.2.1.0).

I have tried this both with the guide cam plugged into the zwo hub (from where it will need to run) and also plugged directly into the laptop. I have tried both starting PHD2 first and then plugging in the camera and also starting PHD2 after the camera is plugged in. I have tried reinstalling the driver once the camera is already plugged in (which informs me that it is uninstalling the previous installation).

In all of these events and their various combinations, I get the message during the configuration startup, upon selecting "QHY Camera" from PHD that "No compatible QHY cameras found".

I had previously installed the wrong drivers ["QHYCCDASCOM Capture StarSenseSci V0.1.51.15" and "QHY5IIDriver 160519(Beta)"] which I have uninstalled using the "uninstall program" option. Don't see that this should be causing an issue, but mention it for the sake of complete disclosure.

Having solved issue one (see previous post), I'm confident the SGL community will be able to go "2 for 2". So, any suggestions?

Thanks.

Share this post


Link to post
Share on other sites
12 hours ago, Demonperformer said:

There was "nowt wrong with AT" - when it worked! Settings are, of course, important, but that does not explain why it will work on one go, but redo the same field immediately afterwards and it fails.

APT has 2 options, ASPS is one, but setting that up requires the computor on which it is being installed to be connected to the Internet. As stated above, my new laptop is not being allowed anywhere near the Internet. 

The other APT option is PS2, which allows you to download everything you need and transfer those files onto the laptop you will be using. This is the option I have provisionally put onto the laptop.

You can also do that for asps,all you need to do is set it up on your other computer, download all the indexes that match your gear and copy it to the "no internet" notebook. 

the index files are located under  the "users\yourusername\appdata\local\astrometry\usr\share\astrometry\data" 

As for the second problem I'm trying to understand it, sure you'll find a solution in here. :)

Edited by Atreta

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By KevS
      This evening/morning I am having some problems getting my unmodified canon 600d to live view via apt. One hell of a palaver trying to get focused. Has any one suffered similar problems? Was working fine yesterday, tonight a bit of a disaster all round. I am running the feed for the guide camera down the same USB cable via a non powered hub, the camera works fine during the data gathering phase but no dam preview. Any suggestions would be greatly appreciated.
      K
    • By BUDA
      Hi All!

      I have guiding problem with the following guider setup: 9x50 finder + ZWO ASI 120mm mini + PHD2.
      The imaging scope is a 6' newtonian + canon dslr on a HEQ5, driven by a laptop via diy EQDIR cable.
      When the mount is set up and running correctly, polar aligned and all... I connect the guider camera
      and mount with phd2. All nice and easy, I run a calibration, then it starts to guide. All seems ok.

      Then I am starting to take pictures. The first seems OK, then the second have the star trails...
      I check phd2 and there is a message: the camera (ASI) did not take a picture for "xy" seconds so it is disconnected.
      Grrr.... I reconnect try to set up a longer period for "xy" in the settings as mentioned in the message.
      And all the same again and again. Whatever I add for connection timeout for the camera, it just reaches that
      and disconnect the camera.
      PHD + philips toucam has worked for me flowlessly. I changed to PHD2 because I gave myself a birthday present,
      the little ZWO camera. (and PHD did not recognize it)
      Do you have any idea what can be the problem? I will contact PHD2 help also, but maybe somebody had already
      the same problem and figured out how to overcome. I am almost sure I make some dumb mistake in the PHD2
      software settings, however I tried to change only what was needed.
    • By Coastliner
      Hi All,
      I'm trying to balance my AZ-EQ5 as perfectly as I can, all was going well (all 3 axes) until I added the Polemaster. As this is off-axis it applies torque to the RA causing the axis to rotate until the Polemaster is hanging at the lowest point.
      I need to couterbalance this, any ideas how?
      or,
      Do I need to counterbalance this? Am I being too picky?
      I have considered taking the arm off and gluing the Polemaster onto the on-axis point of the top cover, but again, is this overkill?
      Thanks,
      Neil.
    • By bottletopburly
      Currently setting up a pi4 with indigosky which will be run via APT , running win10  and the the latest APT Beta release 3.75.2 , now I can connect to indigosky server via browser , but I can’t connect via APT  indigo control panel throws up an error can’t connect to indigo or indi server  server address is default Indigosky , server port 7624 , on pressing navigate server error says dns address can’t be found , has anyone been successful in connecting to indigosky via APT running win10.
    • By Demonperformer
      The other night, I got a rather weird thing happen using Sharpcap. In live-stacking, the first image arrived and it was full of stars. So, without changing any settings, I did a "platesolve" (which also realigns the scope) to centralise my target. It did its single frame capture and I got a practically blank screen and a message saying it could only detect 3 stars. I tried reducing the "sigma" setting, as advised by the on-screen message, with little effect. What gets me is that the same settings produced a whole mass of stars in each of the subs that were being live-stacked. Never had this happen to me before, and no, of course I didn't do anything intelligent like saving the log file!
      I can always try to replicate this next time (although I always find trying to replicate something that isn't working to be a weird activity in itself!), but on the off-chance that anyone can see what was happening without the log file, I thought I would ask.
      Thanks.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.