Jump to content

Stargazers Lounge Uses Cookies

Like most websites, SGL uses cookies in order to deliver a secure, personalised service, to provide social media functions and to analyse our traffic. Continued use of SGL indicates your acceptance of our cookie policy.

sgl_imaging_challenge_banner_lunar_landings.thumb.jpg.b50378d0845690d8a03305a49923eb40.jpg

ChrisEll

Celestron AVX mount - How to fix tight RA / Dec axis

Recommended Posts

Here's a quick guide to adjusting the tightness on the Dec and RA axes on the AVX mount. Freeing up the axes means better guiding, less wear on gears and motors (some gears in the drivetrain are plastic), lower worm PE and you will be able to balance more precisely.

Dec axis: 

Remove the counterweight bar and cup to reveal the tension ring. To adjust this first loosen the 2 grub screws at its side... there is a small access hole at the side of the housing. You'll need a tiny allen key to do this. Then use a slightly larger, stiffer allen key and insert this into the access hole and against the grub screw so that the tension ring is wedged tight against the allen key - this serves to hold the tension ring in place as you turn the axis, no need for a special tool! Now rotate the mount saddle anti-clockwise to loosen the tension ring until you feel some vertical play (grab hold of the saddle and move up and and down to test). Slowly tighten until there's no play. Tighten grub screws.

RA axis: 

Remove the plastic cup at the end of the axis. The RA tension ring has 3 grub screws and the access hole is hidden by the control panel cover (3 screws hold this in place). My RA axis was very tight and needed a few turns of the axis before I got any vertical play.

For those wishing to improve their AVX further I recommend adjusting the worm housings in both axes.

Dec_tension_ring.JPG

RA_tension_ring.JPG

  • Like 5

Share this post


Link to post
Share on other sites

I posted some info about AVX disassembly before but this seems like a good thread to add them again. 

http://rocketsparrow.blogspot.co.uk/2017/01/how-i-made-better-celestron-avx.html (note the comments at the bottom about removing the RA tensioner there are 3 grub screws to loosen first  and it needs a very small allen key as shown above)

https://www.flickr.com/photos/10605262@N04/sets/72157646742806679/?ytcheck=1

This guide is for the older but similar CG5  http://astronomyboy.com/cg5/

https://www.cloudynights.com/topic/578878-celestron-avx-rebuild/

I replaced the RA bearing with an angle bearing  although it does leave a slight gap as mentioned in some threads but it made a HUGE difference to RA stiction

http://www.ebay.co.uk/itm/SKF-32007XQ-Metric-Single-Row-Taper-Roller-Bearing-35x62x18mm/130940248658?hash=item1e7ca5a252:m:m3AAqpQNFsFJgnN6vqioQOw

It's easier than I thought I didn't even need to remove the RA from the mount part.

It certainly made things less sticky and balancing became a lot easier although guiding performance wasn't much better. 

 

In the end I bought an EQ6-R which has been a massive improvement. 

Rob.

Share this post


Link to post
Share on other sites
Posted (edited)

I just wanted to say thank you. My DEC axis was pretty stiff and I never felt confident that I was balanced properly. It's worlds better now and much easier to balance.

 

Thank you!

Edited by ELEMENT22
  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Carboncrazy
      Can anyone help? I'm pretty much a novice at this astronomy stuff but loving the steep learning curve. I started by using camera lenses modified to use an eyepiece but after much debate, deliberation and saving up, I have finally bought my first proper telescope. Unfortunately I now have a problem.
      Last year I bought a second hand Synscan EQ5 mount which has worked perfectly each time I have used it. I  used it about a month ago for the first time with the new scope (last time we had a clear sky). Everything worked as it should. At 2 am I parked the scope, dismantled everything and put it away. Nothing was dropped, snagged or got wet.
      The forecast said we might get a clear sky last night. Anticipating this I got the mount on the bench, stripped, cleaned, polished and greased the DEC axis plain bearings (hoping this might help with guiding). When finished I connected the motor controller and handset and switched on. I was greeted with the following messages: INITIALISING then CAUTION BOTH AXES NO RESPONSE. If I press enter and carry on through the menus, then everything appears to be as it should except no motors run. I have tried everything I can think of and would be very grateful of advise or suggestions. These are things I have tried, so far:
      Factory reset
      Different power supply. I have been using a motorbike battery which is giving 13.5V constantly when I switch on. I have tried two other batteries with a 2A charger connected.
      Continuity tested the cables from the plugs that go onto the motherboard of the controller all the way to the motors.
      I made up the  RJ45 and RJ12 diagnostic cables suggested in the manual and the handset appears to be ok.
      Removed the motors from the mount to make sure that they turn freely.
      Replaced the RJ45 cable from the handset to the controller.
      Examined the motherboard for dry joints and damaged components.
      Assembled everything in the tripod to make sure that the earthing tab on the controller made no difference.
      I now feel that the problem is the controller motherboard but logic tells me that it was the mount I disassembled, so the fault should lie there. Is there anyone who has had the same problem or who has the same system that could help me diagnose the problem. I'm in North Shropshire but happy to travel to anyone who could help. Unfortunately I don't know anyone with the same mount.
       
       
       
    • By Greg6498
      Took my Celestron AVX Mount out this afternoon to familiarize my self with it in the daylight. Wasn’t sure if or how it would work, since it’s my first goto Mount. I got it setup per the directions and attached the SkySync GPS. It locked on my location very quickly so I did the Quick Align option just as a test. The polar scope was oriented north, and I used Sky Safari to locate stars I couldn’t see cause it was daytime. My first choice was Sirius and it slewed  right around to what should be the general vicinity! I then chose Venus in the West and off it went! I hit home and it went back to the original setup position. I can’t wait to take it out tomorrow night and really put it through it’s paces! This is totally most excellent!
    • By Adaaam75
      Hi guys,
      Having had difficulty in aligning and never actually managing to get my AVX to track to the standard I know it can, is the Celestron StarSense gadget the answer? 
      I know I can align my scope accurately if I put the effort in and having moved last year I’ve been unable to have my mount fixed on a pier so I’m seriously considering this piece of kit as an easier way to align and to motivate me to get out more often.
      Please share your thoughts.....
      Adaaam75
    • By Coastliner
      Hi All,
      If I grab hold of the puck on my AZEQ5 I can make it rock back and forth by a degree or so (DEC axis), there appears to be no play in the RA axis. Does anyone else have this? Can it be adjusted out?
      Thanks,
      Neil.
    • By knobby
      Dusted off the scope last night to check if everything is working ok, aimed for a quick bash at Jove, then some fiddling with the OAG setup using M13 as target.
      Attached is Jupiter at around 1030 with Io bottom left. I was quite pleased as only had 2 runs of 3 minutes before moving onto the guiding practice which went 'badly' 

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.