Jump to content

Stargazers Lounge Uses Cookies

Like most websites, SGL uses cookies in order to deliver a secure, personalised service, to provide social media functions and to analyse our traffic. Continued use of SGL indicates your acceptance of our cookie policy.

mikey2000

EQ6-R owners club

Recommended Posts

2 minutes ago, billhinge said:

Turns out the seller was after the new CEM70 instead, I had thought of a CEM60 myself but it would have been a vanity buy, don't think I need it. I just need a decent camera now. I have the full set of Primaluce Eagle bits and pieces. No more freezing hands and feet in winter!

The CEMs are interesting mounts, have been tempted in the sense of considering a CEM120 as an upgrade should I ever need to go beyond what I can do with the EQ6R but the 6R's a formidable mount for the money!

Not sure we'll see a lot of "post-lockdown" sell-offs, but it's possible I suppose.

Share this post


Link to post
Share on other sites

Hello everyone, i'm new to this forum.  

I was moving my EQ6-R Pro inside for cable management and took the CWs off, etc.. when i put the mount back on the tripod, i accidentally hit the CW shaft and the mount's RA shifted... Is it supposed to move if i apply enough pressure?  Thanks!

 

 

Share this post


Link to post
Share on other sites

Yes, the clutch only holds the RA in place with pressure, it's not a locking mechanism. It's designed like this so the gearing inside isn't damaged if it does get knocked.

Share this post


Link to post
Share on other sites
36 minutes ago, cuivenion said:

Yes, the clutch only holds the RA in place with pressure, it's not a locking mechanism. It's designed like this so the gearing inside isn't damaged if it does get knocked.

Ahh!! Thank you! :) 

  • Like 1

Share this post


Link to post
Share on other sites

I too have a new EQ6-R PRO and I have read through all 17 pages of this topic with interest.

I had a Sky-Watcher HEQ5 PRO and noticed that the RA Setting Circle does not behave as expected e.g. it's either locked at 0, or clamped but doesn't indicate RA. The dealer said it was mostly "cosmetic" e.g. not a fault.

Now that I have the EQ6-R PRO I notice that the locking screw is moved from the mount to the Setting Circle and the manual does refer to it as a Setting Circle and not a Polar Alignment Aid (HEQ5).

With both screws locked down, when I move the RA with the clutches "unlocked" it does move and does indicate RA.

When I have the clutches "locked" and slew with the HC  then it doesn't move with RA. Did I miss something?

I'm guessing it depends what it is clamped to internally. So it's better but not perfect.

Simon    

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.