Jump to content

Stargazers Lounge Uses Cookies

Like most websites, SGL uses cookies in order to deliver a secure, personalised service, to provide social media functions and to analyse our traffic. Continued use of SGL indicates your acceptance of our cookie policy.

stargazine_ep20_banner.thumb.jpg.c34e90166f1f5aa93f5211765a962cda.jpg

Marky1973

Celestron c9.25 OTA £875 SW SCT Focuser £75 ****OTA SALE PENDING****

Recommended Posts

***Updated with individual prices***

I purchased this early this year but just haven't been using it. A combination of other stuff going on and just generally bad timing on the 3 good nights we have had this year means I have not been able to get into using it in the way I had hoped. And I don't see it getting any better, so seems sensible to move it one to someone who can use it more effectively while I concentrate on broadband imaging with my ED80.

So, I have the XLT Fastar Compatible OTA on a Vixen dovetail with the 6x30 finder, 1.25" visual back and 25mm EP.

I also got a Skywatcher SCT focuser to help with mirror flop for imaging.

Also Bahtinov Mask

And homemade Sun Filter and Dew/Light shield that i can throw in if anyone wants them.

OTA is in perfect condition with the usual expected scratches on the dovetail, but otherwise in great condition. It is a fantastic scope giving great views, I am just not going to be able to use it much.

£875 for the OTA

£75 for the Focuser

£15 Bahtinov Mask

£950 for the lot or make me an offer!

Collection for OTA preferred as this is a bulky, fragile item and couriers generally will not insure such glass going through the post. I am not keen on posting, but could consider it if buyer is willing to organise themselves and take responsibility for it. I think I still have the boxes it came in. Focuser and Mask can obviously be posted.

Bank transfer, paypal accepted.

I'm in Gloucester.

IMG_20171226_213458.jpg

IMG_20171226_213509.jpg

IMG_20171226_213644.jpg

IMG_20171226_213652.jpg

IMG_20171226_213734.jpg

IMG_20171226_213744.jpg

Edited by Marky1973

Share this post


Link to post
Share on other sites

Cheers Catman

OTA SALE PENDING

 

Focuser and mask still available.

Edited by Marky1973

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Starbuddypal
      I purchased a Celestron Powerseeker 70EQ at a Goodwill thinking it was a great find for my first telescope. I get home and realize that it may be missing an eye piece. I'm unsure what else it is missing though. Where can I go to get the missing eye piece for this telescope? I don't know anything about telescopes so I'm not sure where to go or what else I will need or what else could be missing. I attached an image of it with what I think is missing.

    • By StarGazingSiouxsie
      Hi, 
      I have just purchased a couple of these https://www.celestron.com/products/powertank-lithium-pro
      The manual says that when the battery is powering something that the 4 red battery will blink in sequence to show that power is flowing. My units are fully charged up, yet when I use them the red lights don't blink in sequence. I just have 2 red static lights lit under the 4 red battery lights.
      I have 2 of the smaller power tanks, the next model down, and the blue battery lights on those do blink in sequence when they are powering an object. 
      I have tested my new units and they do seem to be providing power. But, if you have one of these, could you confirm please that your red lights don't flash when powering something?
      Thanks. It's just that the manual is very specfic about this. (I have double checked and the manual is specific to my new units) Still, it's a Celestron manual so maybe my expectations are too high
      Thank you  
       
      Siouxsie 
    • By StarGazingSiouxsie
      Celestron Focus Motor install problems on a CPC1100
      I've read enough threads online to know I'm not the only person to encounter problems with installing the Celestron Focus Motor.  Despite following the install instructions to the letter and watching a load of videos on how to do this, I could not get the motor work correctly with the screws for the mounting plate and motor mount installed anything other than loosely - which is obviously not right.
      I read up on a lot of threads about this and it seems the basic problem is that the mounting plate supplied with the motor causes pressure to be put on the focus bearing and thereafter causes binding and locking up. People have come up with many solutions including installing washers / shims and, taking Celestron's Tech Support advice, to install the orginal focus mounting plate first and then the Focus Motor kit mounting on top. - and that's what I did. 
      Whether by luck or design, Cubble came with quite long screws in his original mounting plate so there was ample thread left to pass through both plates. 
      With both plates installed, all the screws can now be tightened down (snugged down, nothing OTT), including the 2 hex screws for the motor mount. Before, the screws had to be left loose just to allow the motor to turn and, believe me, I spent hours making sure everything was true and aligned correctly to try and solve this.
      Anyway, that's what worked for me and I am happy that my motor is now working as intended. Celestron are a strange set up - they produce great scopes but some of their kit and accessories leaves a lot to be desired, from a R&D point of view.
      I hope this may help someone else out down the line. 

      Siouxsie 
    • By SovietShibe
      Hey there! So if you have a telescope as mentioned in the title, you probably noticed that the focus wheel stops working after a bit.
      Well If you look under the focuser you can see a small metal piece with 4 screws on it. You need a Philips head screwdriver to unscrew these, WARNING there's a lot of superglue(which actually isn't needed at all) so wear gloves!after you've unscrewed
      the metal piece a small black 2 ended piece should fall out. If it didn't fall, take it out. Now place your focusing wheels back without that small piece that fell out and screw everything back in.
      The remaining black piece that fell out should probably be thrown away.
      Now just don't focus out to the max and everything should work just fine!
      I hope this helped(btw I'm new here so i might've butchered the terminology) *just let me know
    • By Starboy6969
      Hey everyone, I just purchased my first refractor telescope but I have no idea where to get started, let’s get right into what my problem is. I purchased a Celestron C4-R; model number 21016; this came with a bunch of little pieces that I don’t know what they do, it’s a refractor telescope. I have the star diagonal but I don’t know where to attach it. I just want to know what I have to do to have it ready to be used thank you I would like help asap thank you👍🏼👍🏼👍🏼



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.