Jump to content

Stargazers Lounge Uses Cookies

Like most websites, SGL uses cookies in order to deliver a secure, personalised service, to provide social media functions and to analyse our traffic. Continued use of SGL indicates your acceptance of our cookie policy.

sgl_imaging_challenge_banner_solar_25_winners.thumb.jpg.fe4e711c64054f3c9486c752d0bcd6f2.jpg

Sign in to follow this  
artoleus

Ports to open for PHD2 and Indi server on raspberrypi

Recommended Posts

Hi,

So, I have a minor setup issue for my automation setup.   Here is a brief overview of my setup:

Raspberrypi on the scope connected to a powered usb hub.  Connected to the hub are a external wifi card (raspberry pi3 wifi is weak), an astromodified Canon 550D, a QHY5L-II for guiding and an EQ6 pro mount. The camera and QHY are connected to an OAG.  The QHY5 is also connected to the mounts ST4 port. 

On the Rasperry Pi 3 I am running xubuntu with INDI server and PHD2 installed.  Using realvnc to view phd2.  indi server + webserver starts on boot,  static ip on external wifi card starts on boot. 

On my laptop I have EKOS to connect to indi server and phd2 for guiding.  I am running phd2 on the raspberrypi to hopefully this will let PHD2 have a more direct (faster) connection to the guide camera.  

My issue:

Their appears to be a disabled install of ufw which has some groups under iptables.  I enabled the ufw and enbled the ports 4400, 7642 (PHD2), 8624 (indiweb), 7624(indi) however the guiding suite of Ekos would not connect to PHD2.  I disabled ufw and flushed the iptables and tried again with the above ports however the same result.  In the end I have opened all the ports to allow the connection to proceed, which is ok for short term but ideally I would want some security.  

Does anyone know which ports I should open to get indi, indiweb and phd2 to talk nicely to my laptop EKOS version?  

Anyone else running a similar setup successfully?  Can you give me any indications of what pitfalls to avoid?

Thanks

 

Share this post


Link to post
Share on other sites

You need to use the latest version of Kstars/Ekos. There was a bug in 2.8.0 that prevented Ekos from connecting to the external PHD2 but is now fixed.

I assume you have specified external PHD guiding in your Ekos profile?

You might get information over at the Indilib forum 

Share this post


Link to post
Share on other sites

Yeah I was scratching my head about that for a while so i switched to bleeding edge.  That resolved the connection issue but as I said the Raspberry pi will only properly connect if I open all the ports on it, which is less than ideal. I like to know what is going where. 
Yes thanks i'll pop over there and see what they say.  

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Waynescave
      Hi guys
      Can anyone identify which control box this is? Is it focusmaster? And does it run off robofocus driver in Indi lib as I cannot get a successful connection (in indi within ekos) 
      I bought a robofocus motor with this control box second hand. 
      I have faith with seller that hardware works as should. 
      I've tried other cables and USB ports too. The software (k stars) I use does do port search when connecting equipment.. 
       
      Any help appreciated 
      Wayne

    • By BUDA
      Hi All!

      I have guiding problem with the following guider setup: 9x50 finder + ZWO ASI 120mm mini + PHD2.
      The imaging scope is a 6' newtonian + canon dslr on a HEQ5, driven by a laptop via diy EQDIR cable.
      When the mount is set up and running correctly, polar aligned and all... I connect the guider camera
      and mount with phd2. All nice and easy, I run a calibration, then it starts to guide. All seems ok.

      Then I am starting to take pictures. The first seems OK, then the second have the star trails...
      I check phd2 and there is a message: the camera (ASI) did not take a picture for "xy" seconds so it is disconnected.
      Grrr.... I reconnect try to set up a longer period for "xy" in the settings as mentioned in the message.
      And all the same again and again. Whatever I add for connection timeout for the camera, it just reaches that
      and disconnect the camera.
      PHD + philips toucam has worked for me flowlessly. I changed to PHD2 because I gave myself a birthday present,
      the little ZWO camera. (and PHD did not recognize it)
      Do you have any idea what can be the problem? I will contact PHD2 help also, but maybe somebody had already
      the same problem and figured out how to overcome. I am almost sure I make some dumb mistake in the PHD2
      software settings, however I tried to change only what was needed.
    • By Tom Shinal
      Can Nebulosity and Ph.D operate simultaneously and share a single camera. Running Win 10.
       
    • By Forunke
      Ok, so this is a really annoying bug / problem that I have with my setup:
      From time to time, in non regular intervals the image my guiding cam (ZWO ASI120) send seems to get flipped / mirrored or looks like it's from a completely different patch of sky.
      When I'm paying attention to the guide images I can clearly see that the image seems to be flipped in some way.
      It only happens for 1 frame PHD send a warning ( No star found / Star lost Mass changed) and after that everything is fine again. My gear is all connected to a single USB3 Hub which then runs via powered USB3 cable to my Pc.
      I'm not binning and have the noise reduction off (though PHD might got hickups while processing) but it still happens. Sometimes there are minutes between two events sometimes it happens 5 times in a row.
      It also seems like it's only happening during guiding, I haven't seen it happen during calibration yet...
       
      I'm completely clueless what's happening or how to get rid of it, any help / idea is greatly appreciated.
    • By Cemers1
      Hi Guys, hoping someone can help me with the guiding issues Iv'e been having. First of all my setup is:
      Explore Scientific ED80 Triplet  Skywatcher EQ5 mount with synscan  Orion mini 50mm guide scope Altair GPCAM2 AR0130 Mono (as the guide camera) I did my polar alignment and 3-star alignment, which was spot on. So I set up the GPCAM2 and opened PHD2 where I selected "Altair Camera" and "On-Camera". It was all in focus, kept it on the default settings and I selected "auto select star", then it said I was guiding (I can hear the mount making small adjustments). A message popped up saying I needed to increase the max RA duration, then I needed to increase the max DEC duration, which I did gradually by 1000ms each time the message appeared. Still no progress.
      So I restarted the process with the max RA and DEC duration as 8000ms and it said I needed to eliminate the source of the problems.
      (I HAVE ATTACHED IMAGES OF THIS)
       
      I'm not sure why it not working and if I'm doing something wrong. But if someone knows where I'm going wrong, or has any advise it will be greatly appreciated!

      Oh and just let me know if you need any more info, because Iv'e probably missed something out. 
      Thanks again ?

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.