Jump to content

Stargazers Lounge Uses Cookies

Like most websites, SGL uses cookies in order to deliver a secure, personalised service, to provide social media functions and to analyse our traffic. Continued use of SGL indicates your acceptance of our cookie policy.

Doublek42

Celestron Powerseeker 127eq won't quite focus

Recommended Posts

I'm brand new to this site, but I'm having an issue with my Celestron Powerseeker 127eq telescope. It's brand new right out of the box today. I have another telescope, Zhummel Z10, but the celestron just won't focus. It gets so close to focusing and just needs a little more. 

 

Any my help is appreciated thank!

Share this post


Link to post
Share on other sites

Looking at the Celestron site it seems a slightly odd scope to me at least.

The specification is 1000mm focal length and the body looks a lot shorter so that if correct implies the additional barlow in the focuser which increases the focal length. However the specification also says "erect image optics" so they have in that case added or supplied a prism also into the focuser are to achieve this.

If the above are both correct and the erect image prism is a sort of "fixed" part of the scope then they have added a lot of glass/plastic/whatever to the focuser and unfortunately what is added tends to be not that good. Not sure why Synta have this idea that adding unnecessary bits to a scope make it better as it rarely does.

My presumption is that the erect image prism is placing the image from the mirror just out of reach of the eyepiece image plane. Is the erect image prism unit removable? Thinking it might be an item a bit like a barlow that you can insert or remove as required. If removed or not used then is there a short extension tube included that you need to add in. Thoughts here being the prime image is "pushed" out and the erect image prism is acting partially like an extension tube and so without it you need to add in an extension tube.

Which way, in or out, does it appear to need a bit more movement to achieve focus.

Share this post


Link to post
Share on other sites

Doublek42, I don't recall having the same issue that your having ( ronin - the erecting prism is removable), but I do recall after the first use, how infuriating and time wasting this scope was for visual observations only, and if your thinking your going down the astrophotography route, the GEM is just too wobbly, unstable.

The manual mentions 'return to factory' for collimation ? In all honesty, I would wrap the scope back up, tell them it won't focus, and refund your money, rather than try and solve this situation, on the basis ( my opinion )  that if it did work, your not going to see much anyway from this scope? If you find that removing the  correcting eyepiece ( I would suggest this is for terrestrial use only )  gives a better view with the longer focal length eyepiece, then you may want to stick a little longer with the scope, but image quality is/was pretty poor,  even after learning more, cleaning, collimating, centre-spotting and better eyepieces! and and lastly, the Jones-Bird construction ( long focal length ~ short tube ) makes for further issues along the way?

Get  yourself a refund, I know this reply is pretty blunt, and is not helping the immediate situation. That scope,  taught me how to setup the mount, and gave me my first view of the moon ( even that image is mediocre compared to my 200P) but apart from that, the scope itself ( my opinion) is about as useful as a chocolate fireguard.

If you just looking for some decent visual observations,  jump to a 150Por 200P you won't regret it.

  • Like 1

Share this post


Link to post
Share on other sites

Hi Doublek42,

I have had some experience with this scope some time back. If I recall the image erecting prism is in the lower power eyepiece supplied. You mentioned that you have a 10 inch Dob so I am guessing that you want the PowerSeeker for portability. If this is the case I would agree with Charic and it  would be better to return it and get something else for this purpose. Honestly I do not know why Celestron markets scopes like this. Its fast primary mirror makes it very sensitive to collimation and the mount makes using  the 4mm eyepiece at 250x extremely hard. It is not suitable for beginner or advance users. And a 3x barlow is included - really Celestron!!!

Good luck!

Edited by beka
Added bit on barlow.

Share this post


Link to post
Share on other sites

Oops, not sure how I missed the Z10? (cheers beka ).

My thoughts otherwise remain the same.

Share this post


Link to post
Share on other sites

I just got the powerseeker 127eq and been doodling around the collimation; quite harder with this one and very unstable mounts and hard to maneuver.

About focusing, I get this after couple of tries. This is about 1/4 mile away through my backyard glassdoor.
Camera: Sony a6000 with t-ring / T2 mount, exp- 4sec, ISO-100.

I will give it another go on the field; the one on my pro pic was taken with 55210mm sony; if I didn't get any sharper outta that, I'd throw that away w/o wasting time. :huh::tongue:

DSC00296.thumb.JPG.e6fa10b8877d44ccf2c2ff3fb395ad4e.JPG

Share this post


Link to post
Share on other sites

I expect you are running out of inward focus when trying to focus with a camera.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By JamieHardcastle
      Hi everyone,
      My other half bought me (us) a Celestron 130 for my birthday recently.
      I have watched tutorials and done a lot of reading about collimating and various other tips since alongside several hours peering through the telescope.
      I can achieve a very crisp image of the moon which is awesome. However, trying to get a decent focus on Mars/Jupiter Saturn is proving very frustrating. The only non-blurred image of any of them is a single white-point, non dissimilar to what I can see via the naked eye. 
      i’ve tried both the 20mm & 10mm lenses and adjusted the focus in and out all the way.
       
      Any advice would be gratefully received.
      thank you, in advance.
    • By MountainDog
      I have just encountered an error message which says "NO RESPONSE 16" when I power up my 130slt. Has anyone else experienced this issue?
    • By Dario
      Hi everyone!
      As I said few days ago in my presentation I recently got my first scope  (skywatcher 127) and over the last days I tried to test It.
      Due to impossibility (temporary) to bring the scope in a decent location to make observations, I had to test it from home through a window  (and under the sky of London - not the best at all). So i know that quality is of course affected.
      On the other hand, I am sure that the performances are worse than I could expect also under these conditions (maybe you will correct me) and would asks for opinions to improve.
      As a (mainly) planetary scope, I did not have a lot of choice: no Moon, Jupiter and Saturn out of my field of view. I pointed at Mars.
      First sight, I see the very big central obstruction. I played with the knob of the focus to get rid of the big black spot in the centre of my target and here you are the issues that I would like to talk about:
      1) the target became very small (ok) but still was not focus  (very blurry and not a lot of clues to get atleast the shape of the planet well defined - can imagine to find any detail on it )
      2) Also the colours did not convince me as no other colour than a light yellow was visible
      3) Changing the eyepiece  (10 instead of 25) for a magnification of 150x did not improve the situation: probably the image was even worse, more blurry with more irregular shape than before, no ability to focus at all. Differences from before : bigger (but still much smaller than expected) and very little variation in colours (I believe I saw a bit of orange).
      To complete, later, I tried the scope to stars: Orion costellation was visible from my place and tried to all the stars. Although still a bit blurry  (the brightest stars), I had impression of more sharp view, differentiation in colour and better shape  (stars almost like a dot). Moreover, to give you a final idea, Mars (at the best focus I could get) did not appear that much bigger than Betelguese.
      What do you think I can do to get better results? Could be a scope problem or some adjustments needed? Unfortunately I have no comparisons. 
      Thank you, Hope I was not too long 😅
    • By NightSky_Wanderer
      Hi,
      I am hoping someone here may be able to offer some help or advice. I have submitted a support ticket with Celestron but I am still waiting for a reply and would really like to get this working ready for the next clear sky!
      I recently brought a starsense but have not been able to use it because it comes up with the following errors,
      Err: Model Num
      The telescope model could not be read and initialization cannot proceed.
      Critical error!
      File: ..\source\mo
      Line: 1468
      An unexpected error occurred that may cause the HC to not opperate normally.
      When updating the controller and camera it finishes succesfully but when I check for new updates it proceeds to install the same one again and again.
      I can still control the mount and I think the camera tried to do an alignment in my room.
      I have a Celestron Nexstar 6SE.
      Thanks
      Adz
    • By Witcherking10
      Hello all,
      I always been fascinated by astronomy and finally purchased a celestron nexstar 8se. Setup went smoothly but I'm a little stuck on the lens. I attached the star diagonal to the telescope and focused in on an object. I was able to see a part of the leaf on the plant in my house and I attached a picture of that. Moving the telescope left and right allowed me to see other things. I then took out the 25mm lens and can see through that when not attached to the telescope. I can see my sandals and feet through the lens and attached a picture of that. I then inserted the 25mm lens into the star diagonal and that's where all hope gets lost. I see white (assuming that's my wall) and yes the cover on the telescope is also off. No matter where I move the telescope. All I see is white. I tried last night in clear skies and pointed towards some clear stars using the skyportal app to align but I didnt see anything except pitch black through the lens. I also played with the focus but nothing. Am I doing something wrong, I would think the 25mm wouldnt be so zoomed in that I cant see anything? Thanks for any help you can provide me. Looking forward to exploring!!




×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.