Jump to content

Stargazers Lounge Uses Cookies

Like most websites, SGL uses cookies in order to deliver a secure, personalised service, to provide social media functions and to analyse our traffic. Continued use of SGL indicates your acceptance of our cookie policy.

sgl_peoples_choice_2018_banner.thumb.jpg.f1bf2f8261e1689d19f116486df2bc89.jpg

Jim Smith

StarLight Live V3.3 command line parameters on Windows 10

Recommended Posts

I have had some success with command line parameters when launching SLL 3.3 on my OS X macbook.

I thought I would explore the possibility of using my Windows 10 Surface as an alternative or back-up.

When I run SLL v3.3 on my Surface It appears as a small, scrunched-up mess. However, I believe using the '-platform windows:dpiawareness=0' argument will fix this. Sadly I can't persuade SLL to take any notice of my command line parameters.

My batch file with contents...

C:\"Program Files"\Sll33\StarlightLive.exe -platform windows:dpiawareness=0 -prepend-title-text jim

...runs SLL but there is no difference to when I leave the command line parameters off.

I think I must be doing something wrong! Any ideas?

Share this post


Link to post
Share on other sites

I can't comment on either StarLight Live or the dpiawareness argument but the structure that I would use in my batch file would be slightly different from yours and this *may* have an affect:-

start "" "C:\Program Files\Sll33\StarlightLive.exe " -platform windows:dpiawareness=0 -prepend-title-text jim

  • Like 1

Share this post


Link to post
Share on other sites

Thanks Steve. That makes all the difference! It works!

  • Like 1

Share this post


Link to post
Share on other sites

Watching this with interest as my win 10 laptop doesn't play nicely with sll 😕

Share this post


Link to post
Share on other sites

We crossed!  Pleased to see success 😀.  Can you explain to a numpty how I need to do this please??

Thanks

Helen

Share this post


Link to post
Share on other sites
16 minutes ago, Jim Smith said:

Thanks Steve. That makes all the difference! It works!

Excellent news - pleased it sorted it for you!

Share this post


Link to post
Share on other sites
16 minutes ago, Helen said:

We crossed!  Pleased to see success 😀.  Can you explain to a numpty how I need to do this please??

Thanks

Helen

Hi Helen,

Use a text editor like 'Notepad' and copy in the code I posted above. Save the file somewhere convenient with a recognisable name BUT with the extension .bat rather than .txt

If you now run the new file (known as a 'batch' file'), it will carry out the actions in the code.

HTH

Share this post


Link to post
Share on other sites

Helen, thanks to Steve, my .bat file now contains the following single line...

start "" "C:\Program Files\Sll33\StarlightLive.exe" -platform windows:dpiawareness=0

(I created a .txt file with Notepad and renamed it to .bat) (Also notice that my StarlightLive.exe may be in a different folder to yours!)

When I double click on the .bat file it gives me the nicer version as shown below. If I just launch SLL 3.3 in the normal way I get the squished version, also shown below. 

 

after.PNG

before.PNG

Share this post


Link to post
Share on other sites

Thanks both :headbang:  Will try later and report back!

Helen

Share this post


Link to post
Share on other sites

This has been an ongoing problem using Sll on my surface pro 4 and as one not being so clued up on tech have put up with the squished text. Any chance of a line by line how too! I normally like to fix things with hammers:help:

 

Share this post


Link to post
Share on other sites
46 minutes ago, greealilee said:

Any chance of a line by line how too!

Do you know which folder your StarlightLive.exe file is in? (Try searching your C: drive for it in File Explorer.)

Share this post


Link to post
Share on other sites

You don't need to create a new batch file.  You can just add the command line parameter to your existing Starlight Live shortcut.  Just add the necessary parameter to the end of the line in the "Target" box of the shortcut icon.

Right click the Shortcut icon to Starlight Live and select "Properties"

Add a space to the end of the string in the Target box and then add -platform windows:dpiawareness=0 

Then click "OK"

Your program will always launch with that parameter.

  • Like 1

Share this post


Link to post
Share on other sites

Thanks everybody for the help, Rob your a star and have just followed your instruction and it now works a treat. Can you now tell me how to get rid of the clouds:happy7:

Share this post


Link to post
Share on other sites

You have to add the -clouds flag to your shortcut. :)

  • Like 2

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

By using this site, you agree to our Terms of Use.