Jump to content


Lynx FTDI cable


Recommended Posts

Morning All,

Last night was very unusual as there was not cloud :icon_biggrin: so thought I would make the most of it and fire up the kit and try out my new filter.

Now this is a new pc (old pc) but it was bench tested with all the kit and was working fine before finally being put in place.

No matter how I tried I could not get phd2 or phd to connect to the mount and just kept getting timeout errors.

I reloaded the dirvers but nothing, tried all usb ports but no joy. The computer would acknowledge that a usb device had been connected put eqmod would always time out.

I am so upset that I missed a rare opportunity to do some imaging especially if this user error.

eqmod showed that I was connecting to com3 as did the device manager but when I searched in eqmod it would not find anything.

Has anyone come across this or do you know the answer. I will go home tonight after work and have another go in daylight but thought I would check here first.





Link to comment
Share on other sites

Sorry to hear you are having a problem with the cable - we test each of these with a mount and eqmod prior to despatch and have yet to have one come back as faulty. If you think this may be the case please drop us an email to questions@firstlightoptics.com and we would be happy to swap the cable over for a new one and check the returned one ourselves.

There are some things you could try first though - the connection timeout usually occurs when the wrong port is selected. I find it best to always manually select the port from the 'Driver Setup' option in the EQASCOM Toolbox - the search never seems to work correctly for me and because the Lynx Astro EQDIR adapters remember the port they are plugged in to, in theory you should only need to do this selection once.

If you can get it to connect and operate the mount using EQMOD then PHD etc.. shouldn't be a problem but at least at that point you will know everything is working OK and anything else is going to be software or configuration issues.

One issue we have seen is where a mount was underpowered with an unsuitable power supply which caused issues with the connection - once changed to a better power supply the issue went away. Poor power supplies or inadequate power is a common issue we see with many mounts so it's always worth double checking.

Link to comment
Share on other sites

Thanks for the info. The kit was fine using my laptop but I have replaced this with a desktop pc and I had bench tested it before and it was fine. It just would not play ball last night.

I will connect later using the laptop again and see if things still work then go back to the desktop. I just could not face having to do this last night.  I am sure its user error as nothing has changed only the computer.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. By using this site, you agree to our Terms of Use.