Jump to content

sgl_imaging_challenge_banner_31.thumb.jpg.b7a41d6a0fa4e315f57ea3e240acf140.jpg

USB Selective Suspend, the end of a problem...


Recommended Posts

I have long had a peculiar problem with my G3 (Orion) camera program freezing, or locking up. Then, the only apparent fix was to unplug the USB cord and reinsert it, and restart the Orion Camera Suite. It was really bad when I used a non-powered hub with my laptop. A powered hub helped a lot, but did not entirely stop this annoying problem. Even Orion was scratching their heads with no suggestions.

After adding a AAF2 Mark 2 Focuser, a new monster reared its head along this line. Since I have had to retreat my mount to the house while a storm comes and passes, I thought I would work on what could be causing my USB woes. Happy in having decided it was not a program related problem, I turned my USB detective work towards the laptop itself. Lo and Behold, I think I found a culprit...

I run a PC, and have had Windows based operating systems since DOS 3.11. I've always been able to fix my own by bumble-fumbling my way through. So I began searching for USB freezing or dropping out fixes. Something that cropped up was "How to Fix an Annoying Windows USB Problem". And so far, it's working.

usb-selective-suspend.png

Mining down to this little 'helper' was a bit fun. But I got there. Now this "USB Selective Suspend" is implanted with, I'm sure, good intentions. It's purpose is to conserve power by suspending idle USB ports.

But it apparently misses the boat for those of us sitting in the night trying to keep our telescopes running along, albeit, sometimes slowly.

By disabling this "feature", my laptop and the programs I use, including TekkyDave's AAF2 has run for over 6 hours now. It is a major milestone for me to finally find a work around for a most annoying problem. I most often have my computers on, and plugged in, and on auto-update. So if you are having some odd things from your USB connected devices, it may not be your equipment, nor your programs, but some obscure little helper buried down in the advanced settings of your operating system.

Worth a look...

  • Like 2
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By NeilDMunro
      Hi,
      I have been attempting to update my SynScan V3 Hand Controller from V3.08 to latest version. Handset bootloader is V1.7.
      Unfortunately I just get the message “Can not connect to SynScan hand control”. I have looked at numerous forums and tried everything that has been suggested (including older versions of firmware installer), but getting nowhere.
      I am using a Skywatcher SynScan USB Adapter (purchased from Bristol Cameras) and installed the driver from the Skywatcher website. The adapter shows in the COM ports and says it is working properly.
      I have tried different computers (Win10 and XP) with no joy.
      Can anyone help, or is there anyone in North Aberdeenshire that has successfully updated their handset willing to give mine a go (once travel restrictions, etc ease)?
      Thanks
    • By astrosathya
      Hi Everyone,
      While we all know that there are plenty of hubs out there in the market like Hitec Astro Hub and Pegasus Astro Hubs for providing 12VDC and USB comm link for good cable management, I am a DIY person with little to no experience in electronics. I do know how to solder reasonably well. 
      I am looking to see if someone here could help me with a circuit diagram for a hub that gives has 5x12VDC output, 3x5VDC output and 4xUSB powered hub for communication. I would then go out, purchase all components and build one for myself.
      This is only so that I don't have too many cables dangling off of my mount and becoming a constant trip hazard.
      TIA guys.
       
    • By ScopeDog
      Hi
      Just tried out my new (to me) Canon 6D Mk1 at Galloway Star Party and discovered that my Windows 7, 64bit laptop doesn't see the camera when I try to connect it by USB, so I can't control it with BackyardEOS.
      I've checked the device manager and it just doesn't come up when connected and switched on plus I've tried different USB ports. However, I don't have the same problem when I do the same with my Canon EOS 450D using the same cable with the same laptop.
      Am I missing something important here? Pretty frustrating given it's the first time I've been out under a sky that good in a long time
      Thanks in advance,
      Tom
    • By kbrown
      Got tired of the mess of cables and loose devices I had to always put together and dismantle after each astrophotography session so I figured I'd do something about it. This tray will sit nicely under the tripod and provide a hub for everything including Fused Power, Raspberry Pi, USB Hub, GPS, Dew Heaters, Long Range WiFi etc...
      First version will be really crude as I need to have this working in less than a week as I'm going on a holiday taking my astro gear with me.
       






    • By bottletopburly
      Just sourced a USB lead to power my canon 1000d/500d , looks promising works on usb2 fine but not usb1 , 16000mah battery bank works , works on a galaxy tab2 USB charger but not in an Apple iPhone USB charger  yet to check it on my powered USB hub , I was looking to get away from the 240v mains powered charger .
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. By using this site, you agree to our Terms of Use.