Jump to content

sgl_imaging_challenge_2021_annual.thumb.jpg.3fc34f695a81b16210333189a3162ac7.jpg

EQMOD randomly stops tracking


Recommended Posts

Hi All

I have been using my 'best' laptop with Windows 8.1 to control an EQ5 Pro mount via a USB/Serial converter with a lead directly to the hand controller set to PC Direct Mode.  On the same laptop I have installed PHD2 for guiding and BackyardEOS for image capture and a gampepad for ease of 'tweaking' the telescope pointing. I have also installed Cartes du Ciel (CdC) to find and slew to targets.  This system has worked flawlessly (other than 'idiot induced' problems) for a number of months now.  I was lucky enough to be given another, slightly older, laptop to use so I thought the 'best' laptop could stay in the office and the older laptop could now become the astro imaging laptop.  As far as I can see, I have everything configured the same and, on first trials in daylight, everything seemed to be working OK.  Could connect to the mount OK, control via gampad OK, PHD2 connected OK etc etc.

First 'imaging in anger' night seemed to going well until I noticed that the star trails suddenly appeared to be streaked after successfully capturing a few previous images.  PHD2 was still connected but the guide star was way off target (the little green square in PHD) and appeared to be drifting as I watched.  CdC (the planetarium software I use) was still connected but the rectangle indicating the camera's field of view was also drifting off target.  On looking at the EQMOD window I noticed that tracking was 'off'. "Another idiot induced problem?" I thought.  Selected Sidereal Tracking in EQMOD and I heard the motors of the mount start 'whirring' again.  Selected target in CdC and slewed the 'scope back to the target.  Selected guide star again in PHD and guiding started OK (I could hear the motor 'tones' changing  as they received correction signals from PHD.  Back on track - so I thought!  After a short while, the problem occurred again - Sidereal tracking was shown as being turned off in EQMOD.

These are only differences between the successful setup and the rogue version;

Working System 2.4ghz processor, Windows 8.1
Failing system 2.2ghz processor, Windows 7

Has anyone else had this problem?  Any suggestions as to what could be causing this problem would be greatly appreciated.

Thanks
Richard

Link to post
Share on other sites

**Update**

I have taken PHD and CdC out of the equation by connecting to the mount via the EQASCOM Toolbox.  With PHD and CdC not running and the gamepad turned off the mount tracked for about 10 minutes before the Sidereal Tracking 'switched off' again.  Without doing anything to the setup, I tried slewing the 'scope using the direction arrows in EQMOD and these worked fine so the mount is still communicating with the laptop and EQMOD.

It seems to me that the problem could be with EQMOD 

or could it be Windows 7 :-(

Edited by morayskies
Link to post
Share on other sites
20 hours ago, Uplooker said:

Are there any "Limits" set within EQMod?

Hi Ian

Must apologise.  I have found the "Mount Limits" check box to be ticked and, since unticking, seems to be tracking OK.

In the words of Homer Simpson - "Doh!" :confused2:

 

  • Like 1
Link to post
Share on other sites
16 hours ago, Uplooker said:

Hi sorry, only seen your reply(s).

Glad you got it sorted. If that is the biggest "Homer" moment you have in astronomy you are doing very, very well ?

Had 3 or so hours of success last night.  'Scope tracked well, tracking and guiding didn't fail at all and only had to stop when camera battery died.  First attempt at M42 with this setup :-)

 

Well pleased.

m42_120s_50percent.tif

Link to post
Share on other sites
  • 3 years later...

I have that tick box checked but I’m finding my mount just stops tracking after around 15mins, it’s really annoying. 
any thoughts?

ive read that it could my my USB port on my laptop turning itself off to save power. But my mount battery died before I could try this out. 

 

Edited by Sidecontrol
Link to post
Share on other sites
12 hours ago, Sidecontrol said:

I have that tick box checked but I’m finding my mount just stops tracking after around 15mins, it’s really annoying. 
any thoughts?

ive read that it could my my USB port on my laptop turning itself off to save power. But my mount battery died before I could try this out. 

 

I started with an EQ5 Pro and using EQMod via the hand controller. Had the exact same issue. Mount would stop tracking after a few minutes. Unticking the mount limits box fixed it. A strange quirk if working through the hand controller.

  • Thanks 1
Link to post
Share on other sites
4 hours ago, david_taurus83 said:

I started with an EQ5 Pro and using EQMod via the hand controller. Had the exact same issue. Mount would stop tracking after a few minutes. Unticking the mount limits box fixed it. A strange quirk if working through the hand controller.

As it stands it seems to work, before I made a change it cut off after like 2 mins lol once I made the change it’s currently been going for 20mins. 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Ade Turner
      Now I’ve managed to sort out control of my EQ6-R Pro using Stellarium via EQASCOM, I’m working my way through the other equipment I want to control from my Windows 7 laptop.
      I’m stuck trying to get my Celestron focuser to be recognised. This is what I’ve done so far:
      Downloaded the Celestron Focuser Utility Program (.exe file) from here: https://www.celestron.com/pages/manuals-software Also downloaded the December 2019 USB ASCOM driver set up from above. I ran the ASCOM driver set up and restarted the laptop. Connected focuser direct to laptop via USB. The focuser’s power light shows red and in Windows control panel it recognises the device as ‘Celestron Focuser’ but indicates no driver present. Ran the Celestron focuser utility program hoping it would connect and install the right driver so I could calibrate, but it can’t detect the focuser at all. Finally, ran APT to see if I could connect by choosing the ASCOM driver under ‘Gear’ but this doesn’t work either. Stuck now. I’m guessing I need to somehow ‘tell’ Windows where the driver is...? 
      Any thoughts? Thanks everyone
      🙂
       
      EDIT: I have previously had this focuser working correctly both with StarSense handset and via ASCOM (Celestron unified driver) through the aux on my old Evolution mount. However, now I’ve changed to a Sky-Watcher mount, I need it to function direct through USB.
    • By Ade Turner
      I’ve just bought a Skywatcher EQ6-R Pro. I’m trying to drive it from Stellarium using EQMOD but I’m running into a problem I haven’t the experience to solve.
      This is my set up:
      Windows 7 Laptop > 10m active USB 3.0 cable > 4 port powered Atolla USB 3.0 hub > Lynx Astro EQMOD cable > Mount (plugged directly into hand control socket)
      When I first connected the mount to the laptop (a 2015 Dell Inspiron) Windows 7 searched for a serial/USB driver and installed it on COM 8 (according to Device Manager).
      In Stellarium I created a profile for the mount but it wouldn’t autodetect the COM port. So I manually set it to 8.
      When I try to connect to the mount it sits for a while and then tells me the connection has timed out.
      Anyone have any suggestions as to where I should start to try and get the connection sorted please? Thanks.
    • By williamnohair
      Hi
      am posting this in case it helps anyone who has suffered the same problem as myself.
      In a nutshell: Own a Skywatcher Gti mount for some time now and used with some success, also purchased some time ago Skysafari and wanted to use both, with a problem much reported on the web and so much information out there that it can get a bit confusing and certainly in my case frustrating, after all just want stuff to work!
      After much experimenting and help from other postings this is what happens when you fire up the Gti.
      The mount generates its own wireless network and becomes the gateway, its IP address is always 192.168.4.1 you see this when making a connection with the Synscan app/program, its very similar to a normal router that serves you the Internet. Any device that then connects to this network then gets an assigned address one up from this, i.e. 192.168.4.2, .3, etc. However if you run the Safari app and go in to settings you will find it has also been allocated an address which is one up from the device you are using. In my case my Ipad was connected to the wireless network and had been given the address of  192.168.4.3.  but when I checked the IP address in the settings page of SkySafari it was 192.168.4.4 !
      If you accept this you get the error that the app cannot join the wireless network check your settings etc. If you now manually change that address to the same as the device running the Synscan app in my case .2 it should connect and work. However there is a caveat to this, I tried using an Iphone  4 and an old Ipad and they would not work together no matter what. I got the other error message that I had joined the network but the mount did not recognise the device type I had selected (Skywatcher Synscan Alt Az GoTo) and no amount of changing things would solve it. To get around this I used my trusty Win 7 laptop to run the Synscan program and things worked perfectly so it can be done don't give up!
      Sorry this is so long but I hope it helps someone out there. So to round off when you fire up the mount it becomes address no 1, any physical device gets the next address 2, any software running on the that device gets the next address 3. When you fire up SkySafari it must have the same address as the one that the SynScan app has got and this can e changed in SkySafari settings. None of this makes any sense to me as I thought software couldn't act in that way but there you are. I hope I have got this right feel free to contact me if things don't work
       
      Regards
       
      Bill
       
    • By morayskies
      Hi All
      Has anybody else had this problem?
      I use a single, ageing laptop (HP620 8Gb RAM) running Windows 7 Pro 64bit to control my imaging setup using the following software;
      Cartes du Ciel and EQMOD to control EQ5 Pro mount via EQDIRECT cable connected via powered USB Hub
      BackyardEOS to capture images from Canon 450D via same USB powered hub
      PHD2 for guiding using GP-CAM 130C and EQMOD pulse guiding
      What confuses me is that some evenings everything works absolutely fine.  Another evening, using exactly the same hardware, software and even connections (ie I always plug the leads into the same ports) the system will be working fine but then suddenly fail.  The failure affects EQMOD indicating a timeout or port not available issue and the Canon 450D also 'locks' requiring a restart of the camera and BackyardEOS.
      I have run USBTree during such a failure and it is showing that the EQDIRECT cable (ie serial converter) is still connected to COM4 (which is correct) and the Canon 450D is also still connected.  I basically have to ensure that all the software is closed and any associated services also stopped.  Of course, the scope is now pointing away from its home position so I have to move it manually back to 'home' before starting again.
      My thoughts are that there could be a number of issues;
      1. Use of a USB hub
      2. A dodgy EQDIRECT cable
      3. USB cables too long (ie about 5m)
      4. Windows is turning off a connection (I have set the power management for each USB port to 'off')
      5. Canon 450D somehow 'freezing'

      When using this laptop, I turn off the Wifi and Anti Virus and Automatic Updates are also off.
      It just baffles me that sometimes this system works flawlessly for hours and yet other nights it keeps failing.
      Any suggestions gratefully received.
      Thanks for looking.
    • By Demonperformer
      I am at a complete loss to understand why eqmod was not syncing on CdC last night. I have had a look at this video, I had the star centred on the screen [3m33s], I pressed sync on CdC, I got the dialog box [3m39s], I clicked 'yes' and NOTHING happened: the white circle stayed where it was, no sync points were added to EQMOD, zilch!
      I can get round most problems, but this really one stymies my GOTOs and, therefore, my imaging process.
      I have been unable to find anything in the EQMOD documentation that deals with such an error and a search on here has turned up no help (but that always depends on the words put into the search!). I checked all the obvious things (location, date/time, etc - but why any of these should stop sync working is beyond me). It's all running on Windoze 10.
      Any suggestions on why this should have stopped working and (more importantly) how I might get it working?
      Thanks.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. By using this site, you agree to our Terms of Use.