Jump to content

Stargazers Lounge Uses Cookies

Like most websites, SGL uses cookies in order to deliver a secure, personalised service, to provide social media functions and to analyse our traffic. Continued use of SGL indicates your acceptance of our cookie policy.

Mart

EQMOD with EQ8 no longer Parks to Home position ?

Recommended Posts

I have an EQ8 worked through EQMOD connecting with a number of clients - TheSkyX, MaximDL, CCD Commander etc.

I ran a CCDC script last night and was puzzled as to why when it did a "Park" command the mount put the scope on its side. A Park from any client has always (in the past) put the scope upright with weights down (my Home position). However, EQMOD still Parks to the Home position.

I've been trying lots of things this morning, turning off - moving scope - turning on;  resyncing encoders; autohoming using SynScan handset and rehoming .... but not fixed the problem.

The EQMOD message centre shows when I use EQMOD to Park the scope:

Slewing mount to home position

I've now tried the Park command from three different clients and they all do the same sort of thing:

CoordSlew: RA[ 01:55:00 ] DEC[ +87:48:44 ]
Goto: 01:55:00 +87:48:44
Goto: 01:55:00 +87:48:44
Goto: 01:55:00 +87:48:44
Goto: 01:55:00 +87:48:44
RA Motor set at Sidereal rate
Goto Slew Complete. 01:55:00 +87:48:44
Goto: SlewItereations=4
Goto: RaDiff=000.03 DecDiff=000.02
CoordSlew: RA[ 01:55:33 ] DEC[ +87:48:44 ]
Goto: 01:55:33 +87:48:44
Current location set as new park position.
Goto: 01:55:33 +87:48:44
Scope parked. You may turn it off after slewing

When I do a Park, EQMOD is doing a slew to a specific coordinate ?

I've done a lot of fiddling with the software to get it working after a Windows 10 Anniversary upgrade (lots of discussion elsewhere) so am guessing I've changed something somewhere along the way that has change what the ASCOM Park command now does.

EQMOD is configured with "Park Mode" as "PARK at Home Position" - but this only seems to apply when I Park from EQMOD, if I park from ASCOM clients it does this CoordSlew.

Any ideas ?

Share this post


Link to post
Share on other sites

If you want to park form ASCOM you have to first use the ASCOM setPark command to set where the mount will go when the ASCOM Park command is issued. EQMOD never parks by going to a RA/DEC coordinate (that really makes no practical sense) and parks are always performed by moving to a axis  encoder position. Why you're clients are issuing coordinate slews I don't know - probably are implementing their own (inherently flawed) parking strategy and wrongly assume that when they issue an "ASCOM PARK" EQMOD will park at the current position.

So the correct procedure should be to first move your mount to your preferred ASCOM parking position and the issue an ASCOM setpark. EQMOD will note the encoder positions at the time it receives this command (and store them in its ini file), When your client/script wants to park the mount it then only needs too issue the ascom Park command and EQMOD will move the mount to the saved position.

Chris.

Share this post


Link to post
Share on other sites

Thanks Chris. Still puzzled.

I've found set park commands in TheSkyX and POTH but neither seem to be permanent. When I disconnect and power down the scope and PC and power it all up again the client software is still sending the mount to somewhere other than my Home position.

I wrote a VBscript to perform an explicit setpark and have put that at the beginning of my CCDC script - so long as the mount is in the Home position I can then run the CCDC script and the Park commands work.

I just didn't need to do all this "last week"?

Share this post


Link to post
Share on other sites

One thing you might try is setting EQMOD to use synchronous parks (a setup screen option). By default EQMOD will perform an asynchronous park which means that when it receives the park command it starts the parking process and immediately returns control back to the client. The client should then poll the ASCOM  AtPark property to determine when the park process has completed. With a synchronous park EQMOD will not return control back to the client until the Park process is complete. In general asynchronous provides a  better automation control method the client get on with other important jobs whilst the mount parks - but maybe CDDC is expecting synchronous behavior - clutching at straws but something to try.

Chris.

Share this post


Link to post
Share on other sites

Hello Mart!

 

Try to join the group EQMOD here you will find help there, and one more issue, try to use the newest  EQASCOM_V200g , this has some nice futures for EQ8 and others mounts also  compatible to EQMOD..

 

Cheers

 

Martin

Edited by artem

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.