Jump to content

sgl_imaging_challenge_2021_annual.thumb.jpg.3fc34f695a81b16210333189a3162ac7.jpg

Setting Up Headless Raspberry Pi 3 for INDI Focuser


Gina
 Share

Recommended Posts

Procedures for installing Raspbian and INDI library etc. on a new Raspberry Pi 3 B and micro SD card.

I shall insert links where appropriate to places where various pieces of hardware and software may be obtained.  In most cases there are other sources of hardware which might be cheaper (but not necessarily better).

I shall describe the procedures as I do them with suggestions I think appropriate.  I shall post in fairly small steps to make things as clear as I can as I hope this will be useful to others.

The operating system is Raspbian Jessie Lite (Release date: 2016-09-23)  which is a minimal installation with no GUI and hence called "headless".  This will be installed on a new 8GB micro SD card using a USB card adapter and Win32DiskImager software to install using Windows (I'm using Win7).

  • Like 1
Link to comment
Share on other sites

After downloading Raspbian Jessie Lite, the .img file is extracted from the .zip using Extract All from the right click menu on the .zip file.

Next stage is to write the .img file to the micro SD using Win32 Disk imager.  These screenshots show the process - firstly run Win32 Disk Imager and check that it has chosen the right device for writing.  Select the Image File (2016-09-23-raspbianjessie-lite.img) and Open it.  Finally, Write the image to SD.

Win32DiskImager 01.JPG
Win32DiskImager 02.JPGWin32DiskImager 03.JPG
Win32DiskImager 04.JPG

Link to comment
Share on other sites

Micro SD card inserted into Raspberry Pi 3 B and the latter powered from Raspberry Pi Mains Adapter.  RPi connected to router with Ethernet cable.

Run PuTTY and insert IP Address for the RPi - this may be obtained from your router management screen.  You may want to alter the text size of the PuTTY screen display from the tiny 10 point default - I changed it to 18 point.  Once things are set up, it's a good idea to Save the settings for future use - type the file name for the saved info in the Saved Sessions box and click Save.  These procedures are shown in the following screenshots.  Note - the Saved Sessions include my earlier sessions for other RPi sessions.

IP Address 01.JPGPuTTY 01.JPGPuTTY Configuration 01.JPGPuTTY Configuration 02.JPGPuTTY Configuration 03.JPG

Link to comment
Share on other sites

Next step is to Open PuTTY.  With the new SSH connection, PuTTY comes up with a Security Alert asking you to check that you're accessing the right host computer.  Click Yes to confirm and the SSH login window is displayed.  Log in as pi with password of raspberry and the initial text is displayed followed by the command line.

PuTTY 02.JPGPuTTY 03.JPGPuTTY 04.JPG

Link to comment
Share on other sites

We are now ready to apply any updates/upgrades and set up system files and install software.  First though we need to expand the file system to make room for installing software.  Details about this are here :-  raspi-config

Ran sudo raspi-config and Expanded Filesystem also changed password to a shorter one.  System rebooted to make changes effective with  sudo reboot.   Now need to re-run PuTTY as rebooting closes the session.

New session :-

PuTTY 05.JPG

Link to comment
Share on other sites

Next running sudo apt-get update and sudo apt-get upgrade to update repositories and upgrade software.

Screenshots showing end of update and ready to upgrade.  With the "Y" a Return will answer yes and let the upgrade proceed.

PuTTY 06.JPG

PuTTY 07.JPG

Link to comment
Share on other sites

With the OS upgrades completed we can now install libraries.  We need the bcm3825 chip library to use the GPIO and the INDI and Astroberry libraries for the hardware drivers and INDI server.

bcm2835 library added using the following command lines, executed one at a time.

wget http://www.airspayce.com/mikem/bcm2835/bcm2835-1.50.tar.gz
tar xvfz bcm2835-1.50.tar.gz
cd bcm2835-1.50
./configure
make
sudo make install

Next to make this up to date with sudo apt-get update and sudo apt-get upgrade.  And sudo reboot to finish the installation.

PuTTY 08.JPG

Link to comment
Share on other sites

NOTE - If at any time you want to shutdown the RPi rather than just unplugging and risking corrupting the system it's best to shut down the OS properly using sudo shutdown -h -P now.

Link to comment
Share on other sites

Installing the INDI library full edition next.

First to install the dependencies :-

sudo apt-get install cdbs libcfitsio3-dev libnova-dev libusb-1.0-0-dev libjpeg-dev libusb-dev libtiff5-dev libftdi-dev fxload libkrb5-dev libcurl4-gnutls-dev dcraw libgphoto2-dev libgsl0-dev dkms libboost-regex-dev libgps-dev libdc1394-22-dev

The instructions tell you to download the INDI library next but no instructions for using a headless RPi - only downloading with a graphical interface.  I ended up downloading the indilib file to my Win7 desktop and copying the file to the RPi using FileZilla to FTP across to the RPi. 

Just entered the RPi IP address in Host then Username and Password, Port 22 - then clicked Quickconnect.  Transferred from local window to remote window with drag and drop.

Here is a screenshot of the FileZilla window on Win7 and the resultant list of files on the RPi in the PuTTY window.  (Linux command ls lists files in current directory.)  Incidentally the file "index.html" is there as a mistake on my part.  I could have used FileZilla to delete it while I had it open but I didn't.

FileZilla 01.JPG

PuTTY 10.JPG

Link to comment
Share on other sites

That was yesterday and today I have tried an update and upgrade and new download of the indilib daily build file and run dpkg to install with the same errors! :(

Now I'm stuck and need advice, please.  Pretty please :)

Link to comment
Share on other sites

Excellent post but, just a suggestion, I wouldn't be advertising specific network information (as per your third post). 

Information can be trawled but not publishing it will at least make a hacker's job a bit more difficult ...

AndyG

  • Like 1
Link to comment
Share on other sites

Instructions to cure the problem were :- 

# apt-get install linux-image-generic
# apt-get install linux-headers-generic

but that has resulted in a different problem.  Maybe I shall have to install the full version of Raspbian and delete the GUI stuff afterwards :(

Errors 01.JPG

Link to comment
Share on other sites

Yes, I think that's what I'll have to do.  As I recall from previous installations, the full version is not all that big - something like 6 or 7 GB so I can still use an 8GB probably.

Link to comment
Share on other sites

11 hours ago, Gina said:

Google has come up with a result but I shall need to read it a few times to get my head round it :D

As you kinow, where any sort of linux is concerned I may be talking complete rubbish, but would it make any difference that the poster was installing ububtu and you are installing Raspbian - might this be why you got the additional error messages?

  • Like 1
Link to comment
Share on other sites

Good point and well spotted - thank you :)  I hadn't noticed that.  Yes, I think that could well be why I'm getting the new errors.  The original error is probably from the same cause further back, maybe all the way to Debian on which all these forks are based.  Seems to be a question of version numbers which could be a bit difficult to sort out - and I'm not up to it!  The simplest answer must be to avoid the problem by using the full version of Raspbian as this seems to work.

Link to comment
Share on other sites

I downloaded the latest version of Raspbian Jessie with Pixel overnight but it won't extract - guess there's an error in the downloaded file.  Since I don't really want to wait several hours to try again I'm thinking of installing an earlier version and upgrading (sudo apt-get update - sudo apt-get upgrade - sudo reboot).  I think that should end up with the same result - but am I right?

Link to comment
Share on other sites

Depends :) 

If it is an earlier version of Jessie then it will upgrade to the latest.

If it is an earlier release (e.g. Wheezy) then it will only update as far as the final updates for that release.

Clever Analogy :D :  If you had Windows 7 then it wouldn't apply Windows 10 updates.

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Similar Content

    • By astrosathya
      Hi Everyone,
      Would someone happen to have STL files for a simple printable Crayford/R&P focuser please?
    • By Elp
      Hi, first post so please bear with me, having issues with autoguiding, looked at numerous forum threads and cannot find the issue specific to my setup and the issue I am having.
      Equipment in question:
      ZWO 224 using as guide camera plugged into raspberry pi running Astroberry via USB3,
      Lynx Astro EQDIR cable plugged from USB on raspberry pi into hand controller port on AZ GTI.
       
      Configuration:
      Synscan android app successfully connected to AZ GTI via wifi and can control via mobile phone,
      AZ GTI setup to connect to raspberry pi (so it's on the raspberry pi network) AZ GTI connected successfully as it is recognised in PHD2 and EKOS,
      In PHD2 the mount is setup as INDI mount (AZ-GTI) and connects.
       
      Issue:
      PHD2 is unable to guide in either RA or declination (see screenshot error showing up), it is always one or the other. I have tried setting up multiple times, tried using the network cable which came with the camera directly from the camera into the hand controller port and setup in PHD2 as "on camera" (I suspect this setup is wrong anyway and was one of the first I tried). Polar alignment has been checked multiple times, the end result is always the same, the star field within PHD2 window will always drift in one direction so any star chosen will eventually disappear out the field of view as the mount isn't moving to follow it.
      Looking at the PHD2 graph I know it is trying to send pulses to the mount but either the movement is too much for the mount to move or something isn't happening as it should, in the example screenshot provided I tried this indoors on a fairly fast (compared to in the field) rotating star field looking at a screen so it will fail, though the mount didn't adjust at all, no matter how I've setup prior the AZ GTI refuses to adjust to follow a guide star. I have tried manually moving the mount in PHD2 and it doesn't seem to move in any direction, manually moving however does work in EKOS so the hardware seems to be plugged in correctly. EKOS even knows where the mount is pointing and can issue go-tos (although it is slightly off target at the moment).
      I am kind of at my wits end to why autoguiding isn't working, if anyone can help please assist.
      On another note if someone can advise how to configure PHD2 so the off yellow warning box colour can be changed so the error message can be read clearly - I know theres a line of code I can use in the terminal window which refers to a resource file to change to the default PHD2 colours and launches the software but the changes are never saved.
       

    • By Gina
      I have a triple imaging rig with 3 RPi boards and using wired LAN to the house.  Indoors the rig is controlled by KStars/Ekos running in Linux Mint on my tower system.
      All was working fine a few nights ago but then on a later night I kept getting "Broken pipe" errors and network disconnection. This wasn't all at once but one system at a time with a few minutes in between.
      LAN consists of router plus one network switch indoors and a second network switch on the rig.  Both Netgear 5 port units.  I also have a WiFi LAN if that's relevant.
      On the rig are 2 RPi 3B boards running Raspian and indiserver with drivers plus an RPi 4B running Astroberry Server.  The first RPi 3B controls the EQ8 mount and has 2 CMOS cameras, ASI 1600MM-Cool for imaging and ASI 178MM for guiding.  The other RPi boards run imaging only.  Except that I also have remote focus for the imaging cameras using the Astroberry Focuser driver.  The remote systems run servers and the Mint machine runs 3 instances of KStars/Ekos as clients, controlling everything via 3 individual SSH channels.
      Cable to obsy is CAT6 outdoors rated cable allowing gigabit data rate.
      Nothing has changed between the night the kit worked and later when it lost networking.  The only thing I can think of is that it got warmer.  I have fan cooling through the box with the 3 RPi boards and HATs.  The main obsy power of 13.8v feeds the rig with a 12/24v to 5v 10A voltage dropper/regulator feeding the RPi boards.   1000µF electrolytic and 0.1µF ceramic capacitors are connected across the incoming power connector.
      Any thoughts on what could have gone wrong and/or what I can do to fix it would be much appreciated.  Lots of clear night skies and kit problems!!!  Frustration unlimited!!
    • By AstroMuni
      Hi,
      I have setup Astroberry on my RPi and set it to connect via ethernet cable to my laptop running linux. So the RPi gets assigned a 169.254.x.x address. If I enable the Wifi on the RPi and connect it to my home Wifi I am able to connect to the INDI webmanager from Kstars/Ekos profile. But if I disable the Wifi on the RPi so its only connected via ethernet cable to my laptop, I cant get Ekos to find the INDI webmanager. So my guess is that the webmanager is NOT listening to requests from the 169.254.x.x address??
      How can I get this fixed?
    • By marcocipriani01
      Hello everyone,
      I developed an Android app - Telescope.Touch - capable of connecting and controlling INDI/INDIGO devices, for those of you who use Raspberry/Astroberry/StellarMate.
      It's really powerful, and a lot of new features are in the works.
      Features:
      Mobile planetarium derived from the Sky Map project Mount and focuser controller with directional pads and speed controls Receive images from INDI CCDs Database full of objects to which you can point the telescope directly from the app INDI control panel compatible with every device Aladin Sky Atlas preview and altitude graphs Astronomy utilities: polaris hour angle, compass, red flashlight Languages: English, Italian and French. Sky maps are translated in almost every language. It is available on Google Play: https://play.google.com/store/apps/details?id=io.github.marcocipriani01.telescopetouch
      A Pro version is also available, mainly to support the app's development: https://play.google.com/store/apps/details?id=io.github.marcocipriani01.telescopetouchpro
      I hope you enjoy it! I'm open to feedback and improvements!
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. By using this site, you agree to our Terms of Use.