Jump to content

Stargazers Lounge Uses Cookies

Like most websites, SGL uses cookies in order to deliver a secure, personalised service, to provide social media functions and to analyse our traffic. Continued use of SGL indicates your acceptance of our cookie policy.

stargazine_ep2_banner.thumb.jpg.e37c929f88100393e885b7befec4c749.jpg

michaelmorris

Problem with ASCOM on LX200 - ideas please?

Recommended Posts

I have a venerable old Meade LX200 Classic which I drive using the Meade LX200 Classic and Autostar #494, #495, and #497 (combined telescope/focuser, 5.0.4) driver on an ASCOM6.1 platform on my Windows 7 Pro 64 bit computer.

Last night all was running well with Cartes du Ciel,(CdC) PHD guiding and APT camera control all connected simultaneously with no problems.  CdC is used for GOTOs, PHD for guiding and ASCOM talks to the mount for plate solving and for dithering.

Half way through the night I shut down APT and relaunched it, only to find that it wouldn't connect to the scope.  On testing, I found that in fact this problem was not restricted to APT.  What had happened is that I could connect to the scope via ASCOM with any of these pieces of software one at a time, but regardless of the order I launched the software, not two programs simulateously. (I checked that PHD was set to server mode).

I have tried uninstalling the Meade drivers and ASCOM itself and installing the latest version of each but I still get the same problem.

Ideas?

 

Thanks

Share this post


Link to post
Share on other sites

Hi,

i have had these issues in the past, and for the life of me can't remember how I got round it, I think that PhD had to be run in server mode, to allow the driver to be shared with APT,  but if you connect to the scope via Ascom in APT then it won't connect in any other software for scope control, the Meade Ascom driver can only be used by one piece of software at a time,   so for me if I connect APT to my Meade mount, via the Ascom  driver you mention, to make corrections to the scope, I would have to disconnect from APT to connect with CDC, but it will always connect with APT and PhD together, as long as PhD is in server mode....

i think I have that correct, but if you have had all three connected and working then you are a genius, as I don't think it should..:)

hope that makes sense..

Bill

 

  • Like 1

Share this post


Link to post
Share on other sites

I also have been running APT CDC and phd2 concurrently, without issues. However, only phd2 and cdc were connected to the mount, so this indicates that Bill is right. This was working off the shelf with no changes of any of the default settings...

Maybe you could drop ivo a message on the apt board, he is usually extremely fast with help?

  • Like 1

Share this post


Link to post
Share on other sites

I may have been mistaken about having CdC, APT and PHD all connected to the mount simultaneously, but I could certainly have APT and PHD connected to the mount at the same time by starting PHD in server mode. I've uninstalled>rebooted>reinstalled PHD and still get the same issue.

Help.

Share this post


Link to post
Share on other sites

Quote Ivo from above."Just select POTH (...Hub...) instead of telescope driver and in POTH's properties select the actual driver. This is one time setup...
Then you just have to select POTH"

 

 

Share this post


Link to post
Share on other sites

POTH would connect to the Meade driver, but would crash out when trying to connect POTH to PHD.  However, it all seams to work okay when using PHD2, so (fingers crossed) problem solved. Thanks for all the advice.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Oslet
      Sooo...I'm getting quote frustrated here. This spring I tested my HEQ5 with guiding. The synscan controller was connected to the computer trough the USB plug on the hand controller. This worked like a charm in my living room. On the new controllers you dont need the rs cable. But when I tried the whole thing with guide cameara for some live shooting, it just did not work. I get something wrong with the com port in decice manager, driver not working. I have tried 3 different drivers. The whole thing responded, connected and was guiding when i did a dummy test before the summer. So setup is pc-synscan via usb for pulse guiding. Can it be a problem with windows 10? What t h.... just happened? Where can I find a driver that works? And believe me it worked 5 months ago, argh. Thanks for any respons and support
    • By JBracegirdle
      Good afternoon,
      I'm still new to astronomy in general, my setup is explained in my previous post. I am trying to get plate solving working.
      I can get results from Astrometry.net, and I can get All Sky Plate Solver to solve when given an image file, but I am trying to get it to work with my ZWO ASI224MC direct.
      When I try "Click, Solve & Sync" I get an error "Camera array data unsupported."
      I have my camera connected with ASCOM as ASI Camera (1). The Image Type options are Raw8, Raw16 and Y8. Raw16 is selected and seems to be the default. I have tried the others and they all produce the same error. I've tried it with and without MonoBin. Binning is set to 1 and Subframe to 100% (50% tried). Filter is blank.
      I can connect to the camera in SharpCap via ASCOM (although it warns that it prefers native drivers). I've also tried the SharpCap native Plate solver with the astrometrics install from ASPS, it tries to solve takes a while, but can't find a solution. I also tried AstroTortilla, that reads from the camera but just returns "No solution in 0.0s".
      I've tried a Google search for the ASPS error but it doesn't find anything. I have checked only one application has the ASCOM camera at once. Any suggestions would be appreciated.
    • By Demonperformer
      Setting up all the software on my win10 laptop and getting things to talk to one another is a nightmare.
      I'm starting a new thread, so I can post all the problems I am having, one at a time, so issues don't get confused. This will also hopefully help anyone coming to similar situations later, as the problems and answers will not be interlaced.
      First issue: APT does not detect ZWO camera.
      I have got the camera (ZWO) drivers installed and sharpcap can see it and will connect to it properly. However, when I try to connect the camera in APT, the only CCD options it gives me are SBIG (which it isn't), QSI (which it isn't) and ASCOM. Now it shouldn't need to use an ascom driver, because the proper driver is installed, but I give it a go anyway, and this just offers me 2 simulators and 3 QHY cameras (I have one qhy driver installed for the guidecam .... I'll get to that later!). I have disconnected both the filterwheel and guide camera from the camera hub, so they cannot be interefering with the process.
      I am at a total loss ... any suggestions?
      Thanks.
    • By Sunshine
      Looks like my Lipo project so far may be working good, ran a trial last night with a 3200Mah 3 cell Lipo from my RC airplane, the battery is an 11.1V nominal charge (uncharged) but charges up to 12.6V (4.2V per cell fully charged). All Lipo batteries display nominal charge capacity, which can be misleading because when charged, they jump up in voltage past displayed voltage.
      I wanted to see how long that went for before using one of my larger 5000Mah batts, didn’t take much more than $5 for a 2.5mm connector with 6ft cable included and a Deans connector on other end for the battery. I have a small voltage meter we RC guys use to monitor battery levels per cell and combined voltage, meter just keeps displaying levels constantly then emits a buzz when it drops to pre programmed level. The loud buzz I muffled to a pitiful hum by dropping some hot glue over the little speaker holes, last thing I need is an 80 decibel buzz at 2am in my yard.
      I set buzz for 3.5V per cell which is lowest you want to drain a Lipo per cell, after slewing around manually more times than I can remember I still had enough juice to slew around for another hour if i wanted, I was mimicking a nights slewing around and I think after I slewed around  on both axis simultaneously on and off for 40 min I pretty much covered a nights worth.
      the test will be in the field, if this battery doesn’t cut it I’m sure the 5000Mah will do the trick. I was watching for any shenanigans from the scope as the level dropped but nothing, no glitches or twitching of the controller display, all remained solid.
      UPDATE: 
      The next morning i turned on the scope (without recharging battery)  and again spent the better part of an hour until i was just bored slewing the scope around, i was afraid to burn out a motor with constant back and forth slewing with a short pause of course.
      i am now convinced that this 3200mah battery not much bigger than the average candy bar will last a whole night out and more! fantastic to know that when i drag the scope out for short periods locally (won't need heat strip those times) that this battery will be fine.
      i was dreading having to take my 50Lb deep cycle marine battery every time id like to go for a short local 2hr outreach session, on those long drive dark sky all night sessions yes i will need heat and my marine battery but those a few compared to 
      short local sessions. I can now fit my power supply into my pocket and that is just GOLD!!



    • By AngryDonkey
      Hello,
      Last year I developed an 'all sky' imaging application to run my Starlight Xpress Oculus camera (for Oculus owners you can find out more here: https://groups.yahoo.com/neo/groups/allskeye/info). I have recently added 'experimental' ASCOM support for it but don't have any other cameras to really test in on. If anyone is looking for this kind of software and would be happy to carry out some beta testing please let me know. Please bear in mind:
      The software is really designed for traditional astronomical cameras using longer exposure lengths i.e. not video astronomy and am not sure how well it will work with faster CMOS cameras The software is mono only, no colour images can be processed (although it might be possible to use a colour camera to produce mono images - something I would like to test) It has been running for a while so is reasonably stable but please bear in mind that this will be a beta test so do expect problems! :-) Oh and sorry but it will only work on Windows computers from Vista onwards (no XP) Thanks,
      Mike
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.