Jump to content

Stargazers Lounge Uses Cookies

Like most websites, SGL uses cookies in order to deliver a secure, personalised service, to provide social media functions and to analyse our traffic. Continued use of SGL indicates your acceptance of our cookie policy.

sgl_2019_sp_banner.thumb.jpg.a0ff260c05b90dead5c594e9b4ee9fd0.jpg

Sign in to follow this  
AlistairW

Trying to find 12V 100W linear power supply

Recommended Posts

Hello,

Trying to buy a linear regulated power supply to supply - 12Vdc, rated at around 100W. I am having trouble with my switched mode supply so am trying to run my rig off a linear supply. Was looking for something around £100 or less. But struggling to find anything.

Thanks

Alistair.

Share this post


Link to post
Share on other sites

What is the model of switch mode psu that you are using - and what is it powering?

Share this post


Link to post
Share on other sites

Hi,

Well it did buy it off ebay - see uploaded pic - so I am unsure of make - unless it is 'H'. I feed the output in to a distribution panel, that has 6 'things' (Camera, Focuser, Mount, Dew Band, USB HUB + something else I can't remember). All fairly low current draw, less than 4A each I would say. So the supply has enough grunt (1000W). I am having issues with the Camera running from this though, seems to 'glitch'. Trying with a linear supply seemed to be more successful.

Thanks

Alistair

IMG_1616.PNG

Share this post


Link to post
Share on other sites

Have to admit I struggle with the 13.8V rating that is commonly given on fixed voltage supplies. I want 12V, but it seems 13.8V is the norm. Why power something rated at 12V at 13.8V ? - I know the circuits will take it, but I don't particularly want to run the risk.

Share this post


Link to post
Share on other sites

I would be more concerned running at 12v than 13.8v. some things struggle if voltage isn't quite high enough. We concider our cars to have 12v components yet all car batteries are 13.8v

12 minutes ago, AlistairW said:

Have to admit I struggle with the 13.8V rating that is commonly given on fixed voltage supplies. I want 12V, but it seems 13.8V is the norm. Why power something rated at 12V at 13.8V ? - I know the circuits will take it, but I don't particularly want to run the risk.

If you are really  concerned, the one I use thats linked by blinky has a variable voltage supply. I run it at 13.8v :)

 

Share this post


Link to post
Share on other sites

I run everything at 13.8, including the dew strip - no problems with plenty of headroom to spare.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.