Jump to content

Stargazers Lounge Uses Cookies

Like most websites, SGL uses cookies in order to deliver a secure, personalised service, to provide social media functions and to analyse our traffic. Continued use of SGL indicates your acceptance of our cookie policy.

sgl_imaging_challenge_banner_30_second_exp_2.thumb.jpg.7719b6f2fbecda044d407d8aba503777.jpg

JohnC64

HitecAstro - Mount Hub Pro on OSX

Recommended Posts

I have recently been working on a OSX application so that I can drive my HitecAstro Mount Hub Pro without having to resort to having a Windows VM  running on my Mac

 

I now have this working and can detect the hub plugging in/out and also control the switched power outlets and the Heaters .   I have also written the code to drive the focus motor but am unable to test this(as I don’t have a focus motor yet :-) !!)

56c48452e040e_ScreenShot2016-02-16at20.5

 

Is there any one who has a Mount Hub Pro and who uses a Mac who would become a beta tester for me and who could test the motor control.

 

I am only looking for a small number of testers at present as I do not want to release untested code into the wild.  Especially as it drives the focus motor and I do not want to risk having a coding error mis-driving the motor - potentially damaging something.

 

Other than Debugging, the tasks left to do on this project are to add a ‘Red screen’ mode and to build a proper installation package.  At that point, it will be ready for general release.   

 

Please PM me if you are able to help

 

Many thanks 

John

 

 

  • Like 1

Share this post


Link to post
Share on other sites

I have a Mac and the hub and some focus motors (on scopes and off) so can give it a run through for you.

 

Steve

  • Like 1

Share this post


Link to post
Share on other sites

Hi John,

 

I connected up my HubPro to my Mac and attached a focuser motor (exactly the same as fitted to my Lakeside system on my scopes). Given the weather and the hour I did  not setup a mount with scope & focuser but everything seemed to work OK.

 

Steps worked, reverse direction worked, presets all worked as did the power ports. Did not try the dew band controls.

 

The only minor niggles/suggestions I would make are:

 

  1. The current position of the focuser is updated immediately when you use one of the ‘slew’ buttons on the presets, it would be nicer if it incremented as the focuser moved if possible.
  2. If you use the focus in/out options then the current position is not updated.
  3. Is it possible to put a stop or cancel button on the focus controls, again that would be helped if the current positions as incremental and stopped setting where it stopped.
  4. The on/off power buttons don’t do anything when the focuser is moving but do when the position is reached.
  5. I would make the All On/All off buttons change colour when selected, though they work fine.
  6. When you turn a power port on I sort of expected a light red rather than blue
  7. The 25%,50%,75% to 100% preset speed buttons don’t seem to be linear. A full revolution of the motor took about 24 seconds, 75% took around 65 secs and 50% around 2mins 30. May be worth a check of the code.
  8. I looked for a save option to save the label names but found these were kept anyway.
  9. Not sure if the current position should be kept when exiting/reopening as the focuser may have moved (but some may want to keep it especially if in an obsy).

 

Bear in mind I had not used the Hitec Windows version so some of these may be common to their app too. And I have used a physical or software app from Lakeside mainly. Did not get enough time over Christmas to set the Hub up so this has given me a kick in the pants to get it done.

 

  • Like 1

Share this post


Link to post
Share on other sites

Wow Steve - Thank you for such a detailed report.  Thats exactly the information that i needed to know.

Most of the niggles/suggestion (1,2& 3) relate to the fact that there is no mechanism to read anything from the MHP.  All the commands are write only and you cannot get any initial conditions/  positions from the device.

I was able to reproduce issue 4 in the windows version so not sure if i will be able to cure that one.  Also i found if I send commands when the motor was running, i could confuse the MHP about the heater controls.   I will look into this one further.

5 and 6 should be easy to implement - I was also thinking that the blue 'LED' looked a bit wishy-washy too.

No7 is interesting. I will look at the code again.  The algorithm is 30+(2.15 * pos)  to give a motor range of 30 to 240 so it should be linear.  I will check my code again and inspect the values being sent to the mount.  There is always scope for error in programming. :-)

I tried to make everything as automatic as possible so removed the save button and just saved the values on exit.  Also the program automatically detects if the device is plugged in so the connect button is also not required.


Many thanks for your feedback.  It looks like i am mostly there.  I have a few bugs to iron out but will be incorporating your feedback into the next release and should hopefully have a public release later this week

Is there anyone out there who uses the windows version of the software able to confirm is the speed settings work are linear or non linear.

Many thanks

John

Share this post


Link to post
Share on other sites

Hi All,

I have managed to knock off a few rough edges and have now wrapped the application up in a package for installation.
Please feel free to download  from the link below.

The application will only work on El Capitan due to some jiggery pokery that I had to do on the USB front.  If I can resolve this when the next OSX update comes out, I will make it available on earlier versions.

If there are any issues, please PM me.

Cheers John

HitecAstroHub.pkg

 

 

 

Share this post


Link to post
Share on other sites

Hi John,

I am using Kstars/Ekos and would like to be able to control my HitecastroDC2 focuser controller I purchased recently. https://www.hitecastro.co.uk/index.php/products/item/hitecdcfocus
Unfortunately the existing HiteacastroDC driver in INDI doesn’t work with the controller I have which apparently even in ASCOM needs a different driver from the driver of the earlier HitecAstroDC focuser.
David Brennan from Hitecastro explained the following:

"I think it will be helpful if I explain the difference between HitecDCFocus and HitecDCFocus2.  HitecDCFocus2 was produced to enable people who want to use 2 hitecdcfocus units at the same time.  HitecDCFocus2 has a different USB identifier so that it can be used alongside a standard HitecDCFocus.  In other respects they are exactly the same.  You can of course use a HitecDCFocus2 as a single controller too.”

I am inclined to think that the INDI driver HitecastroDC was based on the HitecDCFocus and that this may be the reason why it doesn’t work with the more recent HitecDCFocus 2.

I came across this thread about the software you wrote for the Mount Hub Pro from Hirecastro. Although I don't have this item and I only need to control my focuser I was wondering whether you could adapt your program so that it would also work connected to my HitecastroDC focus controller 2 without having a Mount Hub connected. It's a  bit expensive to purchase just for the sake of using the focuser.

I am not a programmer and  I admit that I don’t really know how much effort it would be to adapt the driver so it would also work with the HitecDC Focus 2 only but could I ask to have a look at it. I can imagine that there will be more users that would be helped by it.

I have asked Hitecastro itself for any information which I could relay to anybody willing to look at the code of the driver but haven’t received any reply yet.  I understand from my earlier mails with them that they don’t offer any assistance for OSX users as their software is Windows oriented.
I have also started a thread on the INDI forum but also without any replies so far. I read from earlier threads that the HitecastroDC driver is now part of the INDI core. At INDI they told me to put my request on github.com/A-j-K/hitecastrodcfocuser/issues which I did.
The hardware is fine as it works correctly with Backyard EOS which is Windows software.

In other words I’m kind of stuck at the moment. :-)

Any help would be appreciated.


Kind regards,

Robert Temmerman

Share this post


Link to post
Share on other sites

Hi Rob,

I have had a look at the way that the software works for the HitecAstroDC and DC2.  Unfortunately it appears to have a different control protocol so I don't think that I will be able to mod my program to suit your needs. I have sent you a PM with details of the VID and PID values that you will require to modify the INDI driver .rules file.  That combined with Information you obtained from the INDI team should enable you to get the Focus DC2 working with your system.

Cheers John

 

Edit: Looking at the GitHub repo for INDI, It looks like Andy Kirkham has updated the source so that it will work with the FocuserDC2 as the new VID/PID is in the source.  Downloading the latest of INDI will probably sort your problem.

Edited by JohnC64

Share this post


Link to post
Share on other sites

Hi John,

Would you be willing to share your OSX source code for the MHP?   

I am thinking of using a RaspberryPi with INDI to control my imaging rig.  It seems there are INDI drivers available for all the equpment I use bar the MHP.  

In particular I would like to be able to control the power supply switches and dew heaters from the RPi.

Regards

Mike

Share this post


Link to post
Share on other sites

Hi mike,

i am on holiday at the moment but would be happy to send you a copy of the software.  It used iokit for talking to the hid but you could use Libusb  to do the same job on the pi.

I used jet brains dotpeek to convert the hitec Astro dll that comes with their software.  It gave me the appropriate bytes to send to the device to control it.

i am back at home in February so could send you the source code then. 

Cheers John

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By jschusterman
      Has anyone upgraded on Mac to "High Sierra" (OS 10.13) and had any issues with PHD2 or using Wine to run DSS, or any camera control software? I'm getting the notifications for the upgrade, but I'm worried some of my AP software (currently running on 10.12) won't work right before a big trip to a dark sky site in 2 weeks.
    • By GuLinux
      Hello,
      I just finished uploading a new beta version (0.7.0-beta1) of my Planetary Imager application.
      One of the biggest news of this release is the availability for all major platforms (although OSX users might struggle a bit..). But of course, we also have a few new interesting features, like a network mode (client and server), a new histogram, and profiles support. Please look the official changelog for more information.
      You can download the packages from the official download page, or grab the sources directly from the github project page
      (edit: reuploaded Windows package, it had a small directory layout issue preventing startup)
    • By NickK
      Looking good for an alpha release on friday..
      http://stargazerslounge.com/topic/192900-atik-osx-drivers-r100-example-app/page-6
    • By NickK
      The folks over at Cloudmakers have made an INDI ATIK driver for OSX and Linux supporting 32 and 64 bit.
      http://www.atik-came...024.msg2971#new
    • By NickK
      You're probably sick of me.. but this is a big moment for me :)

      I've released the first full version of the ATIK OSX drivers and the example application :)
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.