Jump to content

Stargazers Lounge Uses Cookies

Like most websites, SGL uses cookies in order to deliver a secure, personalised service, to provide social media functions and to analyse our traffic. Continued use of SGL indicates your acceptance of our cookie policy.

stargazine_ep25_banner.thumb.jpg.9e57eee22cad68fd6b67a87befeaa79b.jpg

Which Star is that

Spc900Nc Webcam In Windows 10?

Recommended Posts

I did a quick Google and it seems that there are Windows 10 drivers for the SPC900 available for download.

Share this post


Link to post
Share on other sites

Hi Rick, this driver is running my 2 SPC900's fine under Win 10.

spc900nc_00_dw7_eng

Rob

Share this post


Link to post
Share on other sites

Rob,

 

Are you using W10 32bit or 64 bit?      Any not normal or routine installation instructions?

 

Thanks,

 

Chuck

Share this post


Link to post
Share on other sites
On 1/20/2016 at 07:37, roblegion said:

Hi Rick, this driver is running my 2 SPC900's fine under Win 10.

spc900nc_00_dw7_eng

Rob

I know I'm resurrecting an old thread but I have an old first edition NexImage which, as I understand it, is essentially the Phillips SPC900.

I used this camera on my old Dell running Windows 7 but I've upgraded to a new laptop with Windows 10 64bit and am trying to get all my AP software up and running on it.

I downloaded the spc900nc_00_dw7_eng driver and installed it but SharpCap doesn't see the camera. When I check Device Manager it shows the camera as an "unknown device".

Where did you get your copy of the driver from? Any tips to get it up and running on my Windows 10 64 bit laptop? What capture software are you using.

Thanks,

Greg.

Share this post


Link to post
Share on other sites

A few searches gave a couple of clues. A few searches gave a couple of clues, I would think if the Toucam Pro would work so would your SPC900

Unfortunately on the Philips website there is no reference to windows 10 drivers though

http://www.p4c.philips.com/cgi-bin/dcbint/cpindex.pl?slg=en&scy=nl&mid=Link_Software&ctn=SPC900NC/00

Edited by Pete Presland

Share this post


Link to post
Share on other sites

Hello, guys! The SPC900nc works on Windows 10, too. 

Please contact me to share the suitable driver.

I use the SPC900nc  on Windows 10, successful. Cheers!:hello:

  • Thanks 1

Share this post


Link to post
Share on other sites
On 14/05/2018 at 02:49, URANUS7 said:

Hello, guys! The SPC900nc works on Windows 10, too. 

Please contact me to share the suitable driver.

I use the SPC900nc  on Windows 10, successful. Cheers!:hello:

Hi URANUS7, could you help me too? I get the same problem.

Share this post


Link to post
Share on other sites
On 14/05/2018 at 06:49, URANUS7 said:

Hello, guys! The SPC900nc works on Windows 10, too. 

Please contact me to share the suitable driver.

I use the SPC900nc  on Windows 10, successful. Cheers!:hello:

Hi. Im a new astronomer with this webcam also. Im running windows 10 64bit. Could you help me as well please?

Share this post


Link to post
Share on other sites

Also what software is best to use with it to get the most out of it for Astrophotography?

Share this post


Link to post
Share on other sites

This is an old thread but hopefully this will help some people out. I got it working on Windows 10 as well. It just takes a few more steps. I will break it down as much as I can

1) Download and run the driver "install" spc900nc_00_dw7_aen.exe. You can get it from the Phillips website but here is the a link https://www.philips.ca/c-p/SPC900NC_00/webcam-with-pixel-plus/support

2) Once the install is complete, go to C:\Program Files (x86)\Philips\Philips SPC900NC PC Camera\vista64 right click on camdrv42.sys and select Copy

3) Go to C:\Windows\System32\drivers and paste ( drag and drop will work as well )

4) Restart (This is important)

5) On the windows tool bar in "Type here to search" type in Device Manager and click on the program in the results

6) In Device Manager Under "Other Devices"right click The Unknown device (there should only be one) and select "Update Driver"

7) Click "Browse my computer for driver software"

8) Click "Let me pick from a list"....

9) Double Click "Show all devices"

10) Under The Manufacturer window, scroll down to "Philips CE CSI"

11) In the Model window select "Philips SPC 900NC PC Camera"

12) Click "Next"

13) On the Driver Update Warning window, Click yes

14) enjoy!

Share this post


Link to post
Share on other sites

Thanks @Hildo,   followed your instructions, only I used the UK site www.philips.co.uk/c-p/SPC900NC_00/webcam-with-pixel-plus/support  and Win7 UK driver SPC900NC_00_dw7_eng.exe

In Device Manager the camera driver installed under 'Sound, video and game controllers'  and is reported to be working properly.

I ran Sharpcap and of course it finds the camera and saves video as you would expect.   Some other applications see the camera and save video & audio as would expect.

Windows10 camera app is unable to see it and Skype can only see the microphone.  I am thinking that's because the driver is seen as a game peripheral, not listed in device manager under 'Imaging devices'.

Anyone know if this is correct or can be adjusted ?   Supernice to have this old camera working again, many thanks.

Share this post


Link to post
Share on other sites

Actually got my SPC900NC working using the above instructions 👍

Steve

Share this post


Link to post
Share on other sites

Hello;
We have managed to get the SPC900NC to work with W10 but when closing the firecapture we get this error.
Does anyone know if this error can be fixed;
Regards.

capturada.jpg.2e47b51ac852725ee34d23248a193876.jpg

Share this post


Link to post
Share on other sites

Hmm - this seems to have stopped working for me with the latest W10 update. Happily had it working with Hildo's instructions in June, but no longer. The driver installs (apparently successfully) from the device manager as usual, but does not appear under sound & video controllers, and if I close and re-open the device manager it goes back to reporting  unknown device, no driver installed. Anyone else had this?

NigelM

Share this post


Link to post
Share on other sites

Unfortunately similar here, l haven't had mine working since april when a Windows 10 patch installed and it's still blocking the camera image on 2004 update. Frustrating.

Share this post


Link to post
Share on other sites

I recently got one of these and same result as Mick_J, it appears not as a camera but under the Sound Video and game controllers section. Mine never came up as Unknown tho, just detected once plugged in and worked.

SharpCap sees the camera and works fine with it but MS camera doesn't and skype doesn't get video, not that that matters for what I got it for. That's on W10 2004 and subsequent updates with my desktop and laptop. Just not had much chance to actually play much with it so far. Did grab some video of the Moon and Mars when experimenting but nothing that was very clear so far, but then those were first attempts in poor skies.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.