Jump to content

30sec_exposures_2021.jpg.48851b1871a4bf9500ebd53c3e790d81.jpg

 

 

EQMOD problem


Darth_Muppet
 Share

Recommended Posts

Since I updated to the latest EQMOD I'm getting a problem. When I run up Maxim it connects to EQMOD and runs up fine. Whenever I try and connect another piece of software like cartes Du Ciel, PHD 2 or whatever, it tries to load up another instance of EQMOD again.

Of course, there is already an EQMOD running so the new one fals with a connection error message and I cant use any other software. Prior to the update (v128) I could connect multiple items all using the same instance of EQMOD. Any ideas?

Link to comment
Share on other sites

im pretty sure thats what happened to me TBH , I ran maxim on it then when i went to CDC I had connect error  (something like that) from there I just plunged into the depths of hell in the end i went back to synscan, wish i could help you but im lost on it

Link to comment
Share on other sites

Just a thought  but have you tried running both as admin?. Worth a try as its got me out of a few probs running more than one app relying on a part common to both. If I haven`t just killed the English language :tongue:

Steve

Link to comment
Share on other sites

Chris,

Running applications under admin rights is very risky - especially if the PC is connected to the Internet via anything other than a very locked-down firewall. I've helped rescue a number of PC users that have found their PCs are suddenly not theirs any more. :eek:

Admin rights should only be used for the installation of software (where this is required) and for PC configuration - and then only for the shortest possible time.

Is there any way that EQMOD could be configured to cope with the issues people have experienced, perhaps by only running a single instance at a time?

Link to comment
Share on other sites

I disagree. Admin rights are not just for installation - much of windows itself is running with admin rights all the time.  Granting appropriate rights to applications that need them is a perfectly acceptable and normal aspect of computer management. In almost 8 years of advising folks on EQMOD use I've yet to have anyone complain that granting admin rights to EQMOD / ASCOM has caused them any problem at all.

The whole point of ASCOM is that it provides an environment whereby multiple client applications can connect simultaneously to their mount driver. By doing this separate planetarium,  platesolver, autoguider apps can all be made to work together to provide complete mount automation. Having each app open up a separate instance of EQMOD just doesn't work as once the first EQMOD instance has taken the serial port the others will not be able to access it.

Chris.

Link to comment
Share on other sites

That's OK Doug, I also just re-read my post and I can see why it set of alarm bells!

Just so everyone understands, when I said everything should be set to run as administrator I was referring to all the applications mentioned in the original post of this discussion- not everything on the computer!

Chris.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. By using this site, you agree to our Terms of Use.