Jump to content

2052839955_Mobilephonebanner.jpg.a502a319d7033354d442937f2edd0c2c.jpg

Nexstar plus upgrade


Recommended Posts

Hi peeps just a quick q,I'm trying to upgrade my nexstar play firmware,I got the update ready but I can't get my handset to go program mode,I tried the celetron picture button with the back button and nothing and tried the info button which is bottom middle with the back button and I get initializing and I let go of the buttons but it does go into transmit data,it just goes to normal screen,ant help pls

Many thx

Sent from my iPhone using Tapatalk

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. By using this site, you agree to our Terms of Use.