Jump to content

Stargazers Lounge Uses Cookies

Like most websites, SGL uses cookies in order to deliver a secure, personalised service, to provide social media functions and to analyse our traffic. Continued use of SGL indicates your acceptance of our cookie policy.

sgl_2019_sp_banner.thumb.jpg.a0ff260c05b90dead5c594e9b4ee9fd0.jpg

Spidey

Problems with DSS image result when loaded in PS (greyscale?)

Recommended Posts

Hi, I'm a newbie to astrophotography and I'm really having lots of trouble to extract the colour from my images when I stack them with DSS in CR2 format. I'm using last version (3.3.4) so I think that compatibility with my camera is not an issue (Canon EOS 700D).

After stacking images I get an image where I can barely see stars (as far as I know and I have read this is normal). I save the image as TIFF, 16bit/ch. but when I open it with PS, DPP or Gimp I'm totally unable to bring the colour out, the image remains in what seems to be grayscale. PS asks me when I open the image to select a RGB space so that should not be a problem I think. However, and this is what is driving my crazy, if I convert every single raw image to TIFF and then I stack those with DSS the colour is there and I can more or less extract the information with the image and have some nice pics. I even tried to save the result as FITS, get each colour plane with FITS Liberator and load them in each channel in PS with no luck.

I would love to use directly raw files to stack (although if you tell me that using TIFF files is the same I would be happy anyway :)). Am I missing some step?

Many thanks for your help!

Share this post


Link to post
Share on other sites

Open a non-astronomical raw file (e.g. a scenic view) in DSS.  If it shows colour then it rules out any compatibility problems.

Mark

Share this post


Link to post
Share on other sites

Something is amiss as you should get colour in your TIFF from DSS.  I'm not quite sure why photoshop is asking that question which makes me suspicious that you have one of the settings in DSS wrong at the moment.  Could you say what settings you are using in DSS and we can probably help you (The RAW FITS settings box at the lower right is the most likely place to find things)

Share this post


Link to post
Share on other sites

Open a non-astronomical raw file (e.g. a scenic view) in DSS.  If it shows colour then it rules out any compatibility problems.

Mark

Done it, the image is darkened but there is colour in it.

Something is amiss as you should get colour in your TIFF from DSS.  I'm not quite sure why photoshop is asking that question which makes me suspicious that you have one of the settings in DSS wrong at the moment.  Could you say what settings you are using in DSS and we can probably help you (The RAW FITS settings box at the lower right is the most likely place to find things)

These are my current settings (excuse me if the name of the option is not exactly the same as I'm using a version in spanish and I'm translating them).

For RAW:

-Colours: Brightness 1.0000, Red Scale 1.0000, Blue 1.0000

-White balance: Both options unchecked

-Bayer matrix transformation: Bilineal interpolation

-Last option unchecked (black to 0)

For FITS (only used this one time):

-First option unchecked so only brightness can be adjusted.

-Bottom option unchecked

Thanks a lot!

Share this post


Link to post
Share on other sites

I had this problem with my 600d and raw files. One resolution is to manually select your camera type in the list provided. Unfortunately 600D didn't appear so I have to use a generic raw setting. But then the best tip I had was to use the new Beta version of DSS and this cured the problem.

Share this post


Link to post
Share on other sites

This is a common problem with DSS

The fix is when you have stacked your image, check the box that says " embed changes but do not apply them" then all the data will be there when you move to PS or whatever you use, you don't want DSS changing anything, but it has a habit of doing so, you just want it to stack the images, and nothing else, leave all that to Photoshop or Gimp or whatever you use.

For some reason it always try's to do a colour balance and it rarely works, the image may come out slightly darker but all the data and colour will be there, just adjust it all in processing software of your choice.

Hope that helps

Olly

Share this post


Link to post
Share on other sites

I may be wrong here and I am sure someone will correct me if I am, but when you stack in DSS it automatically saves the file as Autosave(perhaps a number).TIFF. As I understand it this is a 32 bit TIFF. When you choose save in DSS you have only the option to save as 16 bit or 8 bit. I don't understand it but from what I have read that seems to be the case. If you can get the 32bit to load into PS or Lightroom (certainly later versions will accept) then try using this as I find there is more data and colour is easier to bring out. From my experience not many other editors will load 32 bit TIFF's.

Share this post


Link to post
Share on other sites

I had this problem with my 600d and raw files. One resolution is to manually select your camera type in the list provided. Unfortunately 600D didn't appear so I have to use a generic raw setting. But then the best tip I had was to use the new Beta version of DSS and this cured the problem.

am having the same issue as the OP, where exactly can you choose the camera type in DSS  I cant find it

Leigh

Share this post


Link to post
Share on other sites

am having the same issue as the OP, where exactly can you choose the camera type in DSS  I cant find it

Leigh

I think it was in the Raw/FITS dialogue. You shouldn't really need to do it unless you are externally converting Raw files but it can't do any harm. I changed to the Beta version which I believe is now the release 3.3.4?

Share this post


Link to post
Share on other sites

Seems that I finally made it! I don't know exactly if that was  the only cause of the issue but the option that MagnaMan said seemed to be one of the possible problems (I experimented changing several options). And here is the result, please don't be harsh, I have so much to learn and this is one of my first astro photos (I think I used too mucho ISO in this one, so much noise and the tree is a pain in the ass :D). Advices are welcome!

Milky Way

Thank you all for your help!

Share this post


Link to post
Share on other sites

Maybe layer mask the tree and put a single sub of it over the top? It's distracting from an otherwise nice wide field.

Sent from my iPad using Tapatalk

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.