Jump to content


SkyQ wi-fi adapter and iPad App

Recommended Posts

I thought i would purchase the nice little gizmo that is the SkyQ adapter, and it would make everything so much easier, or so i thought!!!

Considering not only did it cost me £122, i also had to pay for the app at £2.99, which is a complete waste of money IMO.

After plugging the adapter in, and then connecting the iPad everything was going well, until I wanted to align the telescope.

After selecting the first star i noticed that the Telescope Overlay controls would not detect my finger although it would select any star on the display. So basically I could not use the iPad to align the scope. I can control the scope in the telescope settings page but not when in sky view mode.

Is there something i've missed, or has anybody else had this issue?

Link to post
Share on other sites
  • 1 month later...
  • Replies 30
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

It's definitely the app. Celestron has not released the required specs for other software to work with the SkyQ adapter. I also have Sky Safari and have used it with the SkyFi module. It's good but th

I've been going through all the agony described above and can only say that Apple are not holding their part of the bargain. But Celestron are slow producing updates and get caught running late when t

I have the same problem on my new iPad and also older iPod. The directional controls do not register my finger touch. Celestron posted an app update on Sept 23 but this did not fix the problem. I was very frustrated that the app did not work after spending $100 on the Wifi module. I emailed Celestron but have yet to hear back from them. I guess all we can do is wait for another app update.

Link to post
Share on other sites

That sounds a shame. I have the Orion module and run it with Sky Safari Pro (the app cost $50 but is unbelievable!!) and it works a charm on my Meade LX90. Looking clear at the moment, I' m going to give it it's first try tonight on the AZ-EQ6.

Perhaps it's the app. Are there any others compatible with the SkyQ module? I'd think there must be?!

Link to post
Share on other sites

It's definitely the app. Celestron has not released the required specs for other software to work with the SkyQ adapter.

I also have Sky Safari and have used it with the SkyFi module. It's good but there are cords all over the place once it's set up and the SkyFi connection to the Celestron CPC-800 hand controller seems weak. In contrast.... the SkyQ plugs directly into the scope, bipasses the hand controller altogether, and is powered by the scope. The SkyQ alignment is maintained even after the scope is turned off (as long as you don't move the mount). I'm always bumping the CPC-800 power cord and loosing power -- then have to realign when using the SkyFi. The power connector seems to be a weak link in the CPC-800.

So I'm inpatiently waiting for a SkyQ app update.

  • Like 1
Link to post
Share on other sites
  • 3 months later...

Shoud have read this thread before buying!! :embarrassed:

The SkyQ link arrived yesterday - I was in two minds but took the plunge and now on balance wish I hadn't.

The problem is exactly as described - everything goes to plan except when you align. Then the controls don't work at all. :mad:  :mad: :mad:  

I have read elsewhere that if you move the scope using the handset, the SkyQ won't accept the movement as centering, so I'm stuffed either way.

I've asked the retailer (F1 Telescopes) for a refund, as I had long conversations with him before and he never mentioned this issue, but we'll see huh!

I'm also going to email Celestron (yet another on the long list for them), but I cannot understand how a reputable company like Celestron can make such a total horlix of this :shocked:

It needs addressing or it's the equivalent of robbery - selling products known not to work.

They should fix it or withdraw it and give their clients their money back!!

In My Opinion.


Link to post
Share on other sites


Had a long and very useful conversation with Luigi at F1 - very helpful & accomodating guy.

Seems the issue may well be iO7 on my ipad/iphone, rather than the Celestron gear.

He's happy to give me a refund, but is aslo going to contact Celestron to see if there is anything that can be done in the meantime.

I will report back asap.


Link to post
Share on other sites

From what I've heard Celestron produce updates, submit them to Apple to be put in the iTunes store, and what appears for download is different to what they submit.  I don't know if the store version isn't updated or if it's changed in some way.

There's no other way they can provide the code.

Edit: I hadn't heard the iO7 news, maybe that's the answer.

There is a new mount just released that's WiFi only, for Apple and Android.  That's almost certainly going to use the same connection so they will have to sort this out.  My guess is that their challenge is getting someone's attention at Apple to help find out what the problem is.

I've heard that it's possible to set up a PC with NexRemote to communicate and use NexRemote.  This is obviously not the same but it will give you a chance to try it.

There's a fair amount about this on TeamCelestron.com, if you join that you can add to the requests for this to be sorted.


Edited by Chris Rowland
Link to post
Share on other sites

Hi Guys,

Firstly, thanks to Radec for posting out this thread - I hadn't seen it, but commented on another thread for the adapter and he (presumably - I don't know if you're male or female - apologies if you're the latter!) posted a link to this thread.

I have the adapter and so far haven't had any problems aligning either of my scopes with it.

Tech stuff: Both of my apple products are using iOS 7.0.4, and the apps on both are version 2.1.1, last updated in September 2013.

Anyway, I guess I'm trying to tell you what I do to use this gadget to see if that helps any of you out.

Firstly, whilst the touch screen technology used by apple is very intuitive, I don't feel that it is for this app.  Its the only app where a 'heavy' touch is required.  A firm press on the direction arrows and holding my finger/thumb there is how I get it to move. You know when it's recognised your touch because the direction arrows light up in a more prominent red colour.

Secondly, the slew speeds on this app DO NOT represent the equivalent slew speeds on the scope. Anything less than 9, and the scope barely moves.  The slew speeds are controlled by a slider that appears on the screen after you've selected the star you want to align to.  Up this to 9 (NB: even for centering the star in the EP, I only ever set the slew speed to 7/8), and then press and hold the direction arrow you want to go in - firmly! 

Hope this helps. 

Obviously, if you have any other questions, please don't hesitate to send me a message, or reply to this thread. 

Link to post
Share on other sites

Thanks for that Rae - interesting.

It could answer one issue that I have - the directional buttons have worked on odd occasions during the alignment process.....

Usually on the third star..... :confused:

I'll set up again and try one more time.

(Mr) Radec :smiley:

Link to post
Share on other sites

A quick update.

It doesn't work, no matter how hard I press, yet the very first time I connected it, the 'up' worked!

Then I tried another and everything stopped & hasn't worked since.

That got me thinking..............

There are 3 lights on the unit - Power (always on); Mode (always flashing) and Transmit - (flashes fast till connected, then off) 

Now, if I go straight to 'control' - all the direction buttons work fine. The problem is purely with the alignment function.

So, when pushing a direction button in 'control' mode, the transmit light flashes once at the start and once when you let go - obviously receiving the signal to start & stop.

Go to the 'Align' mode and the transmit light stays off until you have selected the first star and the direction buttons appear.

It then flashes permanently, as though the App is always talking to the mount!

If I quit the alint function and go back to simple contro, the buttons work fine.

Don't know if this helps or not, but the more info in the chain, the better eh!


Link to post
Share on other sites

Are you connecting via the Direct Connection mode?  I've never managed to get it to connect using the other method.  All of my experience with this adapter and app has been via the direct connection method. 

My apple products are an iPhone 5S and and iPad Air (not sure if this makes any difference since I'm sure it must be to do with the OS and not the actual product.

With regards to the 3 lights.... Mine operate the exact same way as yours, so I would assume that means that its working correctly. 

It is definitely easier to control the scope than to align it.  Sometimes, I have to press a direction arrow more than once to get it to recognise my command.  At the start of the alignment process, I normally have to try each of the direction buttons in turn before it stars to move, but then it does work and allow me to move the scope.  

It is easier for me to do it using the IPhone.  The iPad is much less responsive to my touch, but again, it does still move.  

It is a laborious task to align using this gadget - purely because it's difficult to get the app to recognise finger presses, but again, I can do it with both the iPhone and the iPad - albeit with a LOT of perseverance.  

Since seeing this thread, I've done a little bit of research on this issue and it seems that there are mixed views as to whether its apple's or Celestron's fault, but I can't help but feel this is something that Celestron should be working on - and keeping those who have made complaints updated as to what progress is being made (from their end).   Whilst this is a 'gadget' (in the sense that it isn't really necessary for the scope), it's not exactly cheap! And the app costs money as well.  

Link to post
Share on other sites

Hi All.  I got a Sky Q a few months back hoping to use it on my CG5 and my I Phone 5.  Just as you all note.  Could not set up the alignment as the App did not recognise the directional buttons.  Recognised the mount but it would not budge.  

Sold it on.  Glad i did now after reading this thread.

Hope its sorted soon for you all.   regards  John

Link to post
Share on other sites

Well it just wouldn't work for me at all.

I've even joined the Teamcelestron beta forum in case something surfaces there.

I'm running an iphone 4s and iPad 2, but you are correct Rae, there's a certain amount of bouncing between Celestron & Apple.

My guess is it's the latter with the ios7 update. I understand that it works prefectly with ios6, but you cannot retrace the upgrade once it is in place.

Something about the coding in the ios7 is not compatable and they each blame each other :mad:

Someone on the TeamCelestron forum reckons they will dump the SkyQ app in favour of the Cosmos app (which is free) that they are introducing to control their new range of Cosmos scopes shipping this month.

Just a thought.


Link to post
Share on other sites

I Have to say that does look interesting.

Thanks for the heads-up there Richard.

I will look into that tomorrow.


I use their main nexus with my dob and its excellent, so I would expect this to be just as good for its purpose.

Link to post
Share on other sites

I've been going through all the agony described above and can only say that Apple are not holding their part of the bargain. But Celestron are slow producing updates and get caught running late when they release. We just 'Ipay' for all this miscommunication.

Why not move the whole development to Android and get on with a what is after all 'a good idea by celestron"?

  • Like 1
Link to post
Share on other sites

Been meaning to post this for a few days - didn't get the chance till now! :embarrassed:

I managed a brief set-up & test on 20th Feb and used the SkyQ to align the mount.

Having connected and without the use of the app direction controls, I used a combination of the iPad and the handset to align......

And it worked!

The system took the alignment as genuine and the stars were absolutely spot on. Tracking was normal.

Jupiter was an issue however – always a slight amount under the planet, despite being accurate with the stars and DSOs I selected.

I put it down to maybe a time issue – it took me a fair while to align the scope and I wondered if perhaps the system takes the time you start, which would corrupt the planets more than the stars.......

Until I came in and checked.

The system had decided I was in Birmingham as the last time I used it, I didn’t shut the app down correctly and it took it on itself to change my location!

That would cause the problem with solar system objects as Birmingham is further west from me.

It's also a shame the app doesn't have any facility to refresh alignment on objects as you progress, like the handset does, but overall, if the success can be repeated and isn't a 'one-off' - I will be delighted :smiley: 

More news when the sky clears again!! :mad:


Link to post
Share on other sites

Glad you got it working radec! I still have major problems when using iPad, it does seem much harder to get the direction arrows to respond, so I've just been using my iPhone.  Weird how its easier with one than the other.

Must admit, I've never tried using a combination of both handset and app.  Will give this a go on the next clear night.  

Thanks for the info! 

But, I still think its worth pursuing any complaints with celestron.  The app is meant to be able to be used without touching the handset at all, so this is still something that celestron need to sort out... whether in conjunction with apple or not.  I sent an email to their support team a couple of weeks ago, but no response so far.  Will keep you all updated should I hear anything back. 

Link to post
Share on other sites

Nice pne Rae - good luck.

Just had another go tonight - same result - a good clean alignment :smiley:

Accuracy only slightly less impressive - it was consistent at putting objects into a 15mm eyepiece, but not centred.

Having said that, they were always in the same position, so it may have been a set-up issue (the tripod was level) of some sort.

Either way, it's liveable-with.

What I also tried was to go from skyview to scope control to ajust the position of the telescope to bring objects to the centre, rather than the poxy handset, which is getting cranky on the button front. The direction buttons sometimes move - sometimes not!

Just like an old TV remote :rolleyes:


Link to post
Share on other sites
  • 2 weeks later...

Im about to order one of these, I have an iPhone 5s on io7. something, im such a n00b and was hoping this would be something for me , its a lot of money if its doesn't work, as I wanted the easy(lazy?) route in finding stars etc


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. By using this site, you agree to our Terms of Use.