Jump to content

stargazine_ep44_banner.thumb.jpg.6153c4d39ed5a64b7d8af2d3d6061f61.jpg

Clearing old com ports on windows 7


Recommended Posts

HI thought I would post this as it may be useful to anyone having com port problems as if you are unplugging and replugging devices into different usb slots, then each time a new higher numbered com port is likely to be allocated leaving phantom com ports behind.

So to clear old com ports for windows 7, as windows xp method wont do it on 7.

To permanentely display the phantom devices in device manager first right click computer>properties>advanced system settings>advanced tab>environmental variables at the bottom. Click new and put in variable name box the following devmgr_show_nonpresent_devices then put 1 in the variable value box then ok and out.now click start right click computer>properties>device manager>view>show hidden devices then find com ports right click on each of these and uninstall restart computer and that should sort it.

  • Like 4
Link to post
Share on other sites

I'll do this tomorrow .

Hi I forgot to mention that when you show hidden devices and then right click on the com ports a warning message appears saying you are about to uninstall this device are you sure you want to continue don't worry about this you wont because in this message box is a tickbox giving the option to uninstall the driver software make sure this is unticked.Next time you plug in your mount or focuser etc then a new lower com port will be allocated and if you continue to use the same usb slot for these devices the same com port should be allocated each time

Link to post
Share on other sites

I had to do this on my previous XP netbook but now I'm using a Win 7 laptop it hasn't yet arisen but no doubt it will. So thank you very much for that :) I can see that it's by no means the trivial thing to do that it ought to be - another example of MS making things difficult for the user!!

Link to post
Share on other sites

I had to do this on my previous XP netbook but now I'm using a Win 7 laptop it hasn't yet arisen but no doubt it will. So thank you very much for that :) I can see that it's by no means the trivial thing to do that it ought to be - another example of MS making things difficult for the user!!

Yes MS do seem to like to make things difficult,I believe its like this as a security measure but don't ask me why this is a security measure because that's well beyond me

Thanks Andy - that's great - I was up to COM30! - I've found this also works in Windows 8 .Cheers Steve

I think eqmod doesn't like high com ports above 18 I think, so well worth clearing them out

Also when you get it to show hidden devices you can allocate the com port yourself.To do this go to the hidden devices find the device you want to adjust right click then click properties then advanced then click the port settings tab after which you will find a dropdown box for com ports.You will have to unplug your device and replug it for the changes to take effect or better still change it before plugging it in

Edited by andyo
Link to post
Share on other sites

EQMOD only takes com port numbers up to 16. Maybe there's a good reason for this but I don't know what it is.

Yes, there's a good reason. EQMOD uses microsoft dlls and activex controls to access the com ports and these date from a pre "plug n pray" age when serial ports were few and far between and USB was for printers and mice :-) The resitriction lies in these external componets (also it would be very teadious if the auto comms serach had to go through all possible com port numbers - it takes quite a while with just 16!)

Chris.

Link to post
Share on other sites

Well I followed the instructions, and can't find any com ports. I found PORTS, but there is only 1 item . Not sure if I am doing something wrong as I have connected quite a few things to my USB ports and don't always use the same port twice. I have for example used my DMK41 in every usb socket.

Link to post
Share on other sites

Well I followed the instructions, and can't find any com ports. I found PORTS, but there is only 1 item . Not sure if I am doing something wrong as I have connected quite a few things to my USB ports and don't always use the same port twice. I have for example used my DMK41 in every usb socket.

If you followed the instructions above to the letter then it should reveal your hidden com ports,I have used this on several laptops and desktops with 100% success.I assume you rebooted the PC.Also when you open device manager make sure you click the view tab at the top whicc will give a drop down menu from which you select show hidden devices then they should be revealed under ports com and lpt.Another thing to check is when you open the environment variables you will be presented with user variables and system variables.System variables should be the bottom selection it is this one that you need to select new from,then type in the instructions as above.Failing that here is a link to a detailed step by step method as above,let me know how you get on

http://www.rttyconte...g.com/lagniappe ... ports.html

PS just an afterthought you are running windows 7 and not vista as I believe this does not work on vista

Edited by andyo
Link to post
Share on other sites

Running Windows 7 64bit.

Rebooted and went through instructions twice and cheched COMS & LPT and still only have one listing for a 3g mobile connect on COM3.

I guess I haven't allocated any coms yet.

Link to post
Share on other sites

Yes, there's a good reason. EQMOD uses microsoft dlls and activex controls to access the com ports and these date from a pre "plug n pray" age when serial ports were few and far between and USB was for printers and mice :-) The resitriction lies in these external componets (also it would be very teadious if the auto comms serach had to go through all possible com port numbers - it takes quite a while with just 16!)

Chris.

Thanks for explaining that Chris :)
Link to post
Share on other sites

Running Windows 7 64bit.

Rebooted and went through instructions twice and cheched COMS & LPT and still only have one listing for a 3g mobile connect on COM3.

I guess I haven't allocated any coms yet.

If the one for the 3g mobile on com 3 isn't showing before you click view>show hidden devices then that must be the only allocated com port.I assume you don't use eqmod and that your spc900nc isn't modded for LX as if so both would have com ports allocated.I don't know about the dmk41

Link to post
Share on other sites

If the one for the 3g mobile on com 3 isn't showing before you click view>show hidden devices then that must be the only allocated com port.I assume you don't use eqmod and that your spc900nc isn't modded for LX as if so both would have com ports allocated.I don't know about the dmk41

Yes that must be it. I have no probs then

Thanks for the help.

Link to post
Share on other sites
  • 7 months later...

I would like to say a huge thank you for this. Had 6 ports unused, was getting timeout errors before.

After I followed the steps above, I also did something different to what I've been doing before. 

1) Install the prolific driver first.

2) Turn the mount on.

3) Insert USB cable into computer.

It found "Com 3" and it works like a dream! Last time, the mount was powered on last in this process.

Note this is on a Windows 7 machine, using a HitecAstro EQDIR cable to the mount.

Kind regards, 

Paul.

  • Like 1
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. By using this site, you agree to our Terms of Use.