Jump to content

Stargazers Lounge Uses Cookies

Like most websites, SGL uses cookies in order to deliver a secure, personalised service, to provide social media functions and to analyse our traffic. Continued use of SGL indicates your acceptance of our cookie policy.

SnakeyJ

Synscan Controller V2 and V3 Autopsy

Recommended Posts

My Skywatcher HEQ5 came with the older V2 handset and runs Ver 2.05 of the Synscan Firmware - despite this aged version, it functions perfectly albeit without the ability to upgrade the firmware and some of the advantages of the newer V3 (PAE, Backlash Compensation and GPS support).

Beside this the units looks superficially identical and there seems to be little information to compare and consider the under the hood differences. So what follows is a quick side by side comparison, with lots of pictures.

On display are ; left - fully working V2 (ver 2.05) handset and right - a defunct V3 (ver n/k) handset that I'm hoping to resurrect.

med_gallery_26731_2542_1088427.jpg

From the front view the units are identical, other than the different coloured Synscan logos, there are no differences between key layouts or connection ports or the backlit LCD displays.

med_gallery_26731_2542_1005321.jpg

The units are also indentical from the rear view (other than stickers and velcro). There are 4 x No1 recessed cross point screws which are removed to gain access.

med_gallery_26731_2542_1338031.jpg

Closer comparison of the two PCBs (Rear View). Here you will notice the changes in layout and updated components on the V3 handset - Although there is commonality of many of the board components, the processor, flash and RAM memory ICs are updated..

gallery_26731_2542_1543746.jpg

Fully exploded view of both Handsets (showing front view/ekypads of PCB): Other than the PCB differences there is full comonality of parts between these handsets.

gallery_26731_2542_216400.jpg

Close up comparison of front PCBs

gallery_26731_2542_819845.jpg

The V3 circuit board design shows significant design simplification corresponding with the layout changes to the rear of the board.

There are some closer images of the PCBs in my gallery

Both units were re-assembled and some minor soldering done to re-attach the LCD backlight on the V3 handset. V2 handset now working with less sticky keypad membrane and the V3 handset is still stubbornly refusing to give any sign of life, though a quick check with my multimeter revealed useful voltages at key points - seems likely that the main logic is dead!

Hope this is of use for future reference ;)

  • Like 3

Share this post


Link to post
Share on other sites

A closer look at the LCD displays confirms they are identical 16 x 2 backlit LCDs units:

gallery_26731_2542_261301.jpg

The markings are:

VDM-000197FYS

A5 11 10 005933

  • Like 1

Share this post


Link to post
Share on other sites

Just by way of update - closer examination of the V3 handset revealed:

The backlight connections had been broken (presumably a previous repair attempt). These were easilly re-soldered and the backlight functions correctly with + 3VDC.

LCD faulty. No obvious damage or leaks on this, so may be a faulty ribbon cable/connection.

Though the board does not boot, I can get 12v, 5v pwr from the board - however, 3V does not seem to function correctly. With the board powered I see around .8V across J5 - though if check this jumper for resistance I'm detecting a short. A couple of attempts have been made to solder at this jumper and there is some minor heat damage, but no obvious short circuit here - so it seems likely the short is a component failure further back on the board.

I will attempt to trace the tracks back tonight (as I need my desktop magnifier for this job). Chances of success looking slim at the moment!

  • Like 1

Share this post


Link to post
Share on other sites

Jake

i was wondering if you ever got the V3 handset going as it seems I have the same situation with mine. Sure would be nice if a schematic was available for the circuit board.

Tom

Share this post


Link to post
Share on other sites

Very useful post, thanks. My V2 Synscan controller has given up and it seems to be the LCD: the controller functions but will not display anything so it's pretty useless at the moment. Rather than forking out 3 figures for a new controller, I was wondering if you managed to source a compatible replacement LCD for your V3 and if so, where from?

--- Alistair

Share this post


Link to post
Share on other sites

Could try https://www.teleskop-express.de/shop/index.php/language/en/cat/c189_Replacement-Kits.html/filter_id/21

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By pete_81
      Hi guys,
      With new mount and upgraded scope features, now looking to venture into imaging.
      Before I start, I'm not looking to get feedback on polar alignment, mono guidecam, better imaging cameras, etc; this is more a 'dummies guide' setup discussion! I'm not expecting to get great images at this stage, just more the options available, getting over some issues, so that I can jump outside on a clear night with an ideal, foolproof(!), setup for either imaging or visual as time would permit and what may work best for me. As you may guess from the topic name, I'm a mac user (Macbook Pro) and would rather keep to this if possible (whilst I do have Windows (and Ubuntu) via parallels, I'd rather not use these).
      I've got a setup which has worked well for visual, and obviously want to have a couple of 'staple' setups that I can use depending on expectations of night observing or imaging. So far, the best one for me has been the Skywatcher Wifi Synscan controller, which has worked a treat with my Android phone - I use the Synscan app to complete alignment and GOTO stars/planets/DSO etc, or Stellarium_plus after completing alignment. This removes the need for the Synscan Handset and any USB cables to the mount altogether. But I don't know if this will work for guiding.
      That then brings me to my issue on mac - connecting USB(A) between Macbook and Handset, I've attempted to control the mount through Stellarium. Trying each of the available connections (/dev/tty.usbsetial-1420, /dev/cu.usbsetial-1420, and just for sake of it, the /dev/tty.Bluetooth-Incoming-Port and /dev/cu.Bluetooth-Incoming-Port) in the dropdown menu under DeviceSettings/SerialPort, I cannot get the mount to connect (well, more like selecting the telescope and clicking the "Start" on the TelescopeControl just results in the spinning icon and I have to Force-Quit Stellarium and start again with the same result each time. Annoyingly (for fellow mac users!), Parallels/Windows/Stellarium connects and controls the mount fine! As the mount is the newer "pro" type, I also have a USB connection directly under the hand-controller RJ45 and AutoGuider ST4 sockets, but using this still results in the same issue. Another issue I have seen is that when I unplug the USB from the computer when connected to the handset, the date on the controller jumps significantly - for example, last night at ~23:30, I was transported through the local wormhole galaxy to Jan 2048 according to Synscan! Obviously unplugging isn't going to happen during a genuine session, but just wondering if this is a possible issue somewhere?!
      Any other mac users connecting USB directly to the SW 'Pro' mounts?
      Software wise, would folks generally suggest steering away from Stellarium towards KStars or SkySafari(Plus) for controlling the mount?
      Can the Wifi dongle be used for controlling mount from computer (any OS) or do I need to go USB either to handset or directly to mount?
      Is there an issue in using Mac USB to the telescope compared to 'straight' Windows (i.e. PC/laptop with Windows instead of virtual)?
      Anyway, back to topic... I've a Nikon DSLR to use for primary camera at this stage, which would be triggered independently from guiding software. PHD2 is my hopeful choice of guiding software (is EKOS with KStars similar?), with T7C guide-camera on 240mm f/4 guidescope, and at this stage, I can confirm PHD2 at least connects to the camera on OS-X. There is an ST4 port on the camera, but having read several topics, I think I want to pulse-guide directly - is this correct or is ST4 best for this setup? This sorta comes back to software and connections - my understanding is one of the following cable setups for guiding (as a minimum) :
      Guiding-camera => USB(A) => Macbook => PHD2 => USB(A) => SynscanHandset => AZEQ6
      Guiding-camera => USB(A) => Macbook => PHD2 => USB(A) => AZEQ6
      Guiding-camera => USB(A) => Macbook => PHD2 => Wifi => SynscaWifi Adapter on AZEQ6
      [using ST4: ST4_on_AZEQ6 => Guiding-camera => USB(A) => Macbook => PHD2] (no additional connections needed if ST4 is used)
      Additionally, I'd like to use an observatory package, say Stellarium/KStars/SkySafari, to select objects and drive the mount, then use guiding software to keep good 'tracking'.
      Where in this train does EQMac fit in, or when is it used?
      What about the 2019 addition to EQMod (ASCOM Alpaca)? Can this be used or is it already in other packages?!
      For Windows users, how does EQMod fit in (if I go down route of getting Windows laptop for controlling things, is the setup similar to above?
      There may be bits in the above that repeat, and for that, I'm sorry, just want to get across the message that I'm new to the guiding but haven't quite settled down into the software/hardware I'm expecting to use for 'goto' and 'guiding'
      TLDR:
      For a mac user, what setup and software are folks using for guiding and observatory softwares for the newer USB-on-mount 'AZEQ6/EQ6-R Pro' mounts from SW?
    • By Marsto
      Hi
      I am looking for help and advice on my SynScan EQ5 pro problem which i am struggling with. Everything was working fine and as expected. I have never updated the firmware and thought while i had everything connected i would update the Hand Controller and the skywatcher WiFi dongle. 
      Everything updated first time without issue and i was pleased to be up to date. However i loaded SynScan app on the pc which connected fine through the handset and USB/Serial adaptor cable. I clicked on the movement arrows and nothing happened, i then went in to a random 1 star alignment and again no response from the motors. 
      I powered off again and instead of the PC i tried the hand controller, i tried a 1 star alignment and the hand controller was displaying the slewing but again no response from the motors. in panic i then did the same with the WiFi dongle and phone app, same thing the software is showing movement but the scope remains still. 
      Knowing all was well prior to firmware updates i reverted back to the previous firmware version and no difference, i tried it again in Lo mode and still nothing. I then noticed a firmware update for the Motor Control so thought i had nothing to loose i updated the Motor Control firmware and again no sign of life from the Motors. I have swapped the cables around, checked that they are all inserted correctly, the power is from mains not battery and the power source is plugged in to a a Power Filter and Surge protector. 
      I have little experience of circuit board electronics, i was struggling to find similar experiences online other than voltage issues due to batteries which is not the case. I have opened it up and no obvious loose cables of solder loose, but this was straight after the firmware update which seemed to have installed and updated very smoothly no crashes etc. 
      Any help would be really appreciated. 
       
    • By MattsGazingAgain
      Hello all,
      First post since my initial hello message due to a lot of cloudy nights and a small wait until I could afford my very entry level camera. I would like to apologise straight away for my lack of knowledge and the poor quality of my images. The framing is terrible and they're out of focus, but I'm also completely over the moon with them. I'm very eager for you guys to rip them apart and tell me all the ways I went wrong but I will always love these 4 images as they are the very first successful AP images I've taken
      My equipment is as follows
      skywatcher 150pds on a eq3-2 pro synscan mount
      Polar scope
      Canon 2000d
      Super coma corrector
      I have tuned the motor drives for the mount but haven't stripped down and cleaned and greased the mount itself yet but plan to. Also plan to upgrade to a heq5 Pro asap. I have no guiding other then synscan. Again something else I hope to change as soon as I can but for now its an oppurtunity to learn.
      None of the images are stacked, they're single 30 sec exposures. I very slightly adjusted the raw files by placing a slight s curve on the linear channel but will leave any further processing if I bother until after a good nights sleep. I've included both the before and after image.
      The first image is just of vega, I took it while star aligning. A awful pic for many reasons, especially the flare coming from the star, but my first so will keep it for sentimental reasons. The second I was very happy to catch some light from the ring nebula, and was equally happy to catch the dumbell nebula a little. The fourth is the globular cluster. All really bad framing but was suprised to catch the nebula on just a 30 sec exp with my light pollution. 
      Can't wait for your ideas,suggestions and criticisms. My apologies for a very long post but feel very hyped up even after such awful results.
      Many thanks and clear skies
      Matt
       








    • By NallyFace
      Hello,
      Is anyone on here signed up for the SkySafari and SynScan beta testing to natively support IOS? If so how has it been going?
      https://support.simulationcurriculum.com/hc/en-us/community/posts/360043282514-Beta-Testing-SkySafari-6-iOS-Only-SynScan-WiFi-Read-This-To-Participate-?page=2#community_comment_360012192693
      Its 2020.
       
       
    • By GavinC
      I thought the recent email exchange between Skywatcher support and myself might be of interest, as there appears little information available on this feature.
      ===========================================
      Hi Gavin,
      Regarding "Alignment Sharing", please see the description below.
      ## Alignment Sharing
      Alignment data is stored in each individual app instance. This means if you performed alignment using one app instance, only it will have the newly created alignment data. If another app instance connects to the same mount, it will not have access to the new alignment data.
      The alignment sharing feature (**Utility > Alignment Sharing**) allows one app instance to send a copy of alignment data to another app instance. For it to work, the devices running the app instances must be on the same local area network (eg connect to the same Wi-Fi network). The sending instance turns on **Share my alignment**, while the receiving instance turns off this option. The receiving instance should then see the shared alignment data appear in a list. Loading alignment data overwrites the previous alignment data.

      You can use the Alignment Sharing to transfer the alignment data to another device after completing a Star Alignment. For example, you have done and successfully complete 2-Star alignment with your smartphone and then you can use the Alignment Sharing function to share the alignment data to the SynScan Pro App Windows program which is running on your PC. Then you don't have to do the alignment again to control the same AZ GOTO mount with the Windows SynScan App because it has the same alignment result as your smartphone has.
      If you have any questions, please feel free to let us know.
      Thank you.
      SynScan App Team

      On Wed, Jun 24, 2020 at 1:22 AM Gavin Cox wrote:
      Hello,
      I have just seen you have updated the Synscan app firmware to 1.19.  I have this installed on a Win PC and Android phone and use it to control a AZ GOTO mount running the latest firmware using the Synscan Wifi Dongle.
      There looks to be some new functionality under the utility menu called 'alignment sharing', but I can't find any documentation in the help files on this?
      Please can you detail how it can be used?  If both my phone and PC are connected to the SynScan WiFi hotspot and I perform an alignment on my phone will the app on the PC recognise this too (or vice versa)?
      Thank you,
      Gavin
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.