Jump to content

Stargazers Lounge Uses Cookies

Like most websites, SGL uses cookies in order to deliver a secure, personalised service, to provide social media functions and to analyse our traffic. Continued use of SGL indicates your acceptance of our cookie policy.

stargazine_ep28_banner.thumb.jpg.b94278254f44dd38f3f7ee896fe45525.jpg

Sign in to follow this  
sabana

Skywather 130p GOTO missing part

Recommended Posts

Just picked up a cheap 130p scope from Skymax. The problem is that where the tube should mount, there appears to be no L mount or multi-function mount on the tripod? Should this be included as I can at present just mount the tube directly by just slotting it in and tightening it with the retaining nut but it doesn't look right?

Any help much appreciated

Share this post


Link to post
Share on other sites

If its the same az-alt mount you get with the Sky watcher 130p statrak, then it is like that, doesn't feel all that secure at first but I must admit if the holding screw is tonight enough it doesn't shift at all. Though I would be very dubious about strapping a DSLR or heavy webcam onto the telescope with that mount.

Sent from my Nexus 7 using Tapatalk 2

Share this post


Link to post
Share on other sites

Yes. Thats very similar. The black arm that supports the tube has a slot with a nut inside. On some pictures I see a multi-function mount or l mount thst slots into these grooves thats why I'm concerned it should have been included. At present the tube just goes directly into the arm and is supported by one rotating screw underneath. It seems a bit flimsy.

Share this post


Link to post
Share on other sites
Yes. Thats very similar. The black arm that supports the tube has a slot with a nut inside. On some pictures I see a multi-function mount or l mount thst slots into these grooves thats why I'm concerned it should have been included. At present the tube just goes directly into the arm and is supported by one rotating screw underneath. It seems a bit flimsy.

That is the correct way, I have a 130p AZ GOTO.

As long as the bolt is reasonably tight (hand only, don't use a tool) it should be fine.

It's a dovetail, so it doesn't fall off directly, it can only slide out.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.