Jump to content

Stargazers Lounge Uses Cookies

Like most websites, SGL uses cookies in order to deliver a secure, personalised service, to provide social media functions and to analyse our traffic. Continued use of SGL indicates your acceptance of our cookie policy.

  • Announcements

    SGL 2017 SP

Sign in to follow this  
PNJ

Skywatcher All view panorama mount probs

Recommended Posts

PNJ    226

Hi All

I have the new Skywatcher All view multi panorama mount. What a nice piece of kit for the money.

however i cannot get the electronic shutter release to work

the mount comes with a short lead with a 2.5mm stereo plug at each end. Its basically 2 wires and when shortened together like a switch its sets of the shutter in your camera. Like pressing down on a button with a remote.

The prob i got its not doing this, i have put a test meter across the pins on the plug and im getting nothing from the socket output or on the pins of the plug.

off course with the camera plugged in too, no responce.

i read on a american forum that people are having the same problem

Paul J

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×