Jump to content

Stargazers Lounge Uses Cookies

Like most websites, SGL uses cookies in order to deliver a secure, personalised service, to provide social media functions and to analyse our traffic. Continued use of SGL indicates your acceptance of our cookie policy.

Kef9

Replacement Dec/RA Slow Motion Knobs CG5 / EQ5

Recommended Posts

Hi Guys

Does anybody know where is the best place to get replacement CG5 slow motion control knobs? My young son decided in his wisdom to start messing with my telescope :( and now one of the knobs has the metal ring inside missing meaning it no longer fits! So far I have found this;

http://www.harrisontelescopes.co.uk/acatalog/SkyWatcher_Slow_Motion_Cable_Set_EQ2_EQ5_AZ3.html

Does anybody have any experience of using these?

I want a like for like replacement but I can't find one online so I guess I would have to talk to Celestron/skywatcher if I did. However if these are better then I might as well get them.

I also did a bit of reasearch prior to posting and come guy came up with using these. A bit left field I know!

http://uk.rs-online.com/web/p/potentiometer-knobs/2597039/?searchTerm=259-7039&relevancy-data=636F3D3126696E3D4931384E525353746F636B4E756D6265724D504E266C753D656E266D6D3D6D61746368616C6C26706D3D5E5C647B337D5B5C732D2F255C2E5D5C647B332C347D2426706F3D313426736E3D592673743D52535F53544F434B5F4E554D424552267573743D3235392D373033392677633D4E4F4E4526

Any comments, help or advice most appreciated! :)

  • Like 1

Share this post


Link to post
Share on other sites

Nothing wrong with either recommendation. Except perhaps the difficulty dealing with RS components if you don't have an account.

I don't have a manual CG5 for comparison. But if it is a 6mm diamter shaft, with a flat, it is a standard control knob size - there are others so read the small print. Take a look around an electronics hobby shop near you, or any of the online electronics hobby people, like Maplin. Or look at the 'Farnell' or rapid Electronics' web sites. They will deal with you subject to a minimum order value. You will be spoilt for choice. There are knobs in all shapes sizes and colours.

Then of course, if you wish to change for knobs on the end of a flexible shaft, these are a good solution. I have used them before. They might be a bit clumsy for storage, depending on how you store the mount. Or you might want to remove them each time.

Hope this is useful.

Share this post


Link to post
Share on other sites

I thought the CG5 was already motorised?

Why not take the opportunity to add a single-axis (or dual axis, the price is not much more) motor drive?

Something like this would probably fit - http://www.firstlightoptics.com/skywatcher-mounts/dual-axis-dc-motor-drive-for-eq5.html but don't quote me on that.

Only problem with the radio knobs is that they may not fit over the axle, as the flat is usually inset along the shaft slightly so that the knob doesn't slide off accidentally.

Share this post


Link to post
Share on other sites

The CG5 is (or was) available in manual, motor and goto varieties. It is just the Celestron variant of the EQ5.

'Radio knobs' come in all sorts of fixing varieties.

This problem can be easily solved by using either 6mm shaft with flat, or 6mm round with collet fixing.

The knobs for inset flat types are not that common, and would still fit in this case.

Hope this helps.

David.

Share this post


Link to post
Share on other sites

If you're not in a hurry they sometimes come up on astroboot.

James

Share this post


Link to post
Share on other sites

Thanks for all the responses guys. :)

I actually managed to find the metal insert piece and put it back in the plastic knob and so I am back up and running again. However I now know what to do if they break again because they are quite flimsy! I think I might invest in the telescoping controls anyway.

Cheers

Share this post


Link to post
Share on other sites

I  purchased a Skywatcher NEQ5 and i´m having problem with the stock knobs

The knobs are very hard to fit in the shaft , i tried but i´m worried with the possibility of  damage the mount or the knobs with the pressure, i don´t know how deep it must pushed inside the D shaft. it fits a bit but is very difficult

 with the mountI i purchased two flexible knobs but the screw ot the AR axis touch the white plastic around the shaft  and is very difficult to tight with the fingers.

I woul need cut the screw a bit or replace it with a smaller allen screw .

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Carboncrazy
      Can anyone help? I'm pretty much a novice at this astronomy stuff but loving the steep learning curve. I started by using camera lenses modified to use an eyepiece but after much debate, deliberation and saving up, I have finally bought my first proper telescope. Unfortunately I now have a problem.
      Last year I bought a second hand Synscan EQ5 mount which has worked perfectly each time I have used it. I  used it about a month ago for the first time with the new scope (last time we had a clear sky). Everything worked as it should. At 2 am I parked the scope, dismantled everything and put it away. Nothing was dropped, snagged or got wet.
      The forecast said we might get a clear sky last night. Anticipating this I got the mount on the bench, stripped, cleaned, polished and greased the DEC axis plain bearings (hoping this might help with guiding). When finished I connected the motor controller and handset and switched on. I was greeted with the following messages: INITIALISING then CAUTION BOTH AXES NO RESPONSE. If I press enter and carry on through the menus, then everything appears to be as it should except no motors run. I have tried everything I can think of and would be very grateful of advise or suggestions. These are things I have tried, so far:
      Factory reset
      Different power supply. I have been using a motorbike battery which is giving 13.5V constantly when I switch on. I have tried two other batteries with a 2A charger connected.
      Continuity tested the cables from the plugs that go onto the motherboard of the controller all the way to the motors.
      I made up the  RJ45 and RJ12 diagnostic cables suggested in the manual and the handset appears to be ok.
      Removed the motors from the mount to make sure that they turn freely.
      Replaced the RJ45 cable from the handset to the controller.
      Examined the motherboard for dry joints and damaged components.
      Assembled everything in the tripod to make sure that the earthing tab on the controller made no difference.
      I now feel that the problem is the controller motherboard but logic tells me that it was the mount I disassembled, so the fault should lie there. Is there anyone who has had the same problem or who has the same system that could help me diagnose the problem. I'm in North Shropshire but happy to travel to anyone who could help. Unfortunately I don't know anyone with the same mount.
       
       
       
    • By Bigwings
      I need my garage back so am selling my excess mounts.
      1. EQ5 motorised on both axis.
      No tripod this was mounted ony pier. Tracks well. 
      £100 Collect only because of weight .
      2. An older type Skywatcher AZ goto mount that came with my SkyMax 127. Good condition .
      £100 Collect please but might be able to send if you arrange courier.
      SOLDto Pitbull ...thanks
      3. AZ GTi  goto in excellent condition . Still have the box so can send at cost.
      The pic shows it with a telescope on it which is not included.
      £200
      Location just north of Newark on A1
      Clear Skies.
      Thanks for looking
      All Sold.
      mods VB please move
       
       
       



    • By Greg6498
      Hello all!
      I have been using my Skywatcher 8” Dobsonian for some time now, and decided I wanted a good refractor with an EQ mount as my next scope. I chose the Skywatcher Evostar Pro 80mm with an LX70 EQ5 mount. This seems to be a great scope to compliment my Dob, but I'm still getting used to the EQ mount! Found some good Youtube videos and am hoping for a clear night soon to really give it a workout! Any advice is appreciated!

    • By kman42
      I have an EQ5 telescope mount which i use for astrophotography. I have modified it with a motorised RA axis using a bipolar stepper motor - my thread for the build is here .
      I want to expand the mount's tracking ability by motorising the DEC axis and using a guide scope/camera. I generally use the mount in fairly remote locations so would like to use a raspberry Pi for portability.
      I understand that I'll need to use a Raspberry Pi Camera Module for the guide camera. 
      The capability I want is:
      1. guide the mount along RA and DEC axes using a guide star as feedback
      2. track the mount using the RA axis only, and if possible continuously take 20-30 second exposures on the guide camera (this functionality is optional, but would assist in polar alignment of the mount)
      I don't want any GOTO capability. I am very new to RPi and need some help:
      - do I need to write code for this, or is there existing programming available for what I want to do?
      - is it possible to avoid the use of screens (in the field)? My preferred option would be to flick a switch to start and stop the guiding, with another switch for alignment mode (or something simple like this).
      - do I need to use any particular stepper motors/drivers for raspberry Pi? I'm using a bipolar stepper motor running quarter steps, with an A4988 stepper driver
      - is the RPi 3 Model B+ the unit I should buy?
      Thanks
       
    • By msacco
      Hello, so I bought my first telescope a few days ago, I bought a SkyWatcher 200p on a goto EQ5 mount, my first general impression is that I made a good decision, it was a bit over my budget, but I bought it second hand, and 8" with goto EQ5 is a good start in my opinion so far, as I won't need to replace is really soon.
      So I tried observing for 2 nights so far, I tried using it from my garden, and obviously its not amazing, but I live in a relatively small city with a decent light pollution.
      So the first night was pretty bad, it was really hard adapting to everything, learn how to use everything, my brother ripped by mistake the crosshair in the finderscope(I fixed it today tho, it was kinda loose before, so its even better now), and it was pretty hard.
      Today I read a little about the things that were harder to me, I tried to align my finderscope, and even tho Im unable to do it for some reason, I know where the finderscope leads me, so its a bit easier, I learned how to use my eyepieces better, managed to use the 2x barlow lens, I still couldn't figure how to really do all the aligning correctly such as polar align etc, but hopefully I'll learn that slowly. I also tried adjusting my goto mount, but I couldn't do it because when Im trying to do the star aligning I don't know yet which stars I should use, and trying to figure where each star is in a place that you're not even sure if you can see it because of light pollution is kinda hard, so I gave up on aligning the goto and just used it to move the mount sometimes to follow an object.
      The only object that I really saw was mars(I think), I couldn't see it very well tho, I tried using all my eyepieces(25mm, 10mm and 4mm) and my 2x, but it still wasn't really great. Im not expecting to see anything too well obviously, but I did except to see it a bit more zoomed and a bit more detailed than sort of orange lamp light, it makes me wonder what can I do about it, what do I need in order to see mars better? Is it because of the light pollution? Maybe the eyepieces? Something maybe Im doing wrong? Again, Im not expecting to see it like hubble pictures or anything, not even with details, but just see it a bit bigger and a bit more clear, this is a photo for example(took it with my phone and 10mm super eyepiece):
       
       
      One more thing is about the finderscope, when Im trying to adjust the finderscope, I simply can't adjust it enough to make it accurate, I need to loosen the screws to adjust it, but eventually the screw will just go out and the finderscope will still not be aligned with the scope, what can I do about it?
      I have a lot more to learn and experience, so sorry if I ask really stupid questions etc, thanks a lot for the help!
       
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.