Jump to content

Stargazers Lounge Uses Cookies

Like most websites, SGL uses cookies in order to deliver a secure, personalised service, to provide social media functions and to analyse our traffic. Continued use of SGL indicates your acceptance of our cookie policy.



QHY5 & Windows 7 64bit errors and resolution

Recommended Posts

Greetings folks,

Posting this here in case other people encounter the same issue and want to avoid the same pain.

Last night while fumbling around in the dark, I accidentally plugged my QHY5 USB plug into a USB port on the Windows 7 64bit laptop which I had not previously been using. After a short period of time thinking about it, the laptop came back and said it didn't recognise the device. ******, I thought, and plugged the USB cable in the port I always use for the QHY5, but now it came back and said again that it didn't recognise the device. Uh Oh.

I tried going back to the original drivers for the QHY5 that I had lying around, and going through the process of telling it to explicitly install the QHY5 drivers for that USB device (have disk) - then I got to the point where the laptop would recognise that the QHY5 system device was plugged in, the little red light would come on, but when I tried to use QGVideo or PHD etc I would get spammed with an error of "failed with error 121: The semaphore timeout has expired."

I was pretty gutted at this point as I realised I was going to lose the evening, but after much searching around I came across the reason for this happening and the solution.

Apparently the QHY5 does some sort of EEPROM update via the drivers, and under some circumstances particularly with Windows 7 64bit it can get messed up, and you need to reset the devices VID/PID. You will need a machine with XP on it to fix this (used a spare PC i had lying around) - the fix is here: qhy5 reports usb device when plugged in.

With the post from the QHY guy stating:

You need prepare a XP computer.

0. Check the VID/PID If it is not 04b4:8613. Go to step 1 . If it is 04b4:8613 . Goto step 2

( we supposed the vid/pid is FF18:0901, for example )

1 . uncompress the driver.rar. And there is a .inf file. Please edit it . change all 1618 0901 into the FF18 0901 (There is three position)

2 run the install.bat

3.Connect the camera. Computer will find the camera and install this new driver

4.After camera driver installed success. Uncompress the VIDPID.rar and following the step of the .doc

5.After successful rebuild. You can install the formal driver of QHY5. See if it works

6.After it works. You can add a write protect following the PDF file.

I used this method, which is basically reprogramming the camera so it's not messed up following the instructions in the attachments for that post, and then I was able to plug the QHY5 back into my laptop and bingo - everything started working again.

Quite a huge pain in the behind, but if anyone else gets that semaphore error with their windows 7 system, there is a fix for it !

Really happy now :blob10:

Hope that helps,

Share this post

Link to post
Share on other sites

Been there, done that!...It can happen with an under voltage of the usb, if running through an unpowerd hub with lots of connections for example.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.