Stargazers Lounge Uses Cookies

Like most websites, SGL uses cookies in order to deliver a secure, personalised service, to provide social media functions and to analyse our traffic. Continued use of SGL indicates your acceptance of our cookie policy.

Welcome to Stargazers Lounge

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customise your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

CeeDee

Celestron Advanced GT mount firmware upgrade problem

8 posts in this topic

I have a newly purchased Advanced GT mount running firmware: HC v4.16, MC 5.16

I have successfully upgraded the MC control software which went without a hitch but upgrading the Hand controller to v4.19 is proving impossible.

I have tried all combinations UNDO+INFO = ‘transmit data’ message and running the HCcontrol upgrade software. Yes, I downloaded the correct GEM v4.19 firmware selecting the correct USB virtual COM port etc. But every time I am getting an error message to say I must press UNDO+INFO on the hand controller in order to active the ‘transmit data’ mode. The comms through the laptop must be OK otherwise the MC control firmware could not have been transferred and installed in the mount. So does any know what is going on?? It is not a WIN 7 problem as I tried on a WIN XP laptop with the same results. :):p:p

Share this post


Link to post
Share on other sites

As far as I am aware not all handsets are upgradeable.

Share this post


Link to post
Share on other sites

Yes, that true. But the hand set with the CG5 GT is upgradeable as it has firmware v4.xx already installed.

Share this post


Link to post
Share on other sites

I too had the exact same problem when I got my CG5. I believe it's down to the USB-Serial lead (mines a prolific chipset by the way). So I ended up plugging it into my older PC that does have a proper serial connection, and it worked first time.

Maybe a different USB-serial lead, such as the FTDI version, might work. Someone else would have to confirm that though as I don't have anything other than the prolifics.

Share this post


Link to post
Share on other sites

Moving on.....

Managed to use a computer fitted with a RS323 serial port but running Ubuntu. Configued the serial port, downloaded the HC updater 1.1.14 and GEM 4.19 firmware. Put HC in ‘transmit data’ mode and BINGO! It worked ...up to a point. We got as far as block 09C4 and the thing froze when verified got the following error on the PC:

“Found difference at Bank: 0,block:16” :)

Now the HC is locked in ‘Transmit data’ mode and unable to run any firmware but at least it points to there being an incompatibility somewhere between Celestron’s HC com port and USB-to-serial conversion. Why don’t Celestron produce the HC with a USB port it would save all these problems???? No PC has had a serial port for years!

Now how do I reinstate the firmware?:p:p

Share this post


Link to post
Share on other sites

The guys over on Cloudy Nights Forum suggest using a serial PCMCIA card. Good success with that avenue aparently.

Didn't realise they made PCMCIA Serial port cards!! That could solve all the issues. I'll give it a try and report back. Hopefully this problem and its eventual solution will help other 'night hawks'.

Share this post


Link to post
Share on other sites

Many thanks to all those who offered support and help on this one. I can confidently report:

Problem Solved!!!

Solution: forget Serial-to-USB. Purchase a good quality Serial port PCMCIA card for an XP laptop. Hand controller updates, verifies and works like a dream! GEM Version 4.19 SORTED! :D:):p:);)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.