Jump to content

Banner.jpg.39bf5bb2e6bf87794d3e2a4b88f26f1b.jpg

gcasotti

New Members
  • Posts

    2
  • Joined

  • Last visited

Everything posted by gcasotti

  1. Hi guys, I answer by myself. Thanks to the owner of Nexstar Resource Site, I found that I am now limited to firmware 4.13 unless Celestron creates a newer German version (but then, I don't want German anyway). Celestron recently made the foreign language hand controls behave this way to support their international distributors. In this way, the international distributor knows if a telescope was imported without their involvement (and thus they received no profit) and they will not support it for warranty work. The only option for me is to purchase a new hand control from a dealer in the USA. I think this policy of Celestron it is not a good policy because it will prevent the sale of Celestron products in much of Europe (and maybe the World). Here in Europe, after introduction of the single currency (Euro), the online sales have increased considerably between European countries and a conservative policy is not a good business card. I hope that Celestron will reconsider their choices, allowing it to be possible to install at least the English language on all versions of Hand Controls. I think this is an important matter and international customers of Celestron products would become aware as soon as possible. Guglielmo
  2. Hi All, I live in Italy and last week I bought from a German seller a Celestron Nexstar 127 SLT. The Hand Control software was in German but I need English language so I tried to flash the Hand Control with latest English version 4.17 but after that I got an error message: "Invalid Language" and telescope was unusable. I browsed FAQs and Knowledge Base at Celestron's site and I found Article ID 2344: Can I upgrade my hand control firmware to the latest 4.17 or 4.18 versions (version depending on the mount) in a foreign language? No you can’t. Our latest hand control firmware versions 4.17 and 4.18 are only available in English versions as of February 2010. If you attempt to upgrade a foreign language hand control to one of these versions you will get an error message from the hand control and the scope won’t be usable. If this happens, contact your distributor to have service or replacement of your hand control. You can downgrade your hand control to version 4.13 in English. However, once you do this, you can’t upgrade the hand control to any foreign language version. So I flashed Hand Control with English version 4.13 and operation was successful; then I tried again to upgrade to English version 4.17 from English version 4.13, but I got the same error again! I wrote to Celestron Support and they answered me that unfortunately this is the only update that can be done in English as the Hand Control is programed for German. It will not upgrade any further. Anyone knows why there is this limitation??? I can understand that latest firmware release is only in English... but I don't understand why I can't flash it to whatever Hand Control, even if it was originally programmed in another language. Thank you, Guglielmo
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. By using this site, you agree to our Terms of Use.